Hidden SSID prompt never shows up

Hello Folks:
Brand new Vero 4K user, just received my unit today.
When configuring WiFi, the hidden SSID prompt never shows up on the screen.
Can’t find a way to enter my info manually.
The available WiFi networks are listed, so the adapter seems to working fine.

Any suggestions please?

You’d have to do it with a keyboard or command line.

We don’t recommend using a hidden SSID as it doesn’t provide any additional security.

OK thanks
Never seen a WiFi setup where you couldn’t config for ‘no broadcast ssid’

We should probably add support for it.

It’s very rare that a user has a hidden SSID, so it hasn’t come up often. Hiding your SSID isn’t a good idea.


Sam, found an easy way to get this done.
Turn on broadcast SSID on your modem/router.
Log onto your WiFi network using your Vero 4K.
Turn off broadcast SSID on router, Vero stays connected and retains info, even after power off.
Much easier than Ethernet or command mode methods if you’re just using WiFi on the Vero.

I like hiding the SSID from neighbours and the kids, one less piece of info to give them.
I know there are ways to find it, but why make it easier for them.


sorry to bump this tread again , but this seem still to be a issue, I am not able to see the hidden wifi service advertisement on the vero 4k unit, I am on a terminal session is there a “long way” work around to get this working for a wpa2 hidden ssid?

Kind Regards

Yes stop hidding your ssid as there is no logic behind doing that in the first instance.
Or y=use the method explained just above your post

This is at a corporate site and I am not the network administrator for this service.
There should be a simple command line “how to” to resolve this, I was able to do this with my pi 3 in the past via the my OSMC app and via terminal.
This feature should be simple to request to implement.

Thanks for you quick response @fzinken :slight_smile:

Here’s an attempt to connect to a hidden SSID using connmanctl:

osmc@osmc:~$ connmanctl
Error getting VPN connections: Unit connman-vpn.service not found.connmanctl> 
connmanctl> enable wifi
Enabled wifi
connmanctl> scan wifi
Scan completed for wifi
connmanctl> services
connmanctl> agent on
Agent registered
connmanctl> connect wifi_XXXXXXXXXXXX_hidden_managed_psk
Agent RequestInput wifi_XXXXXXXXXXXX_hidden_managed_psk
  Name = [ Type=string, Requirement=mandatory, Alternates=[ SSID ] ]
  SSID = [ Type=ssid, Requirement=alternate ]
  Passphrase = [ Type=psk, Requirement=mandatory ]
Hidden SSID name? 

I’ve left out the rest for obvious reasons, but I was able to connect using the hidden SSID name and passphrase.

Hi @dillthedog

connmanctl> services
does not list the “wifi_XXXXXXXXXXXX_hidden_managed_psk”
and this have me concerned, as I am currently connected on that SSID via my mobile right next to it.

connmanctl> services

*AR Wired ethernet_c44eac12976f_cable
*A VC-Mobile wifi_ccb8a8bad970_56432d4d6f62696c65_managed_none
VC-BYOD wifi_ccb8a8bad970_56432d42594f44_managed_none
VC-BYOD-MDM wifi_ccb8a8bad970_56432d42594f442d4d444d_managed_ieee8021x
VC-Corporate wifi_ccb8a8bad970_56432d436f72706f72617465_managed_ieee8021x
VC-Guest wifi_ccb8a8bad970_56432d4775657374_managed_none
VC-OPCO wifi_ccb8a8bad970_56432d4f50434f_managed_none
VF-Corporate wifi_ccb8a8bad970_56462d436f72706f72617465_managed_ieee8021x
Vodacom wifi_ccb8a8bad970_566f6461636f6d_managed_ieee8021x
DIRECT-fiJACQUESDEBEERmsB2 wifi_ccb8a8bad970_4449524543542d66694a4143515545534445424545526d734232_managed_psk
connmanctl> agent on

So how do I get that working on the Vero?
The Pi3 was able to list the hidden SSID… :worried:

You’re right, the Vero4K doesn’t seem to see the hidden SSID. I used my Pi3 for the example, since my Vero4K was in a poor location for WiFi reception. I hadn’t appreciated that they work differently.

I’d guess that it’s either a driver/firmware issue or perhaps something in one of the config files (/lib/firmware/nvram_43455c0.txt and /lib/firmware/config_43455c0.txt) might need a tweak.

I appreciate your confirmation, I was getting nervous that I was missing a key part here :smile: , and I will eagerly await a update on this matter here,
Just to confirm I am on OSMC April 2018 2018.04-1 built.

seems Debian is totally different beast to tackle than ubuntu, :wink:
Regards again

Could this assist with the reported behavior, seems like other forums say add ap_scan=2 to


bssid=<M.A.C. of Access Point>

And some more info on this,just not sure if it relevant this OS

AP scanning/selection

By default, wpa_supplicant requests driver to perform AP scanning and then

uses the scan results to select a suitable AP. Another alternative is to

allow the driver to take care of AP scanning and selection and use

wpa_supplicant just to process EAPOL frames based on IEEE 802.11 association

information from the driver.

1: wpa_supplicant initiates scanning and AP selection; if no APs matching to

the currently enabled networks are found, a new network (IBSS or AP mode

operation) may be initialized (if configured) (default)

0: driver takes care of scanning, AP selection, and IEEE 802.11 association

parameters (e.g., WPA IE generation); this mode can also be used with

non-WPA drivers when using IEEE 802.1X mode; do not try to associate with

APs (i.e., external program needs to control association). This mode must

also be used when using wired Ethernet drivers (including MACsec).

2: like 0, but associate with APs using security policy and SSID (but not

BSSID); this can be used, e.g., with ndiswrapper and NDIS drivers to

enable operation with hidden SSIDs and optimized roaming; in this mode,

the network blocks in the configuration file are tried one by one until

the driver reports successful association; each network block should have

explicit security policy (i.e., only one option in the lists) for

key_mgmt, pairwise, group, proto variables

Note: ap_scan=2 should not be used with the nl80211 driver interface (the

current Linux interface). ap_scan=1 is optimized work working with nl80211.

For finding networks using hidden SSID, scan_ssid=1 in the network block can

be used with nl80211.

When using IBSS or AP mode, ap_scan=2 mode can force the new network to be

created immediately regardless of scan results. ap_scan=1 mode will first try

to scan for existing networks and only if no matches with the enabled

networks are found, a new IBSS or AP mode network is created.


I am not able to test this for 2 days, maybe someone can trial this at their end on a vero 4k if the config could apply or manipulated for this scenario :thinking:


Unfortunately, ap_scan=2 doesn’t work. The only value that is accepted is 1.

My original guess that this is likely to be a driver/firmware issue still stands.

There are driver updates and new firmware from Broadcom.

I’ll look at integrating these. We tried before but got log spam and no perceived improvements. We weren’t aware of this issue then however, so it’s worth revisiting.

1 Like

@sam_nazarko, Any way I can assist with testing any option on the Vero 4k in this regard since the april -2 update did not seem te have any impact on this issue.

Kind regards

Hi — we will update the driver soon, which should help with this.


1 Like

Hi Guys,

This is the fix - to apply if urgent,

Login via the command line
Edit the file /etc/apt/sources.list
Add the following line: deb http://apt.osmc.tv stretch-devel main
Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
Your system should have have received the update.

– I believe this will be integrated with the next software release,
Thanks @sam_nazarko

1 Like