HifiBerry DAC+ Overlay not working OOTB

Hi,

Thanks for the update. Only one small bug report from me.
I have followed this guide, which has always worked before:

I have a HifiBerry DAC+. Since the v19, when my Pi3 is restarted it loses the connection to the dacplus+.

It is still selected in My OSMC under Hardware Support as the Overlay, but when I check in Settings/System/Audio Output the Audio Output Device is greyed out.

To fix this I have to go into the My OSMC/Pi Config/Config Editor and Open config-user.txt, and if I change the line:

dtoverlay=hifiberry-dacplus-overlay

to

dtoverlay=hifiberry-dacplus

and then reboot, everything works again and it is visible in the Audio Output Device, but the next time I reboot this becomes greyed out again and I need to perform the edit in config-user.txt and then reboot to get it working again.

Hope all of this information helps witha fix.
Many thanks.

1 Like

We will look in to this.

Similar issue for IQaudio. The config-user.txt shows
dtoverlay=iqaudio-dacplus-overlay,unmute_amp
Editing to remove -overlay restores sound until the second reboot.

Airplay is not working but this seems to be a Kodi issue.

Many thanks for the upgrade. Appreciated.

I’ve got the same problem with the same config (rpi3 + hifiberry)

So removing -overlay from config-user.txt didn’t solved your issue?

Raspiaudio.com audio+ board has the same problem and solution in case anyone is searching for this. (It looks the same as hifiberry dac to osmc).

While I’m happy to get it going again, I notice there is no longer an HDMI option under the audio output choices - just the Dac.

If you put the line “detoverlay=hifiberry-dacplus” in the /boot/config.txt file, it survives reboot. It looks like someone mixed up config.txt with config-user.txt as to which file should be overwritten.

1 Like

I’ve just tried it and it works! Thanks

At first I thought you had a typo there, but I can confirm that this works and survives a reboot.
If anybody happens to be using Raspotify, add
OPTIONS="--device hw:CARD=sndrpihifiberry,DEV=0"
to /etc/default/raspotify, otherwise it will play over HDMI regardless of your OSMC settings.

Oops! That was a typo. I meant dtoverlay=hifiberry-dacplus. I can’t imagine it working with the ‘e’ squeezed in there.

I get the same with hifiberry digi.
It doesn’t work at all even deleting overlay txt in osmc config.
When scrolling to audio tab I get a 10 second delay before it shows and output device is greyed out so can’t change it back to HDMI.
I get permission denied trying to edit /boot/config.txt using winscp.

Firstly - you should edit /boot/config-user.txt.

If you are having issues with permissions, just wait for the next update.

Sam

1 Like

Confirmed same issue on a fresh install today (with updates). Same solution of editing the /boot/config-user.txt file worked for me too remove the “-overlay” so only “dtoverlay=hifiberry-dacplus” remains. I did this by removing the sdcard from the raspberry pi 3B+ and editing the txt file on my laptop. You guys rock as I had gone through the GUI 20 times over before finding the solution here.

Hi kevingham,
many thanks for your hint. Last week my OSMC (Raspberry 3) fell silent after an update. All searches for solutions were unsuccessful at first, so that I even (unsuccessfully) carried out a new installation.
Today, I found your contribution and deleted the obsolete part “-overlay” … and immediately the audio output was reanimated.
I hope that the Hifiberry people will update their instructions