Hifiberry-dac stops working after upgrade - SOLVED

There is a problem with external sound card.
Right after upgrade my hifiberry DAC clone stops working.

>dmesg |grep snd
[ 12.488386] snd-hifiberry-dac soc:sound: ASoC: CPU DAI (null) not registered
[ 12.488424] snd-hifiberry-dac soc:sound: snd_soc_register_card() failed: -517
[ 14.041849] snd-hifiberry-dac soc:sound: ASoC: CPU DAI (null) not registered
[ 14.041875] snd-hifiberry-dac soc:sound: snd_soc_register_card() failed: -517
[ 14.098213] snd-hifiberry-dac soc:sound: ASoC: CPU DAI (null) not registered
[ 14.098242] snd-hifiberry-dac soc:sound: snd_soc_register_card() failed: -517
[ 14.121550] snd-hifiberry-dac soc:sound: ASoC: CODEC DAI pcm5102a-hifi not registered
[ 14.121590] snd-hifiberry-dac soc:sound: snd_soc_register_card() failed: -517
[ 14.193279] snd-hifiberry-dac soc:sound: ASoC: CODEC DAI pcm5102a-hifi not registered
[ 14.193321] snd-hifiberry-dac soc:sound: snd_soc_register_card() failed: -517

>cat /boot/config.txt |grep dt

>modprobe snd_soc_bcm2708
modprobe: FATAL: Module snd_soc_bcm2708 not found.

>aplay -l
aplay: device_list:268: no soundcards found…

>find /lib/modules/4.4.8-3-osmc/ -name *bcm2708.*

>tail /var/log/apt/history.log
Commandline: apt-get dist-upgrade
Install: rbp1-image-4.4.8-3-osmc:armhf (3, automatic)
Upgrade: armv6l-bluez-osmc:armhf (5.3.8-8, 5.3.9-1), wireless-firmware-osmc:armhf (1.1.0, 1.1.1), rbp-bootloader-osmc:armhf (1.2.6-1, 1.2.8-1), mediacenter-addon-osmc:armhf (3.0.611, 3.0.614), rbp1-mediacenter-osmc:armhf (16.0.0-13, 16.1.0-1), armv6l-libsqlite-osmc:armhf (,, base-files-osmc:armhf (1.9.1, 1.9.3), rbp1-kernel-osmc:armhf (2.5.8, 2.6.8), armv6l-libnfs-osmc:armhf (1.9.8-4, 1.10.0-1), rbp-userland-osmc:armhf (1.1.8-1, 1.2.0-1), armv6l-remote-osmc:armhf (1.1.9, 1.2.0)

You did not post the information I requested in my previous reply to you.

which clone?

We haven’t removed any kernel modules (you can verify this with diff), but if you see anything that seems amiss just let me know what we need to append in our kernel configuration.

I also just performed an upgraded after which my hifiberry DAC stoped working.

My logs are exactly the same as what pleha posted.

Any idea where to look for to debug this problem?

Same problem with Hifiberry-Dac.
In Settings -> System -> Audio Output Hifiberry-Dac is missing.

Provide logs via grab-logs -A

For reference, R Pi2 + HiFi Berry DAC+, updated to the May update with no issues:

dmesg |grep snd
[ 9.415960] snd-rpi-hifiberry-dacplus sound: pcm512x-hifi <-> 3f203000.i2s mapping ok

I did find that the patch I needed (proper single FLAC + cuesheet support, finally fixed!) from kodi 16.1Final wasn’t included - OSMC/May update seems to be based from an earlier release candidate

Same problem with hifiberry
logs http://paste.osmc.io/duviracume

also same problem with hifiberry
logs: http://paste.osmc.io/yisojiziko

Today I installed fresh 2016.04-1 version, and there is no problem with sound.
I also noticed, that 2016.04-1 version also doesnt have module snd_soc_bcm2708, so this was no issue.
After upgrading to May 2016.05-1 - sound dissapear.

Same here

Which HifiBerry has stopped working? I think they produce quite a few now.

Can you show me a photo?

I have the DAC+ Light it is not working after upgrade to


I have the HIFIberry Dac for Raspberry Pi A/B: https://www.hifiberry.com/dac

Same problem here with HiFiBerry DAC+ Light (RCA) on Pi2 B: http://paste.osmc.io/zoraqamove

All of the failing HifiBerry’s are using the same overlay - hifiberry-dac. I modified all of the soundcard overlays last week to allow dynamic loading and unloading, but in doing so I broke the hifiberry-dac version - sorry about that. I fixed it the next day, but @sam_nazarko was unlucky enough to get the bad one. You may be able to patch up your system by downloading this fixed version and overwriting your installed copy, otherwise I’m sure the next release will no longer have this problem.

It works again!. Thanks!

Works fine, thanks a lot

Where can I find the overlay in order to replace it?

Download the linked file and replace the one inside overlays directory (when inserting the sdcard into a windows machine).