Home key function changed


On my Vero 4K+, and as expected from https://kodi.wiki/view/Keyboard_controls, the Home key on my Logitech keyboard jumps to the top of the menu. However, on my Vero V, it jumps all the way back to the main menu. Using home to move to the top of the menu is in my muscle memory after 5 years on the 4K+, and this change is very jarring.

I could use some help in debugging this. The rest of this post is to show that as far as I can see, I have done nothing to cause this change in behaviour.

Except for the following two lines, /usr/share/kodi/system/keymaps/keyboard.xml is the same on both my Veros.





In both cases, I have copied /usr/share/kodi/system/keymaps/keyboard.xml to /home/osmc/.kodi/userdata/keymaps/custom.xml and added the line


to the <keyboard> section.

I take it that on your your Vero 4K+ you didn’t have the OSMC remote control dongle plugged in then. This mapping is coming from the special keymap for our remote with the point being that because the difference between back and previous window is quite minor, and the OSMC remote has a back button, I switched the home to just go to the home window as a more useful function. Because the Vero V has a dongle inserted internally this means, by default, the special keymap for the OSMC remote always loads. There are two different options to correct your issue. The first option would be to just disable the special keymap by going to settings>system>input>peripherals>OSMC RF Remote> and enable the option “Don’t use the custom keymap…”. The other option would be to add a keymap of your own overriding just the mappings for the home button. Information on how that would work can be found in the following thread…

Thank you for the quick reply.

1 Like