Horrible skin in osmc 17

You mean the visualisations from popcornmix? I think you just need to re-enable his repository in addons settings.

Tried that, getting a can’t connect error. Just having a look to see if anyone else is having issues now.

Enabling the repo works for me, so maybe provide debug logs after trying to reenable them.

by “enabling the repo” do you just mean getting the popcornmix repo zip and installing it or is there something else to be done? I have allowed unknown sources if that has any bearing.

It should still be installed. Go to installed in user addons and it should be greyed out.
Klick on it and choose enable.

Popcornmix Add-ons is showing as enabled in “My addons” (Version 1.0.0). Still don’t get any entry for visualisations under “Look and Feel”.

You need to enable the addons themselves. Not just the repository.

Go to settings -> addon browser -> install from repo -> Popcornmix add-ons and enable add ons from there.

I’m getting a can’t connect to repo error if I attempt to enter the Popcornmix addons repo.

I don’t believe there are any addons installed to enable at the moment.

The URLs look valid in our XML file which brings them in:

+<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
+<addon id="repository.popcornmix" name="Popcornmix Add-ons" version="1.0.0" provider-name="popcornmix">
+    <extension point="xbmc.addon.repository" name="Popcornmix Add-ons">
+               <info compressed="true">https://github.com/popcornmix/repository.popcornmix.storage/raw/master/addons.xml</info>
+               <checksum>https://github.com/popcornmix/repository.popcornmix.storage/raw/master/addons.xml.md5</checksum>
+               <datadir zip="true">https://raw.githubusercontent.com/popcornmix/repository.popcornmix.storage/master/</datadir>
+       </extension>
+       <extension point="xbmc.addon.metadata">
+               <summary>Popcornmix Add-ons</summary>
+               <summary lang="en">Popcornmix Add-ons</summary>
+               <description>Repository of add-ons by Popcornmix. Add-ons in alpha and beta status are here to test exclusively and for testers to provide them with upd$
+               <platform>all</platform>
+       </extension>

CC @popcornmix

Works ok from my side - I can connect to Popcornmix’s repo and download & enable both visualisation and screensaver.

Perhaps it is a temporary GitHub issue – this happens sometimes and is usually resolved quite promptly. You are probably being served from a different server than the affected user.

…and you’re using OSMC Krypton comp. Feb 7 2017?

Yep, latest Krypton 2017.02-2. But the problem could be, as Sam says, with github.

I couldn’t connect the other day either… I’ll look into it.

Start a new post with debug logs if you continue to have a problem

Weird. Now have access no problem. Must have been a git issue as suggested. One final thing before I get on with what I should actually be doing…

Does anyone know why 2D Spectrum doesn’t stay as the selected visualisation when switching in and out of full screen mode. Other ones I have tried seem unaffected by this issue. Have tried with/without background visualisation enabled in skin settings.

Hi all, as a 74 year old retired engineer and resistant to change, I also did not like the new skin–at first–but after one day of use found the new skin excellent. I have a dozen Raspberry PI units (8 RPI2’s & 4 RPI3’3) and have tried the new release on all the units and all work as expected. I also loaded the older Confluence Skin without issue on one unit.

I am having one issue in another area (Kodi 17 release for OSMC and for Linux OS) with the new release but that is for a different discussion–not a problem unique to OSMC but to all Kodi 17 versions.

As an engineer of almost 40 years mostly hardware design with software experience with DSP’s. FPGA’s, and microcontrollers–All I can say is that the team of engineers at OSMC has my greatest respect–do they make errors–yes, but they always seem to correct them. I will always give this team both my admiration and respect.



I went from OpenElec to OSMC for same reasons you want to leave.

For my point of view, OSMC is the better code quality, distro and the better project coordination.
And trust me, from time to time I’m tried / still trying OpenElec/libreElec and it’s still not acceptable by my family members. Most time I use libreElec for cross checking, if it’s an Kodi/OSMC or hardware issue. It was always the hardware or my mistake.

have a nice trip,
and if you are with computers since 1982, you should have heard about nettiquette. Team to read it once more again.