How to change Recording system path on Linux

I am new to OSMC and I am having problems retrieving my recordings.
I am running V17 and TVHeadend on a Raspberry Pi3 with a usb disc drive.
When I did the install it detected my USB drive and picked up the device name as a directory.
When accessed by the GUI or by the TVheadend web server (ip + port 9981) then it comes up as /media/WD 150G USB. Note that the name has spaces embedded in it!
So I can see my recordings in the web interface under “Finished Recordings” - so far so good.
However, if I log onto the RPi using SSH then I can’t access the directory “/media/WD 150G USB” because the bash shell won’t accept a space in a directory name.

So, two possible answers to get access.
1 Can I use the existing directory name by inserting maybe an escape character(s) round the spaces? or
2) Can I rename the diectory and not upset OSMC / TVHeadend / Samba? But of course I still need to be able to put the name “WD 150G USB” into the bash shell!

Any ideas?

cd “/media/WD 150G USB”

That worked - thanks.

Hmm - that shows up some old recordings (from a previous OSMC install) but not the ones I have done on my current build. Wonder if they have worked? Or where OSMC has put them?

Hi @BruceEmsworth, I have a little déjà vu seeing this topic. Wasn’t that you in Osmc recordings location ?

So, what have you inserted in the recording system path field that topic was about?


OK I think I have found my problem.
I have been following an OSMC guide written by Clive Webster and published in a Raspberry Pi Projects Book.
In following the guide I mounted my USB disk to /mnt/recordings as instructed.
When I ran OSMC the initial time I guess that worked properly and it recorded to /mnt/recordings which properly went to my USB drive.
However, I later rebooted the RPi and of course that “lost” the mount, so it recorded to the directory /mnt/recordings.

So when I went in to /mnt/recordings I could see my recent recordings but not the older ones. And when I went into /media/WD 150G USB I could see my older recordings.

OK, so now I have mount ed /dev/sda1 to /mnt/recordings and from an SSH session I copied one of my newer recordings to the USB drive and it shows up and it plays.

My problem seems to be that I had “lost” my mount. I will now try a new recording and check it ends up on the USB drive.
If that works, then I guess I edit my fstab and make the mount permanent.

Phew …

1 Like