How to connect with the right wifi adapter (out of 2)

I’ve had problems with the performance of the onboard Raspberry Pi 3 wireless adapter, so I plugged in a USB wireless adapter (that I’ve used in the past with RPi2).

The problem is that no matter if i select “[wifi name] (wlan0)” or “[wifi name] (wlan1)” in the list, the onboard adapter sets up the connection (usually wlan1).

How do I force the OSMC wifi manager to pick the right adapter to use?

You should disable the internal adapter to avoid interference

You can use connmanctl if you don’t want to do this.

Thanks. How do I disable it?

I’ve already tried using dtoverlay=pi3-disable-wifi in config.txt, but doing so I still end up with the two interfaces.

I’ve tried that too, to no avail. What’s a clean solution? :slight_smile:

That method is definitely working. Provide grab-logs -A for us to check whats going on

I’ll post logs when I get access to the machine.

Meanwhile I wonder though, if I have a NOOBS or PINN installation in front of OSMC, which one(s) of the config.txt needs the editing?

Always the one on the boot partition which should be a FAT partition labeled recovery