How to install my 'pi desktop debian package'

I own a Pi Desktop case from element14. To use the on/off button I need to install the package from their website: pidesktop-base-1.1.0.deb. While running Raspbian I can download and install this package using any browser.
This works and I can start-up and close-down my Raspbian with the on/off button on the case.
How can I install this file (pidesktop-base-1.1.0.deb) after installing OSMC on my RP3.
Using apt-get can’t find the package… How can I install this in OSMC
Thanks in advance for any help so I can use this nice glossy desktop case after installing OSMC.
Wout

Download the package using wget:

wget https://github.com/pi-desktop/deb-make/releases/download/v1.1.0/pidesktop-base-1.1.0.zip

Then unzip and nstall:

unzip pidesktop-base-1.1.0.zip
sudo dpkg -i pidesktop-base-1.1.0.deb

Thanks a lot, the installation works well.
Sorry for late reply, was at work for a couple of days. The on-off button on my pi-desktop is still not working after this installation. I have to figure out what else I have to install or comands I have to set.
Keep you posted via this chat if I succeed.

After some tests I am back to zero. I installed pi-desktop-base-1.1.0.deb on OSMC. (Thx dillthedog). But my Raspberry Pi3 which is build in the nice case (Pi Desktop) from element14 doesn’t react on the on/off power button. I should be able to switch of the RPi via OSMC software button and switch on again on hardware button.
In Raspbian it works. Why not on OSMC which uses the same type of software in the background. Someone an idea how to continue?

Just a guess, but it could be something in the kernel that has been compiled into Raspbian but not into OSMC. Perhaps @sam_nazarko might have an idea and it wouldn’t hurt asking the people at element14.

There is also a gpio utility that might be of use in determining the state of the GPIO pins, which could be of use. See [SOLVED] RPI.GPIO won't work after fresh install - #3 by dillthedog

Hi,

I have the same case:
http://de.farnell.com/element14/pi-desktop/element-14-pi-desktop-hatencl/dp/2687142

After downloading and unzipping the package Pi Desktop Debian Package v1.1.0 , I installed it with sudo dpkg –i pidesktop-base.deb

…and the Power On/Of-Button works fine with OSMC :slight_smile:

Therefore, I think the your issue with this case must be somewhere else, maybe when mounting the Add-On board…

1 Like

Thanks for your help. I started from scratch and installed OSCM July 2017-1
then downloaded, unzipped and installed. According to terminal all succesful.
But no difference with or without pidesktop-base.deb.
If I close from OSMC, it shuts down but red power-led on rpi and blue power led on pi-desktop case stays on.
I need a 5 second hold-power button to shut down and all leds light out.
Now I can power on with power button on pi-desktop.
Does yours work in the same way, than yes, mine is working. But I expected a complete power shut down without holding a button for 5 seconds.
I’m interested in your experance. Thanks in advance for reply.
Wout

I too was having the same issue but just got it fixed. The problem is that there appears to be a package missing, from OSMC, that is needed to get the GPIO pins working. That package, raspberry-gpio-python, can be downloaded from the following link: https://sourceforge.net/projects/raspberry-gpio-python/ Scroll down to near the bottom of the page and download this package: /raspbian stretch/python-rpi.gpio_0.6.3~stretch-1_armhf.deb
I put it on a flash drive, which I had labeled 8GB-USB. I inserted the flash drive into the Raspberry Pi 3 and connected to it via SSH. (osmc is the default ID and Password) From there I ran the following: sudo dpkg -i /media/8GB-USB/python-rpi.gpio_0.6.3~stretch-1_armhf.deb
After a reboot, the button on the Pi Desktop started working as it was intended. I did already have the Pi Desktop Debian Package v1.1.0 loaded. If you install the GPIO package first, you’ll still need to install the Pi Desktop Debian Package and reboot.
The only minor issue that I noticed, when shutting down using the power button in Kodi, is that the Pi Desktop power light flashes for about 30 seconds or so before the full power down. Not a big deal, for me, now that things are working.

That file is possibly ok but is built for Debian stretch.

The correct file for Debian jessie is http://archive.raspberrypi.org/debian/pool/main/r/rpi.gpio/python-rpi.gpio_0.6.3~jessie-1_armhf.deb

The package comes as standard with Raspbian, but is not available in the Debian repo that OSMC uses.

You can install it via pip (recommended)

Thank you very much. Great job / good advice from Lennyb81 and thanks for pointing to the correct file dillthedog.
sam_nazarko, your comment is realy appriciated but I’m the kind of newbee who has no clue how to use pip. I will google on that unless you know where to find more.
For now, I’m very happy with my working Pi Desktop element14, running OSMC.

Hi. I have just read this conversation, and I wonder, how I can install osmc on the msata ssd, what you can mount into element14 pidesktop expansion board? I have a Pi3 B+. I have just installed osmc on the ssd, but osmc said during first startup, that bootfs is missing or someting. Sorry I am noob, but I can use any good advice. THX!

You can probably do this by selecting the USB install option in OSMC installer. You’d still need an SD card for the boot files however.

Can you provide me with a description’s link, to know exactly what files needed, with what content?
I put the boot files from the msata to a sd card, but install stopped with “Install failed: can’t mount root” message. Or you mean, I should use the NOOBS image to install OSMC, and there I will find a “USB install” option?

Use the OSMC installer from osmc.tv/download.
Select USB install; insert your SD card.

Image the SD card and the installer takes care of the rest for you

Thank you! Finaly I realized, that I did not used the installer! Sorry I used osmc more years ago, I just used etcher to make imaging, the drive. I tried OSMC installer, but unfortunately my msata to usb don’t appear in usb intall menu as drive. Is it possible to image a usb pendrive and than migrate content to msata?

You’re not meant to install OSMC using the installer to the mSATA. Please read above more carefully. It needs to go on the SD card. The SD card will then configure your hard drive.

Ok, than my understanding is, that I don’t need to select usb install, just need to use SD card install in OSMC installer. But in this case I don’t understand the point of this sentence above “Select USB install; insert your SD card.” That is why I tried to use usb install.

Because you are selecting where you want the final OSMC installation to go on; not the medium you are installing it with.

Now this is simple and clear. I’ll try it. Thank You! Sorry for noob questions.
Nice support!