How to play SNES Game with Snes9x?

I am trying to play an SNES ROM Game on my Vero 4K +, running OSMC 2020.10-1 with Kodi 18.8.

I have plugged in a USB controller and configured it according to the popup window that appeared.

I have enabled the Snes9x plugin at: “Home -> Settings -> Add-on browser -> My add-ons -> Game add-ons -> Emulators -> Nintendo - SNES / SFC (Snes9x - Current).

But “Home -> Games -> Game add-ons” is empty.

And “Home -> Games -> /path/to/rom” gives this error:

Add-on is incompatible due to unmet dependencies.
Missing: game.controller.snes.mouse, game.controller.snes.multitap, game.controller.snes.super.scope, game.controller.konami.justifier.snes

Which steps am I missing to be able to play an SNES ROM?

install the controller profiles needed to begin with,

setting -> add-on browser -> My add-ons -> Game add-ons -> controller profiles

i’ve installed them all to not have this issue if i wanna try another emulator

The first thing I did was configure the controller.

“Home -> Settings -> Add-on browser -> My add-ons -> Game add-ons -> Controller Profiles” has:

  • Default Controller: Enabled
  • SNES Controller: Enabled

The controller is not my issue. How do launch the game from the ROM?

Been a while since I tried emulation in kodi, but I think it was among others snes9x that needed the roms in zips. There is an old thread on this forum, where there instructions to release zip files from kodi internal unzipper,and you can’t have archive-addon enabled either. I’ll search for the thread and post a link here once I’ve started the laundry machines in the neighborhoods common laundry room, in the neighbouring house.

There you get more information

The ZIP file format is also not the issue.

“Home -> Games -> /path/to/rom” easily opens the ZIP-file and displays the containing SFC-file. But when I try to open the SFC-file, I get the error I quoted.

I also tried unzipping the ZIP externally and putting the SFC-file directly into the folder. But opening that, again, gives the same error.

Thanks for the link to Retroplayer (Emulators list), but I cannot find the answer to my question there. How do I play the ROM with Snes9x?

Shouldn’t “Home -> Games -> Game add-ons” have content and browse through either Emulators, Contoles or Games? But it’s empty.

You have to install ALL SNES controller profiles, even if you don’t use them, it is a requirement of the SNES-game addon you have chosen. That’s why I said

Next step, Under mainmenu Games
chose “Add games…”
Chose Browse… Navigate to the folder containing SNES-roms, name the media-source you are creating to SNES.

next time you wanna play a SNES game just go Games->SNES and chose your rom

That’s a place reserved for Game-addons that have their own navigation interface, like DosBox, Scummvm and 2048…

How do I add more SNES Controllers?

“Home -> Settings -> Add-on browser -> My add-ons -> Game add-ons -> Controller Profiles” only has “Default Controller” and “SNES Controller” (both are enabled).

How do I install the others?

Home -> Settings -> Add-on browser -> Install from repository

Yes, installing the four controllers (snes.mouse, snes.multitap, snes.super.scope, konami.justifier.snes) worked. Now opening the SFC (or ZIP) starts the ROM with Snes9x.

I should have taken the error message more seriously. But I somehow expected Snes9x to not pe set-up properly, because I assumed either Snes9x or the ROMs would show up under “Home -> Games -> Game add-ons”.

Thank you!