How to play SNES on Kodi 19?

I only have one Vero and one Kodi - the OSMC on my Vero. I did not install another Kodi on another hardware to test what they say in their Wiki.

Is there an “official” way to install Snes9x on OSMC 19?

Kodi Wiki sais Settings → Add-ons → Install from repository → Nintendo - SNES / Famicom (Snes9x) → Install. But as described, this does not work on my OSMC.

Then I believe we are in alignment with Kodi regarding which binary add-ons we make available. I’ll check on Windows when I get a chance.

Any additional binary add-ons would need building from source.

I know @joakim_s is looking at the possibility to add more add-ons. We would probably need to re-think the approach for how we distribute additional game cores. Likely something to think about after Kodi v20.

Until then, what’s the “official” way to install Snes9x on OSMC 19?

You would need to compile the add-on from source. There isn’t an official way, because it isn’t an official Kodi add-on (from what I can see).

@sam_nazarko: Do you have a Kodi 19 to test?

Why does their Wiki say install it via Settings → Add-ons → Install from repository → Nintendo - SNES / Famicom (Snes9x) → Install and say nothing about adding a repo, let alone compiling anything from source?

I don’t know. I don’t maintain the Kodi Wiki. All I am saying is that, currently:

  • We only ship the same binary add-ons that Kodi does with their releases, when supported on Linux
  • Their (Kodi) GitHub repository which is used as a reference for building these add-ons does not include the SNES9X add-on, and therefore we do not build it.
  • If you wish to use it, at this point in time, you will need to build it from source.

Hopefully this clears things up.

Okay. Thanks for your help.

One last OSMC question: Why did OSMC 18 build and ship Snes9x?

If OSMC 19 doesn’t because Kodi 19 doesn’t, then I don’t understand why OSMC 18 did when Kodi 18 didn’t?

Because the add-on worked then and there were fewer game emulators. Now the game emulators have gone back to a downstream state and many are broken.

So the decision was made to ship what is officially supported and what officially works. If Kodi re-introduced that add-on in to the binary addon repository tomorrow, we would be building it and including it.

Build from source, like Sam says. It’s a steep knowledge climb, but doable. I have done it multiple times.

Or use the “build-bot”-armhf-repo that Zack is offering up, so far those I’ve tried (2) of Zacks prebuilt binary have worked as expected.

Sure they are built for “Pi” mostly, no optimization for “non Pi things” like the Vere4k. Which an “official OSMC” package would most likely have, which I was aiming at with my “exploration of kodi-game binary.repo” for Vero4k. But Zacks automated work isn’t bad at all. Tempted to actually look in behind the scenes =)

@ilf I will try tonight to write a less then ten lines, stepp by stepp to get your Vero playing Snes (to begin with :wink:)

Thanks! <3

@ilf, here you go. These instructions is on a totally newly installed vero4k+, with Debian11 testing, Hope they are clear enough (English not being my native language):

> cd /home/osmc && mkdir addons && cd addons && wget
> systemctl stop mediacenter
> sqlite3 /home/osmc/.kodi/userdata/Database/Addons33.db "UPDATE installed SET enabled = 1  WHERE addonID = 'game.libretro'"
> systemctl start mediacenter

In Kodi:

  • Settings->Addon browser->Install from zip
    Unknown sources “Tick it”
  • Settings->Addon browser->Install from zip
    Browse to homefolder/addons
  • Settings->Addon browser->Install from repository
    Kodi build bot…
    Game addons
    Nintrendo * Snes9x(current)

Back to main menu

  • Games
    add games
    browse to your snes-rom folder

Reboot your vero4k and go to Games, your added snes source and just try to click a rom =)

Hope this worked for you, that last Reboot drove me crazy. Good Luck

1 Like

@joakim_s Thanks, this works!

1 Like