[HOW-TO ] retrOSMCmk2: a RetroPie installer on the Vero4K

No conflicting file, but I renamed the .cfg forcing ES to generate a new one, which has resolved the ES settings menu issue. Comparing side by side, and it appears that the .cfg wasn’t working due to me setting the Kiosk value to “full” when it should have been “Full” with a capital F. Schoolboy error.

Will tackle the Retropie issue this evening.

I followed your guidance to a tee, but I’m still having the same issue. All of the emulators are working, but all Retropie options (from ES menu) are not loading (black screen, “rp module not defined” on screen and back to menu).

I had a look in the folders and I can see .rp files for all the menu options in the “RetroPie/retropiemenu” folder, but not able to run any of them from the menu itself.

Manage RetroPie from the retrOSMCmk2 menu is still just looping back to the same menu screen. No options available to Update dependencies/emulators etc. Have updated what I can from the script.

See image below … where I mentioned in my previous post about RetroPie installation hanging, this is what I see. Some mention of ‘virtualgamepad’ old code removal, which I see was added to the git just a few days ago … and then no further.

Curious. I’m trying to reproduce this here. I shall let you know.

1 Like

Hey Mr Shark

I’ve been thinking recently about getting a SindenLightgun and I was wondering if this would be compatible with “retrosmcmk2”?

I’ve been looking at the documentation and it appears that the support requires specifically modified emulators to be installed from his repo, either:

OR:

(Not entirely sure which one you should use when the emulator exists on both)

And for overlays to be added to retroarch. Im pretty sure most of the setup should be compatible but I dont know what specific changes have been made to the binaries/source for “retrosmcmk2” and whether or not any emulators compiled from the lightgun repos would still work on Vero.

So can you tell me if I were to follow the setup instructions would this actually work on the Vero4k?

And/or any chance you could add the sinden lightgun support to your binaries, where this has already been added for a specific emulator?

Here is the pdf from the sinden lightgun driver software if you are curious:

https://filebin.net/boo88vaczhenx6q7/SindenLightgunDocumentationV1.03_Linux.pdf?t=yc4hfg8u

Hi guys
retropie is working on my vero4k but I have problem with xbox controller when I want wireless connection.

I found this solution on many forums but still doesnt work
echo ‘options bluetooth disable_ertm=Y’ | sudo tee -a /etc/modprobe.d/bluetooth.conf

Please help …

I’ve already figured it out :slight_smile:
Need to switch to 4.9 kernel

then disable_ertm=Y and xbox controller connect wireless

I’ve tried to break it in the same way, but I just can’t reproduce the problem,
When you try to launch one of the RetroPie menu options are any errors logged under /dev/shm/runcommand?

Sorry for such a lengthy delay getting back to you. I’m still no further forward. I tried manually deleting/renaming all RetroPie folders that I could find to see if that forced a different result, while preserving ROMS, BIOS and Emulators etc.

Exact same experience on installation. It hangs before getting to the stage where I can configure the setup/install the cores.

I also seem to have completely lost the RetroPie menu from ES (probably through deleting it as above, and it now not finishing the install).

Couple of videos that show the installation process, and the post-install menu that’s missing the configure option, but I don’t imagine it’ll enlighten you any further.

Installation: Imgur: The magic of the Internet
Menus: Imgur: The magic of the Internet

Is there a way to fully purge every file/config/folder that’s been installed to date, so it is truly a fresh install (without having to fully reinstall the Vero)?

Thanks again for your assistance

Not much to see there in the vids, but clearly something is stalling (how did you make those by the way?).

Try editing setup.sh to look like this at the top:

#!/bin/bash
                                                                                                                                                                                                                   
exec 5> debug_output.txt
BASH_XTRACEFD="5"
PS4='$LINENO: '
set -x

Run the install. Then after it fails upload the resulting log file to the OSMC paste bin (will be a bit big to be posting on here).
Then delete the log file and try running RetroPie-Setup from the menu. Upload again.

Share the links to the pastes and I’ll have a look at those.

And did you say that retrOSMCmk2/submodule contains a full RetroPie-Setup directory structure after the install is completed? Try going in there and running retropie_setup.sh directly to see if that works.

1 Like

I used Termius app on iPad and screen record function. I don’t have a laptop at home, so the app works well.

Thanks for the additional guidance. I’ll update again as soon as I get chance to test.

First of all: big fat kudos to you @hissingshark for one of the most awesome additions to the OSMC ecosystem :partying_face:

Deploying retrOSMCmk2 was like a breeze and I only have one issue that’s probably related to SDL/KMS/drm or the like, which is the reason I’d like to ask here before I move things upstream: when Amiberry gets launched the display stays dark (after the RetroPie launch window). I can tell that the game (WHDload) gets loaded successfully as audio works just fine (so this shouldn’t be a kickstart issue), I just don’t get any video output. The Amiberry config menu can also be used/displayed normally.

Note that all libretro cores I tried so far worked flawlessly, so this shouldn’t be a general rendering issue. I also made sure all packages are up2date. I even reinstalled retrOSMCmk2 to make sure the (custom?) SDL libraries are also in place. Still no video output with Amiberry.

Unfortunately I couldn’t find any useful log output, eg. errors or failures in /opt/retropie/configs/amiga/amiberry/whdboot/save-data/Debugs or /dev/shm/runcommand.log /opt/retropie/emulators/amiberry/amiberry.log (needed to enable logging).

Any idea?

Hi,
Sorry for the delayed response. Crazy times.

I have reproduced the issue here. I’ve not run Amiberry for a long time, so I couldn’t say when this began. I’d need to compile some builds from older sources to try and determine what has triggered this, but that will take time. It may be an environment issue. Are you on the standard 3.14 kernel or testing 4.9?

Sorry for the delayed response. Crazy times.

So true. No worries!

I have reproduced the issue here.

That’s good.

Are you on the standard 3.14 kernel or testing 4.9?

Still on stable.

I had opened an issue in the meantime. We should probably continue there to keep this thread as concise as possible.

Cheers!

I have reproduced the issue here.

Just wanted to check back again. Could make any progress on this? Any way I might help?

Thanks!

Not yet. It’s similar but not identical to an issue when I first ported PPSSPP here.
Presently I’m building older versions to determine when things changed.

Ok, glad to hear you’re still at it. Highly appreciated as it would be great to see the essential Amiberry working.

Cheers!

It seems to be an upstream issue. There’s something ongoing that has been reported for the RPi which sounds similar enough. They froze at v3.3 on RetroPie because of it. I’ve had to go back to v3.1.3.1 for us.
I’m having issues updating the download, but I’ll report back when it’s done.

Do you mean upstream RetroPie or Amiberry? Any link to the issue in question?

FYI, I just received an update popup for retrOSMCmk2 and installed it. Quickly checked Amiberry and it’s (still) at 3.3. Guess the update was unrelated then.

Cheers

It’s an issue with Amiberry. So RetroPie have frozen at a last good version. Ours seems to be an earlier one. I don’t have a link. I just searched their forums for the issue you’d described.

When the new binary is available you’ll just need to update Amiberry from RetroPie. Although it’s an older version its a newer build, so it’ll download. As I said, I’ll let you know when it is available.

The update you installed was for the addon itself and it read

URGENT: Prepare for Python 2 to 3 migration

That is because Kodi 19 will break the addon as it moves us onto newer python. There will be an update on the day of release, BUT users won’t get that update if the addon is already broken by the newer python version… The update protects against that deadlock and they’ll only have to reboot to fix it.

Thanks for the details. Sorry, completely forgot about the update’s message in the meantime - duh!

Cheers