[HOW-TO ] retrOSMCmk2: a RetroPie installer on the Vero4K

I don’t have a 4K+ to comment. I tried a few titles on the 4K when I first started. Some had slow downs as you’d imagine, but they were playable. Others didn’t work at all - which may have been the nature of Reicast or my ROMs. It’s a tricky area Dreamcast emulation.

I never found anything that was completely without performance impact.
For that reason it’s not something I pursued as it wasn’t that important to me personally. These SBCs don’t need to be given more overhead!
But please let us know if you encounter a tolerable setting. It will be of use to someone I’m sure.

1 Like

Thanks. I have retroarch on my Switch and just wondered if this would give me better access to any other cores

Perhaps not the best place to post this but I’ve found that with a series X controller, the guide (logo) button and share button are not found when setting up the controller in retropie.

@hissingshark, do you have anything to do with the retropie platform itself?

I’m afraid not.
I contributed to the platform recognition on Vero4k and some build issues, but I’m not one of their developers. Most of my time has been spent on the installer and add-on here.

1 Like


I’ve just moved from a Pi3 to a Pi4. Tried to redo my setup. I got past the public key issue. But there seems to be an issue with AGS in Optional Emulators. So if you hit install all, it gets to AGS then they all fail.

RetroPie-Setup version: 4.7.19 (04a74980)
System: rpi4 (aarch64) - Debian GNU/Linux 10 (buster) - Linux osmc 5.10.32-1-osmc #1 SMP PREEMPT Wed Apr 28 05:45:57 UTC 2021 aarch64 GNU/Linux

= = = = = = = = = = = = = = = = = = = = =
Installing dependencies for 'ags' : Adventure Game Studio - Adventure game engine
= = = = = = = = = = = = = = = = = = = = =

Did not find needed dependencies: libaldmb1-dev. Trying to install them now.
Hit:1 http://security.debian.org buster/updates InRelease
Hit:2 http://ftp.debian.org/debian buster InRelease
Hit:3 http://ftp.debian.org/debian buster-updates InRelease
Hit:4 http://ftp.fau.de/osmc/osmc/apt buster InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
libaldmb1-dev is already the newest version (1:0.9.3-6+b3).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libaldmb1-dev : Depends: libdumb1-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
Could not install package(s): libaldmb1-dev.

osmc@osmc:~/retrOSMCmk2$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 37 not upgraded.
54 not fully installed or removed.
Need to get 0 B/93.0 kB of archives.
After this operation, 236 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 70566 files and directories currently installed.)
Preparing to unpack .../libdumb1-dev_1%3a0.9.3-6+b3_armhf.deb ...
Unpacking libdumb1-dev:armhf (1:0.9.3-6+b3) ...
dpkg: error processing archive /var/cache/apt/archives/libdumb1-dev_1%3a0.9.3-6+b3_armhf.deb (--unpack):
 trying to overwrite '/usr/include/dumb.h', which is also in package rbp4-mediacenter-osmc 19.1.0-14
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I don’t know if this is an upstream thing or a conflict with OSMC but thought I would drop it in here in case anyone knows a fix.

That’s odd…

Can you try updating again (there’s a new rbp4-mediacenter-osmc) available and seeing if that persists?


Exactly the same unfortunately.

Just to double check. rbp4-mediacenter-osmc 19.3.0-7 is the latest?

Yes, that’s the latest version.

I’m looking in to this.

Hows everyone elses experiences been on the Pi4?

Got mine up and working apart from the aforementioned but the Es menu is slow. Like even in the ES configuration menus it’s slower than the Pi3 it’s replacing.

Edit: Realised why it seems so sluggy in the menu. It’s maxing out the cpu and topping out at 6fps

Same here. ES Menu is laggy slow but everything works so far.

Is there a way to change the resolution of ES Menu on Pi4? Maybe this would be the solution.

The new video drivers are considered experimental by RetroPie at the moment. So it’s likely related to that.
On the Vero4k there’s a launch resolution option, but not on the RPi. I’m not convinced it would make a difference as it shouldn’t be taxing at any resolution.

So basically a case of waiting until RP catch up then?

That’s my understanding, yes.

1 Like

Hi all,

I would like to try this out on my Vero 4K+ and had a question on controllers. I want to get a “budget” bluetooth controller that will work on the Vero and with retrOSMCmk2 and wondered if some kind soul could give me a top 5 “known to be working” list. I am looking at the £15 mark.

Already installed retrOSMCmk2 so I could have a peek at the games etc. but I am getting stuck at the first hurdle where it asks to map a controller (I only have CEC controls and the original Vero remote at the moment).

Also, while I am getting one, is there a way to get past the remote issue temporarily so I can load some games and see if it “is for me” or not?

Thanks all.

Connect a USB keyboard and map that to the keys.

1 Like

Thanks fzinken

any suggestions for a budget controller that works (bluetooth)

The keyboard is a great suggestion as most games won’t need an analogue stick.

Personally I use a Gioteck VX2. That uses a USB dongle though. Were you hoping to use the built in Bluetooth on the Vero?

You’re absolutely right - thanks to all.
I will simply use the keyboard - it does the job just fine :slight_smile: