[HOW-TO ] retrOSMCmk2: a RetroPie installer on the Vero4K

Well most should work, I have Xiaomi Game Controller Bluetooth MDZ-11-AA that worked.


I’ll preface this by saying I am a Linux noob, so I don’t doubt that I probably f’d up somewhere.

I’m trying to use your excellent tool to install a few emulators on my pi 4 running OSMC

I keep running into the same failed signature check errors as Cillit, gpg errors above.

I’m installing via ssh, on a clean osmc install, with mediacenter stopped. I’ve tried multiple times with similar results.

I don’t get the option to Install/Update all core packages from binary, as I follow the instructions in the 1st post.
When I choose Install all core packages, it runs through until the errors.

This is the 1st to pop up

followed by

Here’s the log from my last attempt. retrOSMCmk2_1 - Pastebin.com

Can someone point me toward where I’m going wrong please? Any help will be much appreciated

Thanks in advance, Pete.

This was a problem a year ago and maybe has been since. Unfortunately I don’t have an RPi4 to support it or debug the problems.

What is apparent is the GL drivers are a problem. RetroPie themselves don’t consider the GL drivers supported on RPi4 yet. So I’m afraid fixing the gpg issue is moot at this time.

1 Like

OK, totally understandable. Cheers!

I have the same issue as him. He doesn’t seem related to the GL drivers. I have an RPI3.

But it seems I am not allowed to dl some library because of the signature retrOSMCmk2/setup.sh at 1c1a7e054c8594a09ef59a7f4e2cd5ff21e4a94b · hissingshark/retrOSMCmk2 · GitHub


Interesting. I’ll have a look into on the RPi3. I take it this is a fresh install, or recently updated?

It’s a fresh install. I Have installed latest OSMC (Kodi 19.4 Matrix). Everything works fine on this side, using it since months.

And when I run your installer I got this.

This was a change in RetroPie. I’d already lined up a fix for it on the Vero4K, but forgotten I have to provide all of the RPi2/3 binaries these days (OSMC now uses the GL drivers and RetroPie don’t support them yet). I’d like to test it on my RPi3 this week before I push it out.

I tried this afternoon to disable the GL driver, but yes was surprised that it wasn’t booting without it. OSMC starts and then it blocks with a sad emoji :slightly_frowning_face:.

I will wait for your fix then :slight_smile:

I’ve not been able to reproduce this issue.

On an existing installation I re-installed SDL2 and each of the Core items from binary.

Then in case it was environmental, I did a clean install of OSMC and retrOSMCmk2, then re-installed all of those without generating your gpg error.

Ok then I am gonna re-install it again from 0. May be I touched something.

Ok fine on my side. May be I did something wrong during the osmc configuration or whatever the first time.

New here. Got a fresh install of newest OSMC working (Kodi Matrix v19) on Raspberry PI 4. Want to get Retropie, but am reading oldish messages about retrosmc script not working on OSCMatrix/pi4 systems, with move to Python3.

Saw hissingshark created retrOSMCmk2 to address issues:https://github.com/hissingshark/retrOSMCmk2

But that hasn’t been updated if I’m reading correctly since 8/29/2021, but in the interim I see some complaints of only being able to run Retropie off CLI and launcher not working, and even then, prohibitively laggy.

Is that still the case or is retrOSMCmk2 largely working?

Not even sure if this is the right thread to post or this one:

As much as I hate crossposting, will put this post there, too.

1 Like

Just trying to install this onto vero4k+
It fails for me

Latest Nov update

1 Like

EDIT: While writing this out I actually decided to do a more generic google search and found this linux - mkfifo with all permissions still errors with permissions denied for other user - Unix & Linux Stack Exchange which worked!

Just going to leave the original message I wrote in case it helps anyone out. @J0k3r hopefully this would solve your issue.

I’ve managed to install and added the addon in OSMC. But when I try to use it nothing happens, and then if I try to exit OSMC after trying to run the addon it freezes and I have to SSH on to reboot. If I select reboot in OSMC it works fine

Looking at the logs I see these

Sep 25 02:11:40 osmc app-switcher.sh[662]: ls: cannot access '/home/osmc/.config/pulse/*-runtime/native': No such file or directory
Sep 25 02:11:40 osmc app-switcher.sh[257]: /home/osmc/RetroPie/scripts/app-switcher.sh: line 177: /tmp/app-switcher.fifo: Permission denied

Looking at the app-switcher.sh file itself comments imply the first one should only be relevant if pulseserveraudio is running. As for the second one I got this error also the same as @J0k3r above when installing. But I was able to progress past the error when I ran it again.


There have been some issues on RPi4 that I could not fix because I don’t have one to test.

This project was intended for the Vero4k, which at that point had no gaming support at all. It continues to work. I’ve slowly worked on some improvements for my own interest in the background - but there’s been nothing to actually fix since we moved to Python 3, hence no updates.

I expanded support to Rpi3 as I had one to test. The laggy RPi issues are due to the GL drivers that have been adopted for the platform’s primary purpose of being a mediacenter. I cannot get around that. When RetroPie officially support them we will be able to move forward.

1 Like

I’ll have a look at this when I can. It’s working on my existing and updated installation.
But that looks to be a permission issue for new installations.

1 Like

Thanx yeah its new device vero4k+

Im going to revert to old FW try install as normal then update as i did upgrade FW DAY1 first

Thanks also to dude above for links ill read em after reinstall

reflashed back to March , reinstalls fine no issues. Hopefully upgrade to l8st FW September will stick

Update after updating osmc it broke again :upside_down_face:

Anyone able took at installer for latest November update please


Hi, I seem to have the same problem as J0k3r above, did you have a chance to look into this issue?

I have a vero 4k+, unfortunately exactly the same problem I had before has reappeared after reinstalling OSMC, so the reinstall hasn’t helped.

I’m using OSMC as a file and media server, not sure if there could be any conflicts with retrOSMCmk2.

1 Like

NB - I have managed to run the installation after following the advice above by FazF, although creating the config file needed a login as root.