[HOW-TO ] retrOSMCmk2: a RetroPie installer on the Vero4K

Well most should work, I have Xiaomi Game Controller Bluetooth MDZ-11-AA that worked.

Hi,

I’ll preface this by saying I am a Linux noob, so I don’t doubt that I probably f’d up somewhere.

I’m trying to use your excellent tool to install a few emulators on my pi 4 running OSMC

I keep running into the same failed signature check errors as Cillit, gpg errors above.

I’m installing via ssh, on a clean osmc install, with mediacenter stopped. I’ve tried multiple times with similar results.

I don’t get the option to Install/Update all core packages from binary, as I follow the instructions in the 1st post.
When I choose Install all core packages, it runs through until the errors.

This is the 1st to pop up

followed by

Here’s the log from my last attempt. retrOSMCmk2_1 - Pastebin.com

Can someone point me toward where I’m going wrong please? Any help will be much appreciated

Thanks in advance, Pete.

This was a problem a year ago and maybe has been since. Unfortunately I don’t have an RPi4 to support it or debug the problems.

What is apparent is the GL drivers are a problem. RetroPie themselves don’t consider the GL drivers supported on RPi4 yet. So I’m afraid fixing the gpg issue is moot at this time.

1 Like

OK, totally understandable. Cheers!

I have the same issue as him. He doesn’t seem related to the GL drivers. I have an RPI3.

But it seems I am not allowed to dl some library because of the signature retrOSMCmk2/setup.sh at 1c1a7e054c8594a09ef59a7f4e2cd5ff21e4a94b · hissingshark/retrOSMCmk2 · GitHub

image

Interesting. I’ll have a look into on the RPi3. I take it this is a fresh install, or recently updated?

It’s a fresh install. I Have installed latest OSMC (Kodi 19.4 Matrix). Everything works fine on this side, using it since months.

And when I run your installer I got this.

This was a change in RetroPie. I’d already lined up a fix for it on the Vero4K, but forgotten I have to provide all of the RPi2/3 binaries these days (OSMC now uses the GL drivers and RetroPie don’t support them yet). I’d like to test it on my RPi3 this week before I push it out.

I tried this afternoon to disable the GL driver, but yes was surprised that it wasn’t booting without it. OSMC starts and then it blocks with a sad emoji :slightly_frowning_face:.

I will wait for your fix then :slight_smile:

I’ve not been able to reproduce this issue.

On an existing installation I re-installed SDL2 and each of the Core items from binary.

Then in case it was environmental, I did a clean install of OSMC and retrOSMCmk2, then re-installed all of those without generating your gpg error.

Ok then I am gonna re-install it again from 0. May be I touched something.

Ok fine on my side. May be I did something wrong during the osmc configuration or whatever the first time.