[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC

Thank you so much, RJ45! Retrosmc is back in action.

1 Like


I also have retropie installed and could try one or the other emulator. :slight_smile: Many thanks for the work and time invested here.

I wanted to test the package Steamlink (under Experimental) in Retropie. Unfortunately, the installation does not work. Has anyone tried or knows what it fails?

Log started at: Di 23. Apr 15:51:54 CEST 2019

RetroPie-Setup version: 4.4.12 (d35e6193)
System: Linux venus 4.14.78-4-osmc #1 SMP PREEMPT Wed Dec 12 17:58:11 UTC 2018 armv7l GNU/Linux

= = = = = = = = = = = = = = = = = = = = =
Installing dependencies for 'steamlink' : Steam Link for Raspberry Pi 3
= = = = = = = = = = = = = = = = = = = = =

= = = = = = = = = = = = = = = = = = = = =
Installing 'steamlink' : Steam Link for Raspberry Pi 3
= = = = = = = = = = = = = = = = = = = = =

Holen:1 http://security.debian.org stretch/updates InRelease [94,3 kB]
Ign:2 http://ftp.debian.org/debian stretch InRelease
Holen:3 http://ftp.debian.org/debian stretch-updates InRelease [91,0 kB]
OK:5 http://ftp.debian.org/debian stretch Release
OK:4 http://ftp.fau.de/osmc/osmc/apt stretch InRelease
Ign:6 https://packages.e-tobi.net/vdr-experimental stretch InRelease
Holen:7 https://apt.pilight.org nightly InRelease [5.462 B]
OK:8 https://packages.e-tobi.net/vdr-experimental stretch Release
Holen:10 https://apt.pilight.org nightly/main armhf Packages [19,9 kB]
Es wurden 211 kB in 5 s geholt (40,1 kB/s).
Paketlisten werden gelesen...
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
E: Paket steamlink kann nicht gefunden werden.
Unable to install binary for steamlink

Log ended at: Di 23. Apr 15:52:12 CEST 2019
Total running time: 0 hours, 0 mins, 18 secs

Thank you for looking

That’d be “Unable to locate package”. Since your RetroPie already is on Debian Stretch, it’s not a major version problem. Basically, RetroPie is unable to find the steamlink package in the repositories in which you told it to look for it. Usually you edit your /etc/apt/sources.list to get around that but I’m not quite sure how to do that in the environment of RetrOSMC. You could try running ./install-retrosmc.sh and choose 4 from the menu, Update scripts.

For those interested: a2dp-app-osmc suggested changes · Issue #505 · osmc/osmc · GitHub

some fixes to a2dp-app-osmc to fix audioproblems with systemwide pulseaudio, it worked for me :slight_smile:

hi, is there updated instructions for installing under the latest OSMC build (18.2)

I’ve done a clean build onto 2 boxes and i get an error when downloading the script, although this still appears to work, however nothing happens when i try to launch it.


Can’t confirm, download works as intended.

Your screenshot doesn’t look like PuTTY. Which ssh client do you use?

‘doh’ my bad, I used terminal rather than putty. thanks for your reply.

Great . Really interested to see about Retrosmc. I have used retropie for gaming, and written the article also on that ( Retropie | How to build raspberry pi game console! | Thetips4you) I will share this information to my community. May be l am very late to get this information, still this a a great to start. Thank you.

Just wanted to say thank you for all the work. I used the newer installation version 0.009, see the sub-forum “testing” for the instructions plus two tweaks I added to the thread. Overall this works very well, in contrast to the built-in gaming capabilities of Kodi Leila at the moment…

Are there any issues when installing retropie on latest OSMC (18.2) on Rpi3.
I am concerned crashing my osmc.

In case of emergency: can I completely redo/uninstall retropie from osmc again?


Unless you have any OS-based alterations, a backup with MyOSMC backup tool should be enough if anything would go bad, but I’ve done an install on both pi3 and vero4k, both works great with 18.2. and then look at post 1454 in this thread.

Hey guys,

What about [2019.11-1]

Thanks guys

1 Like

I am interested too in what about in 2019.11-1. Instalation without any error, but after running addon, after while it goes back to Kodi :frowning:

You should check out [HOW-TO ] retrOSMCmk2: a RetroPie installer on the Vero4K - #95 by sam_nazarko rather than using this old thread

Heya, struggling a bit here. I have installed this but had trouble pairing my ps3 sixaxis controllers via bluetooth (only works when wired). I tried downgrading the kernel as suggested in this thread: Latest update and PS3 sixaxis controller - RetroPie Forum but that bricked my OSMC so I have reformatted and installed everything but still can’t manage to pair my controllers via bluetooth.

Any ideas as to where I’m going wrong? How can I get these things paired?

There is a thread about retromsc is not working properly with latest OSMC and Kodi19: Issue with launching retrosmc on kodi v19 - #37 by sam_nazarko

In nutshell, when I try to start emulationstation, I get the following on the console:

Couldn't get V3D IDENT0: No such device

And then the retropie runs with 5-10 fps, very laggy. Anyone could make it work with the latest kodi and omsc?

You can work around this issue by editing the addon.xml file in ~/.kodi/addons/plugin.program.retrosmc-launcher/ .
<import addon="xbmc.python" version="2.1.0"/> to <import addon="xbmc.python" version="3.0.0"/>

Afterwards it should be possible to enable the launcher via settings.

But then it doesn’t launch via OSMC, but in command line yes (tested it on my side, I can confirm):

Something seems wrong about the retropie.sh when executing from the addon. Any ideas?

New here. Got a fresh install of newest OSMC working (Kodi Matrix v19) on Raspberry PI 4. Want to get Retropie, but am reading oldish messages about retrosmc script not working on OSCMatrix/pi4 systems, with move to Python3.

Saw also that user hissingshark created retrOSMCmk2 to address issues:https://github.com/hissingshark/retrOSMCmk2

But that hasn’t been updated if I’m reading correctly since 8/29/2021, but in the interim I see some complaints of only being able to run Retropie off CLI and launcher not working, and even then, prohibitively laggy.

Is that still the case or is retrOSMCmk2 largely working?

Not even sure if this is the right thread to post or this one:

As much as I hate crossposting, will put this post there, too.

1 Like

Hi mcobit, i have a question. I tried to install retropie using retrosmc but got warning about experimental gl and problems it may cause for retropie. Is there a way arround this?

Please see this thread [HOW-TO ] retrOSMCmk2: a RetroPie installer on the Vero4K

For updated installation process