[HOW-TO / TESTING] RetroPie on Vero4k

Can’t see anything in log indicating an error, what i posted last time is the last entries in the log. Here is the complete log: https://paste.osmc.tv/qahofiyeci

mupen64plus-ui-console/projects/unix/mupen64plus not found

means either that mupen64plus-ui-console is the module that failed to build, which is why it’s not found,
or as with a bug I found last year, it’s a typo, so it’s there alright but it doesn’t find it.

Thanks for the log. In the meantime I’d done a rebuild on my system to try and break it and got the same result.
Just search for “error” in the log and all is revealed :wink: Line 324.

CC  _obj/debugger.o
In file included from ../../src/core_interface.c:32:0:
../../src/core_interface.h:107:8: error: unknown type name 'ptr_DebugBreakpointTriggeredBy'
 extern ptr_DebugBreakpointTriggeredBy DebugBreakpointTriggeredBy;

And on it goes. Leave it with me. I’m looking into it.

There’s an upstream bug on mupen64plus-core that needs fixing. As we are probably the only 2 people in the world using RetroPie on the Vero4k right now it’s easier just to patch your copy around it.

sed -i -e 's/b75fdfb")/b75fdfb" "master 838d4d4")/' -e "s/[\']mupen64plus ui-console[\']/\"mupen64plus ui-console \${commit[1]}\"/" ~/RetroPie-Setup/scriptmodules/emulators/mupen64plus.sh

Then try again. Works here.
And thank you for testing.

1 Like

thanks, that made a differance =)

I’m glad to have emulationstation running on my Vero now. I have a couple of minor issues that I’m still trying to figure out.

I’m running the Kodi 18 RC, most recent osmc build as of 12/27. I installed RetroPie with emulationstation-dev as mentioned in this thread. I have tested a couple of the emulators and they are working.

There seems to be something amiss in the audio. I have working audio, both in ES and in games, but when running from the command line I see errors about attaching to the audio device. If I touch anything in the audio settings in ES it will crash. Not a big problem as it seems to work ok if I don’t touch that, but I thought it worth reporting.

My other problem is trying to launch from Kodi. In the past on my old RPi I used System.Exec() on the retrosmc script successfully. When I run the script from the command line everything works great, but when launched from Kodi I get a Bus Error when it tries to run the script that it writes to /usr/bin/emulationstation. Any ideas what might be wrong?

Got it running a bit, only unzipped roms run in emulationstaion with the resolution 320x200, if i run it in console
./mupen64plus.sh mupen64plus-video-rice "/home/osmc/RetroPie/roms/n64/mk4.n64"

I get 640x480, but since i dont have any conf files and i know jack about how to conifgure it properly i’m in deep water.

I’d really like to get the picture stretched or higher resolution since my tv shows 320x200 in the lower left corner.

i was able to adjust the resolution by editing /opt/retropie/configs/n64/mupen64plus.cfg and adjusting ScreenWidth and ScreenHeight. i also noticed that when i tried to play Mario Kart 64 the screen was flashing quite a bit, but updating ScreenUpdateSetting to 4 fixed that issue for me.

I don’t usually adjust the volume from ES but when I have it hasn’t resulted in crash. Never really understood the need for the volume slider in ES, although it was one the things I had to fix when I ported it to the Vero4K! The whole Kodi 18 RC thing is a bit of red flag. Might be one to revisit when it’s released.

Regarding launching, I’ve used an ssh phone app in the past to run a script that kills Kodi and starts ES. And vise versa.
These days I use the launcher addon that came with RetrOSMC. Just needed to manually install it. That’s working fine with Aeon Nox.

I actually use an improved version as per below. Have a read.

Mupen64plus has so much scope for config tweaking and plugins to get the best performance. Like with PPSSPP having different settings per game - it’ vital.

I usually use the mupen64plus-video-n64.so (gles2n64) for the likes of MarioKart. I too prefer fullscreen stretch.

In gles2n64.conf make the following changes:

#Window Settings:
window width=1920
window height=1080

#VI Settings:
video stretch=1

Thanks for the input. I’ve not tried to tweak the other plugins too much and certainly not from there. I shall have to give that a go!

Since i didn’t know where to put that cfg file i changed to rice and edited the right file, now i got a muppen64plus running fullscreen. Now the kids want to reconfigure the buttons but i should be able to fix that with the help of google. Thanks a bunch.

Most welcome. Glad it’s fun for all the family!

I think the default gles2n64.conf is only written after the first time running it, which doesn’t help matters. Very tempted to experiment with the others now too.

Mupen64plus-input auto detects a lot of controllers, but these days it doesn’t matter so much as Retropie should pass all that config on when you have used ES. If you want to custom tweak the layout it’s usually been appended by that process to

lr-vecx, lr-stella and dosbox-sdl2 is compiling and working.

lr-desmume-2015 compile and works, some games more then other lags alot.

lr-freeitv and lr-blueMSX (colecovison) is compiling and sort of works, not getting controller to work. Probably need to get the Retro-arch documentation and read up on them I guess.

ES changes have been cherry-picked to the regular stable branch, so it’s now acceptable and safer to install emulationstation from the “Manage Core packages” page.

1 Like

Guys hope someone can help me here…im interested in running some arcade roms I already have, I just wanted to know if installing emulation station is necessary to do this on my vero4k+, I’m slightly confused as I thought kodi18 had all this built in?

Any help is appreciated, cheers.

If your game is supported by one of the currently working emulators (see link below) then yes you don’t need retropie and everything is in Kodi 18.

Thanks for clarifying.

im honestly not sure what emulator was used by the roms, I last played them ages ago on a Pi via emulation station.

One quick question:
In the Kodi repository, in game addons, game providers, the only add-on there is ‘Advanced MAME Launcher’, so I’ve installed that.
In the settings for that add-on, there’s a ‘Mandatory executable path’ which is empty…that doesn’t seem right? Do I need an executable from somewhere?

well you don’t need that since it uses an external executable, to get this to work you have to go:

Setting->Add-on Browser->My Add-ons->Game add-ons->Emulators and enable the emulator you want.

After that you add a source, by navigating to you roms folder. From there you can click the rom and it should open in the emulator of you choice. If you are going for Mame-rom read the instructions in First post about File association and libarchive.

Uninstall the Advanced MAME launcher, since it’s not needed.

Ah ok thanks…
Only problem is in Setting->Add-on Browser->My Add-ons->Game add-ons
I have no Emulator section, just Controller profiles, Game providers, and Standalone games…
Im running the latest stable OSMC btw, is that the problem?

Are you sure you are looking in “My Add-ons” not kodi repository?

Ahaa! I knew id be doing something stupid, thanks!