[HowTo] Install and use SyncThing on OSMC


You are being far to vague for me to be able to give you a clear answer.


OK, thanks for everything. I will try to reinstall.


Simply delete the /home/osmc/.config/transmission-daemon folder after you stopped the Transmission service. Then start the service again. The folder will be recreated.

“Does not work” is too vague for me, no idea what you mean exactly but if you think it happened because of the automated script, it is most likely an issue of user permissions.


Great, thx for help. I do that and transmission works now :slight_smile:


Hello, do any of you have cpu load issue with syncthing?
I have it on a raspi3 running the last stable version of osmc. The sync folder is on a USB hard drive.
I have set up syncthing following this thread.
The cpu is always at the maximum speed (1200mhz), the load is around 50% or more and the temp reaches nearly 80°C.
Do you have any idea how to cool down my pi3?


I didn’t have those issues, because I use only Syncthing, when I charge phone (normaly once in a day), but I’m also using chipset cooler from asus and one small iron cooler for rpi. Now is my working temparature of rpi2 like 40-50, maybe maximum 61 celsious on heavy usage.

Asus chipset cooler:

I hop you find that usefully :slight_smile:


HI, is this recipe still valid? I was looking for exactly such a setup: need to update dirs remotely.
It seems the script vanished

Ok, the manual install worked I just had to adapt the instructions a bit (see below)

this had to be added sudo apt-get install apt-transport-https and release was replaced with stable echo "deb https://apt.syncthing.net/ syncthing stable" | sudo tee /etc/apt/sources.list.d/syncthing.list

great stuff