Howto Netflix/Android

Read the wiki page.

Write the Android Image to a SD card using the OSMC Installer. Having a system not supported by the Installer, I’ve used:

sudo umount /dev/mmcblk0p{1,2,3,4}
gzip -dc <OSMC*vero2_android*gz | sudo dd if=/dev/stdin of=/dev/mmcblk0 bs=4M conv=notrunc,noerror

Put the SD card into Vero2, reboot (to Android) and wait.

You need a keyboard and a mouse.

Go to Settings → Security and enable ‘Unknown sources’.

[details=GoogleApps installation is not really needed]Reboot to osmc (CTRL-Alt-Del).

Download Google backdoors from OpenGAPPS. Choose ARM/4.4/pico. Sam suggested nano, but after seeing the differences between nano and pico I’ve choosed pico. Download the MD5 checksum file too.

You need ssh access to your Vero2. Copy the downloads to your Vero2:

scp open*zip open*md5 osmc@vero-ip:

On Windows use pscp.

Unpack the archive:

ssh vero-ip
sudo -s
md5sum -c *md5
mkdir gapps
cd gapps
unzip ../open*zip
apt-get install lzip
mkdir naked
find -name '*.tar.lz' | sort | xargs -n1 -I{} tar -C naked -xf {}

You need to copy the files from naked/ directory to your SD card, on a partition that is mounted under /media/adb… directory.

find naked -type f -name '*.apk' |grep -v priv-app|xargs -n1 -I{} mv -v {} /media/adb*/app/
find naked -type f -name '*.apk' |grep nodpi/priv-app|xargs -n1 -I{} mv -v {} /media/adb*/priv-app/
mv -v naked/vending-all/*/*/Phonesky.apk /media/adb*/priv-app/
find naked -type f -name '*.so' | xargs -n1 -I{} mv -v {} /media/adb*/lib/
find naked -type f -name '*.jar' | xargs -n1 -I{} mv -v {} /media/adb*/framework/

Move the .xml files to the corresponding etc directory. Some must be copied with their parent directory, like:

mv -v naked/defaultetc-common/common/etc/sysconfig /media/adb*/etc/

Fix the owner (if needed):

chown -R root:root /media/adb*/{app,priv-app,lib,framework,etc}

Reboot to Android.[/details]

Use the browser to search, download and install a Netflix APK. Now you have it. Really! I’ve installed 4.10.7 from apkmirror.

Trying Google Play

I’ve wanted to see if Google Play works. It does, somehow. I’ve made a new Google account. Installed TVLauncher from Awesome Development as Sam suggested. All OK. Tried to upgrade Netflix from Google PlayStore: found version 4.4 with the mention that is not supported for my device. It sucks. Maybe I have to change some .prop files. There are some in the opengapps archive.

Todos and questions:

  • WiFi sucks even after I’ve unchecked the battery helper. I had to switch it off/on to get a couple of minutes with 4 lines signal before landed to no lines. I wonder if the 5Ghz WiFi dongle works on this Android image and is better than the builtin one. - waiting for a new Android image
  • su is not su, or at least I didn’t get id 0
  • How do I reboot (to OSMC) without a keyboard? I could not find any shorcut for that - Shutdown could work with proper su
  • A script to download, unpack and copy gapps to SD card. It should be made ready to run from Vero2. - might not be needed for Netflix
  • Why Netflix from Google PlayStore doesn’t install? - workaround: install Netflix on an Android phone and move the apk to Vero with GhostCommander
  • How do I control the Netflix app without a mouse? Is there any simple app for that? Does Remote control from Settings helps here?

Ah, I know what the will be (assuming it’s not giving you problems in OSMC) and can fix that with a rebuild.

The easiest way is probably one of those ‘tools’ that let you reboot, boot to recovery, etc.

What terminal did you use? What did whoami say?

Probably, as you say, an architecture mismatch; assuming that the latest APK still targets 4.4 OK. Can you install other apps OK?

I think that Netflix to be controlled with a remote is an Android TV thing.

This is reasonable; but we wouldn’t be able to host the GApps. So provided they’re hosted somewhere in a way that they can be directly downloaded, it’s possible.

The WiFi is OK in OSMC. At least the buffering is enough when playing videos. With Netflix, the video quality was poor even after 1 minute.

The terminal used was jackpal.androidterm-1.0.70-71-minAPI4.apk
I didn’t use whoami, just id, and I’ve got the same output/uuid, while on OSMC I get:

osmc@osmc:~$ id
uid=1000(osmc) gid=1000(osmc) groups=1000(osmc),4(adm),6(disk),7(lp),20(dialout),24(cdrom),29(audio),44(video)
osmc@osmc:~$ sudo id
uid=0(root) gid=0(root) groups=0(root)

Yes. TVLauncher.

I wonder if Netflix from phone can control the one from Vero, like HBO Go does.

The archive could be hosted as a torrent :smiley: , and all the Vero2 users who install it should run a torrent client. See? The hosting part is solved.

Not everyone would want to host this file; particularly with some of the issues redistributing these ZIPs. Effectively we’d just be pushing the legal issues from us on to you (the users) – not good. I’m sure things can be simplified however.

WiFi is probably a power saving bug – I can produce a new Android build if you’d like to test it out.



Sure. But just be aware that I’ve unchecked the power saving stuff from WiFi settings.

I don’t think that’s related.

I was under impression that I need GPAPS to run Netflix. I’ll try without it. If GAPPS are needed just for Google Play connection, I will feel better without.

I do own a Nexus tablet without a linked google acount, with Google Play disabled, and with Netflix installed through Atpoide Store.

Don’t think you need Google Apps for Netflix.


What is the link between a hardware power button (which trigger the poweroff/reset menu) and userland android? Couldn’t be used for reboot?

Not quite sure I get the question.

Can you describe what you’d want to do and maybe I can help you.

I’m not sure I could find a simple tool to reboot. Maybe something big, like Kodi :slight_smile: .

Maybe you can map a long press of HOME or BACK to CTRL+Alt+Del.

I’ll think about this.

We’d need a daemon for interpreting long presses; and my Android app development is a bit rusty.


If a new code has to be written, I think a reboot tool is better than a daemon.

On a second thought, nevermind. I’ve remembered about F-Droid.

You should consider the inclusion of Shutdown from F-droid repo in the next Android image (with the su fix).

Can Vero2/Android behave like a chromecast dongle? See chromecast explained.


Can you explain what you mean by su fix?

I have patched su as other Android ROMs do. I’m not sure what else needs changing.

Probably – is there an APK I can include for this behaviour?

Even the simple apps (Shutdown and SimpleReboot from F-Droid) doesn’t see the Vero2 as rooted. I don’t know why.

I found webpages about CheapCast, Android Media Shell and CastReceiver(?).

Installed CheapCast and YumMap Cast (or something like this). After reboot, I could connect the Netflix from my Android phone to Vero2. I did not get the streaming to work. The wifi status is unbearable.

Btw, should adb work on some USB port?

Shouldn’t su be suid?
-rwxr-xr-x 1 root root 71244 Aug 21 15:02 /media/adb710b5-df09-4059-bcc3-10254d26db6b/xbin/su

The /system partition is mounted with nosuid on both systems (OSMC and Android).

Found this link about root on ouya:

Every OUYA is shipped already ‘rooted’, just not in the way most people expect it to be. If you type ‘su’ at the adb shell, you get root … however the installed ‘su’ binary doesn’t give you the normal permissions GUI that most root-requiring apps use.

Let me have a chat with some old XDA friends.


Any news about these?

  • With WiFi dropping every couple of minutes there is not much to do or test.
  • Without working su I can’t reboot the system without a keyboard attached.