[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC

Same error here. Can start from SSH but starting from inside Kodi 18 causes seg fault

Is there even a point for RetrOSMC in Kodi 18? Are the built-in retro libraries so bad you still have to use a full RetroPie installation?

As of this moment there are alot of cores not integrated into Retroplayer yet. I have em both installed to get the complete experience.

Despite this extensive list I’m having trouble determining by reading online sources which cores are supported and which aren’t. Seems like there’s no other way than to test for yourself just like you did. Anyway, thanks for the heads-up! I’ll lower my expectations for the gaming part of Kodi 18 now. :I

I tried installing Retrosmc today and received the same error as scorrmbritton, Onizuka, and ender11122. I tried again using a new SD card with the same result…

Has the cause of this been determined? Any solutions that anyone is aware of?

@birdmanofalcatraz @scottmbritton @Onizuka @ender11122

I had already typed out a reply how I could second your description of the problem because I, too, ran into it yesterday during a reinstall. Of all the search engine results for /usr/bin/emulationstation Segmentation fault $es_bin “$@”’ there was one which I hadn’t read yet, and it turned out to contain the solution. Shoutout to hakuya on Github who posted the solution:

So if this isn’t self-explanatory, ssh into your RetrOSMC installation, open the script in question with a text editor like nano:

nano RetroPie/scripts/retropie.sh

and add the line

cd /home/osmc

below the initial shebang so it looks like this:

Press Ctrl + O to save the edited script, then Ctrl + X to exit.

Doesn’t work with the launcher of the 0.009 beta, though. If you’ve used it, you have to remove the 0.009 install script, download the 0.007 install script, make it executable, run it, have it uninstall the current launcher, and then install the 0.007 launcher again.

Happy gaming! :grinning:

4 Likes

Thank you for the help. This worked like a charm.

1 Like

Thank you so much, RJ45! Retrosmc is back in action.

1 Like

Hello,

I also have retropie installed and could try one or the other emulator. :slight_smile: Many thanks for the work and time invested here.

I wanted to test the package Steamlink (under Experimental) in Retropie. Unfortunately, the installation does not work. Has anyone tried or knows what it fails?

Log started at: Di 23. Apr 15:51:54 CEST 2019

RetroPie-Setup version: 4.4.12 (d35e6193)
System: Linux venus 4.14.78-4-osmc #1 SMP PREEMPT Wed Dec 12 17:58:11 UTC 2018 armv7l GNU/Linux

= = = = = = = = = = = = = = = = = = = = =
Installing dependencies for 'steamlink' : Steam Link for Raspberry Pi 3
= = = = = = = = = = = = = = = = = = = = =


= = = = = = = = = = = = = = = = = = = = =
Installing 'steamlink' : Steam Link for Raspberry Pi 3
= = = = = = = = = = = = = = = = = = = = =

Holen:1 http://security.debian.org stretch/updates InRelease [94,3 kB]
Ign:2 http://ftp.debian.org/debian stretch InRelease
Holen:3 http://ftp.debian.org/debian stretch-updates InRelease [91,0 kB]
OK:5 http://ftp.debian.org/debian stretch Release
OK:4 http://ftp.fau.de/osmc/osmc/apt stretch InRelease
Ign:6 https://packages.e-tobi.net/vdr-experimental stretch InRelease
Holen:7 https://apt.pilight.org nightly InRelease [5.462 B]
OK:8 https://packages.e-tobi.net/vdr-experimental stretch Release
Holen:10 https://apt.pilight.org nightly/main armhf Packages [19,9 kB]
Es wurden 211 kB in 5 s geholt (40,1 kB/s).
Paketlisten werden gelesen...
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
E: Paket steamlink kann nicht gefunden werden.
Unable to install binary for steamlink

Log ended at: Di 23. Apr 15:52:12 CEST 2019
Total running time: 0 hours, 0 mins, 18 secs

Thank you for looking

That’d be “Unable to locate package”. Since your RetroPie already is on Debian Stretch, it’s not a major version problem. Basically, RetroPie is unable to find the steamlink package in the repositories in which you told it to look for it. Usually you edit your /etc/apt/sources.list to get around that but I’m not quite sure how to do that in the environment of RetrOSMC. You could try running ./install-retrosmc.sh and choose 4 from the menu, Update scripts.

For those interested: a2dp-app-osmc suggested changes · Issue #505 · osmc/osmc · GitHub

some fixes to a2dp-app-osmc to fix audioproblems with systemwide pulseaudio, it worked for me :slight_smile:

hi, is there updated instructions for installing under the latest OSMC build (18.2)

I’ve done a clean build onto 2 boxes and i get an error when downloading the script, although this still appears to work, however nothing happens when i try to launch it.

image

Can’t confirm, download works as intended.

Your screenshot doesn’t look like PuTTY. Which ssh client do you use?

‘doh’ my bad, I used terminal rather than putty. thanks for your reply.

Great . Really interested to see about Retrosmc. I have used retropie for gaming, and written the article also on that ( http://www.thetips4you.com/retropie-how-to-build-raspberry-pi-game-console/) I will share this information to my community. May be l am very late to get this information, still this a a great to start. Thank you.

Just wanted to say thank you for all the work. I used the newer installation version 0.009, see the sub-forum “testing” for the instructions plus two tweaks I added to the thread. Overall this works very well, in contrast to the built-in gaming capabilities of Kodi Leila at the moment…

Are there any issues when installing retropie on latest OSMC (18.2) on Rpi3.
I am concerned crashing my osmc.

In case of emergency: can I completely redo/uninstall retropie from osmc again?

Greetz
Duffy6

Unless you have any OS-based alterations, a backup with MyOSMC backup tool should be enough if anything would go bad, but I’ve done an install on both pi3 and vero4k, both works great with 18.2. and then look at post 1454 in this thread.

Hey guys,

What about [2019.11-1]

Thanks guys

1 Like

I am interested too in what about in 2019.11-1. Instalation without any error, but after running addon, after while it goes back to Kodi :frowning: