[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


#1436

Hi everyone!

I’ve successfully installed RetroPie following this guide and enabled the swap file in order to do so.

I’ve tried to disable it in 2 ways:

  1. sudo /touch disable swap

  2. sudo swapoff -a -v
    sudo rm swap

After the restart swap file is present again and in use.

Should I be concerned about SD card wear since swap is on and if yes, how can I disable/remove it?


#1437

Try:

sudo rm /enable_swap
sudo reboot


#1438

That did it, thanks @joakim_s!

I’ve seen that there were 2 empty files in the root - enable_swap and disable_swap.

If my understanding is correct, by deleting one of them you effectively enable/disable swap.

In my case, I needed to delete enable_swap and leave disable_swap in order do have the swap disabled after reboot.


#1439

You can remove both, the second one you created by doing your own touch command.

The touch command creates a 0 byte file, and OSMC just checks if there is an enable_swap file in root directory, if there is it will create a swap file.


#1440

Got it, thanks again.


#1441

Just curious, has anyone successfully got Wiimote Classic controller to work on RetroPie?
I’ve tried to follow this https://github.com/RetroPie/RetroPie-Setup/wiki/Wiimote-Controller (method 1 Option B) but some of the folders and/or files they ask to modify don’t seem to exist.

Thanks,
Robert


#1442

Hello. Tried installing Retrosmc today. Followed the steps completely. I am getting the message

/usr/bin/emulationstation : line 13: xxxx Segmentation fault $es_bin “$@”’

Uninstalled retropie and tried again and get the same message.

I tried searching here for anyone with a similar issue. I don’t have Hyperion and no over clocking. If I run /home/osmc/RetroPie/scripts/retropie.sh from the command line in ssh Emulation station starts up without problems.

I’m not sure what to look at. Any help would be appreciated.


#1443

You could try the 0.9 beta launcher, it’s working as long as there is a controller or keyboard connected to the USB port. it has trouble starting with just a bluetooth controller.


#1444

Just some more info. Installing on a RPi 3 B+. I went ahead and did a fresh OSMC install on a separate 16gb sdcard. Installed Retropie following the instructions step by step and still get the same error and results. ES starts fine from the command line but not from the launcher addon or creating my own with System.Exec. Thanks.


#1445

Thanks for the response. No more segmentation fault but now I only see a blank screen :slight_smile:

Command line still works properly.


#1446

Was a while since i used this on my Pi3, when I get sometime I will investigate further. Might be something simple, but when it comes to 0.009 beta I’m doubt it’s something simple.


#1448

I have the same problems as Scottmbritton. After installation

/usr/bin/emulationstation : line 13: xxxx Segmentation fault $es_bin “$@”’


#1449

Same error here. Can start from SSH but starting from inside Kodi 18 causes seg fault


#1450

Is there even a point for RetrOSMC in Kodi 18? Are the built-in retro libraries so bad you still have to use a full RetroPie installation?


#1451

As of this moment there are alot of cores not integrated into Retroplayer yet. I have em both installed to get the complete experience.


#1452

Despite this extensive list I’m having trouble determining by reading online sources which cores are supported and which aren’t. Seems like there’s no other way than to test for yourself just like you did. Anyway, thanks for the heads-up! I’ll lower my expectations for the gaming part of Kodi 18 now. :I


#1453

I tried installing Retrosmc today and received the same error as scorrmbritton, Onizuka, and ender11122. I tried again using a new SD card with the same result…

Has the cause of this been determined? Any solutions that anyone is aware of?


#1454

@birdmanofalcatraz @scottmbritton @Onizuka @ender11122

I had already typed out a reply how I could second your description of the problem because I, too, ran into it yesterday during a reinstall. Of all the search engine results for /usr/bin/emulationstation Segmentation fault $es_bin “$@”’ there was one which I hadn’t read yet, and it turned out to contain the solution. Shoutout to hakuya on Github who posted the solution:

So if this isn’t self-explanatory, ssh into your RetrOSMC installation, open the script in question with a text editor like nano:

nano RetroPie/scripts/retropie.sh

and add the line

cd /home/osmc

below the initial shebang so it looks like this:

Press Ctrl + O to save the edited script, then Ctrl + X to exit.

Doesn’t work with the launcher of the 0.009 beta, though. If you’ve used it, you have to remove the 0.009 install script, download the 0.007 install script, make it executable, run it, have it uninstall the current launcher, and then install the 0.007 launcher again.

Happy gaming! :grinning:


Retrosmc Launcher issues
#1455

Thank you for the help. This worked like a charm.


#1456

Thank you so much, RJ45! Retrosmc is back in action.