[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


#1416

have you tried this install script, this is beta 0.009 but I it installed perfect for me on OSMC KODI running the latest official OSMC (KODI 17.6)

You might get an error about a joytokey python script missing, but that shouldn’t cause any issues as all that gets installed with RetroPie

I did try updating to KODI 18 but had no end of video issues, so went back to OSMC KODI 17.6 and all the video problems went away. But, it does clearly state KODI 18 is still in ALPHA but gave it a try

Try installing the latest RetroPie script, via the RetroPie config, or run the RetroSMC script again and it should automatically take you there. Then, do a rebuild ALL. It WILL take a loooong time. Overnight is better but should update ALL RetroPie to Debian Stretch

It might be easier to do a full fresh install of OSMC and once that is running, THEN install the beat 0.009 RetroSMC script. Its a major pain I know, but if you’ve been messing for a long time, sometimes a fresh install can fix everything

I run OSMC off a USB hard drive, not that should make a difference, using the ‘install to USB’ option when initially starting OSMC from a fresh install


#1417

Use the two commands from the post by @Tom_Doyle above.

wget ftp://ftp.us.debian.org/debian/pool/main/b/boost1.55/libboost-filesystem1.55.0_1.55.0+dfsg-3_armhf.deb

sudo dpkg -i libboost-filesystem1.55.0_1.55.0+dfsg-3_armhf.deb

#1418

Hey Sam,

I’ve been looking into seeing if retrosmc can run on the Vero 4k yet, but still doesn’t seem to be. Any info on whether this will be supported soon??

Thanks


#1419

I think using it build in Kodi v18 makes much more sense than having any parallel installation


#1420

I’m a total newb when it comes to Osmc, Kodi, etc. Would you know how long it may be before we’re updated to release 18?


#1421

While there is a alpha/beta version currently available that works kind of OK currently it is hard to say when it becomes stable release but surely will not be any time soon.


#1422

If you wish, you can install the stable OSMC then tell it to upgrade to the latest alpha release via updates

I’ve tried this a couple of times and it updated ok to KODI 18 but had various issues with videos stuttering or various issues with ‘some’ add-ons simply being unpredictable

Had to re-install OSMC to get back to KODI 17.6 and ALL video issues were fine, but under KODI 18 cause problems. I also use RetroPie installed via RetroSMC and this does have issues if you upgrade to KODI 18 ALPHA, under OSMC 17 things work great

My main reason to try out KODI 18 is the emulation that is now part of KODI 18, but could never get it to work as I thought it would. As it says though … it is an alpha release so WILL have issues that may cause problems later if things change

KODI 18 does work, and some things are much better but has issues. Considering its still in ALPHA release it is for the most part stable and does what it should, just needs a few things working out

If you want to try the KODI 18 update, you’ll need to follow these instruction. BUT once you have upgraded you CANNOT downgrade. If your not happy or isn’t stable enough for you, then you WILL have to reinstall from scratch to get back to OSMC KODI 17


#1423

Doesn’t work for me :frowning:


#1424

Hi,

would help if your posted the error you are getting now.

Thanks Tom.


#1425

Exactly the same as mentioned above. No changes. As I tried several tricks listed here, is there a way to clean my libboost packages before retrying this solution?
Thanks


#1426

Hi,

Did did you get any errors when running the above command, what device are you trying to run this on?

Thanks Tom.


#1427

Hi Tom,
First I have to get the file through http as ftp doesn’t seem to respond.
Then I run the install:

sudo dpkg -i libboost-filesystem1.55.0_1.55.0+dfsg-3_armhf.deb     (Reading database ... 66388 files and directories currently installed.)
Preparing to unpack libboost-filesystem1.55.0_1.55.0+dfsg-3_armhf.deb ...
Unpacking libboost-filesystem1.55.0:armhf (1.55.0+dfsg-3) over (1.55.0+dfsg-3) ...
Setting up libboost-filesystem1.55.0:armhf (1.55.0+dfsg-3) ...

No specific errors here.
The error below comes when installing RetroPie on my rpi2.

594:make[2]: *** No rule to make target ‘/usr/lib/arm-linux-gnueabihf/libboost_date_time.so’, needed by ‘emulationstation’. Stop.


#1428

Hi,

I would check you’ve installed the additional packages and created the symlink as described here:

Thanks Tom.


#1429

I did that also, but still the same error… No rule to make target ‘/usr/lib/arm-linux-gnueabihf/libboost_date_time.so’, needed by ‘emulationstation’. Stop.


#1430

Hi,

I’d check if that file exists, if not another symlink may get you going:

cd /usr/lib/arm-linux-gnueabihf
sudo ln -s libboost_date_time.so.1.62.0 libboost_date_time.so

Thanks Tom.


#1431

This is what I can see:

/usr/lib/arm-linux-gnueabihf$ ls -al | grep libboost_date
-rw-r–r-- 1 root root 139094 Nov 12 2016 libboost_date_time.a
lrwxrwxrwx 1 root root 28 Nov 12 2016 libboost_date_time.so -> libboost_date_time.so.1.62.0
lrwxrwxrwx 1 root root 28 Aug 11 12:42 libboost_date_time.so.1.55. -> libboost_date_time.so.1.62.0


#1432

Hi,

Not sure why it isn’t working then, @rj45 any ideas?

Tom.


#1433

@raspdealer @Tom_Doyle Can’t really explain either. :I Especially since RetroPie now officially supports Stretch.

I’d give the method mentioned above a shot. Just make sure you select the correct image of OSMC corresponding to your Pi model.

Also, you do have SWAP enabled and you stick to mcobit’s step by step tutorial in the start post of this thread, right?


Why OSMC has a worst performance when compared to other Kodi installations?
#1434

Hello, just installed OSMC and followed all instructions on installing retrosmc. I’m having an issue where no emulators will launch because runcommand.sh is missing. After checking the runcommand core package is not installed, and for some reason wasn’t installed during the installation.

When I try installing runcommand from install-retrosmc.sh I get the following error about libraspberrypi-bin. Seems the librasperrypi-bin package doesn’t exist in the repos. Is there a workaround for this at all?

Log started at: Mon Aug 13 12:01:25 EDT 2018

RetroPie-Setup version: 4.4.2 (30e9c4a1)
System: Linux osmc 4.14.34-4-osmc #1 SMP PREEMPT Fri Jul 20 15:44:43 UTC 2018 armv7l GNU/Linux

= = = = = = = = = = = = = = = = = = = = =
Installing dependencies for ‘runcommand’ : The ‘runcommand’ launch script - needed for launching the emulators from the frontend
= = = = = = = = = = = = = = = = = = = = =

Did not find needed package(s): libraspberrypi-bin. I am trying to install them now.
Hit:1 http://security.debian.org stretch/updates InRelease
Ign:3 http://ftp.debian.org/debian stretch InRelease
Hit:4 http://ftp.debian.org/debian stretch-updates InRelease
Hit:5 http://ftp.debian.org/debian stretch Release
Hit:2 http://ftp.fau.de/osmc/osmc/apt stretch InRelease
Reading package lists…
Reading package lists…
Building dependency tree…
Reading state information…
E: Unable to locate package libraspberrypi-bin
Could not install package(s): libraspberrypi-bin.

Log ended at: Mon Aug 13 12:01:32 EDT 2018
Total running time: 0 hours, 0 mins, 7 secs


#1435

Did you follow the guide from here :slight_smile:

Also, this is the latest script to install. Its the one I use and have no problems installing on an RPI3B

If/When the script says joy2pi is missing,d on’t worry about that. Thats installed in the intial install and isn’t really needed for the initial installation

The install script should automatically download all need libraries and any extras needed for correct installation

Also, if you are install RetroSMC on the OSMC VERO 4K that isn’t supported at present, but apparently does work but more effort is needed to get it to install correctly