[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC

can i update retropie to 3.1 with retrosmc?

Nope, sorry, mate. :confused:

You can try to update via the retropie-setup script.
Do a binary installation, but backup your sdcard first.

If there are any problems, tell me. Could be that you need to adjust some things after the update. Like the emulationstation script.

I didn’t try myself because of time constraints.

Hi, sorry haven’t installed the latest version of Retrosmc yet. Once i do will work on the scripts.

No worries! I was just being hopeful. This is my first foray into anything that’s not windows or android but it’s fun. I’ve got an image of my current setup so I’m just going to have a fiddle (probably until it breaks).

Check out the config here and let me know

Find the scripts and instructions here

I just installed the latest Version of the script and tried to install Retrogaming. The Installation was Quickly succesfull. Now I have the Problem that the Emulatorstation wont start. I tryied to run it offer the installed Appluncher. After The emulatorstation booting Screen it termates and I got back to the OSMC Screen. Could someone help me with my Problem. In which logfile do I get some Informations?

Tanks Joiyco

If the install went too fast, there could be a problem with the download or extraction process.
Please restart the installation and make sure you are connected to the internet and that your apt is working correctly.

apt is working correctly. Are there any posibilities to see what is done during the Installation. Like switching to the debug mode?

Did you try again? Did the downloading and extraction take longer this time?
Is there enough free diskspace?

There is enogh space free. It took a bit longer. The foldersize of retroosmc is 1,7 GB.

That’s the size of /opt/retrosmc right?
Have you tried deleting video.sh from /home/osmc/RetroPie/scripts?

Yes thats the Size of /opt/retrosmc. No I’ll try it if im back from work and let you know if it brougth a Change/result. Thank you for your help

So far so good. The emulatorstation is working. I just have to figuer out. Why my games aren’t working. I enabled the Emulator for snes games. And copyed my Roms in the Roms Folder. But only one is starting.

Thank you for your great Help and your great Job

i think you have to change to another libretro-core/emulator (by starting the rom and pressing a button when it tells you to). just. there has been a problem in retropie 3.0 which caused some snes games to not start (it takes you right back to ES, right?)

Yes it does. How do I Change the libretro-core/Emulator? Just add an other bios ?

snes doesn’t need a bios-file, i think… so no.
as i said, just press X or something on the controller/keyboard shortly after starting the game. you’ll end up in a configuration menu where you can tell retropie to use the other libetro-core for snes-roms in the future.
i think choosing another libretro-core (retroarch!) is the better option, as other emulators have other ways to config the controller.

I’ll try it if I am at home. Thank you for your help :wink:

You can also update only the lr-snes9x-next emulator with the retropie-setup script. This is the emulator, that fails to load some roms.
This is a known problem and described numerous times in this thread.