[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC

Unfortunately I cannot help with the xbox controllers as I don’t own them, but of course you can connect multiple controllers via usb hub.

I want to say thank you!!!

I got a cheap sound card based on the cm108 chip-set and it works fine in osmc.
how can i enable it in retrosmc??

And How can I use my Dual shock 2 controller to navigate osmc?
It works fine in retrosmc.

Thank you!!!

Don’t know about the soundcard.
The controller would need to emulaze keyboard presses to be recognized in osmc.
I think it doesn’t use joypads as that would require sdl.

Allright, this is my fifth attempt and I can’t get it to work at all. Raspberry Pi II with OSMC v2015.09-2.
Initially I tried with one of the first install script on another thread which also didnt work, but cleaned up and tried with this version. The script completes, but after scrolling back I see the folowing errors after the cleanup dialog:

chown: cannot access '/opt/retrosmc/etc/sudoers': No such file or directory
chown: cannot access '/opt/retrosmc/etc/sudoers.d': No such file or directory
chown: cannot access '/opt/retrosmc/usr/bin/sudo': No such file or directory
chown: cannot access '/opt/retrosmc/usr/lib/sudo/sudoers.so': No such file or directory
chmod: cannot access '/opt/retrosmc/etc/sudoers': No such file or directory
chmod: cannot access '/opt/retrosmc/etc/sudoers.d': No such file or directory
chmod: cannot access '/opt/retrosmc/usr/bin/sudo': No such file or directory
chmod: cannot access '/opt/retrosmc/usr/lib/sudo/sudoers.so': No such file or directory
unlink: cannot unlink '/opt/retrosmc/etc/resolv.conf': No such file or directory

After downloading a few files it outputs:

grep: /opt/retrosmc/home/pi/.emulationstation/es_input.cfg: No such file or directory
mkdir: cannot create directory '/opt/retrosmc/home/pi/.emulationstation': No such file or directory
./install-retrosmc.sh: line 142: /opt/retrosmc/home/pi/.emulationstation/es_input.cfg: No such file or directory

/opt/retrosmc never gets created. Scripts are created correctly in /home/osmc/RetroPie. Launcher never gets created altough the script doesnt mention any error.

If I attempt to start RetroPie/scripts/retropie.sh it obvioulsly fails with the following:

/home/osmc/RetroPie/scripts/video.sh: line 8: /opt/retrosmc/usr/bin/omxplayer: No such file or directory
/home/osmc/RetroPie/scripts/video.sh: line 10: /opt/retrosmc/usr/bin/omxplayer: No such file or directory

After which kodi just restarts. Any ideas why it’s not working ? I tried using a different install path, logging in as root and uninstalling / redownloading / reinstalling retrosmc many times.


After taking a look at the install script and some debugging by trying to extract the installer package manually, I noticed I was missing pv and bzip2 – It appears it was apt-get that was stuck, missing dependencies for libsdl2 (might have been caused by my attempt with the old script) and was refusing to fix or install anything. I temporarily removed libsdl2 and then the installation went trough.

Yes. The old scripts tend to this behaviour.
One of the reasons I made the new one. This should be much safer.

I would suggest to reinstall osmc completely though. You have used a very old script that could cause some more problems in the future because of packages from raspbian.

I’ll probably do that, as It crashed a couple of times. But it’ll have to wait since I have no SD card reader around. At least I managed to try it! Thanks for the reply, and good work!

Ever get any joy with the 360 controller? I’m having the same trouble. Did Yggdrasil give you any more info on creating 2 different cfg files and editing the script to kill and restart with the new cfg?

can i update retropie to 3.1 with retrosmc?

Nope, sorry, mate. :confused:

You can try to update via the retropie-setup script.
Do a binary installation, but backup your sdcard first.

If there are any problems, tell me. Could be that you need to adjust some things after the update. Like the emulationstation script.

I didn’t try myself because of time constraints.

Hi, sorry haven’t installed the latest version of Retrosmc yet. Once i do will work on the scripts.

No worries! I was just being hopeful. This is my first foray into anything that’s not windows or android but it’s fun. I’ve got an image of my current setup so I’m just going to have a fiddle (probably until it breaks).

Check out the config here and let me know

Find the scripts and instructions here

I just installed the latest Version of the script and tried to install Retrogaming. The Installation was Quickly succesfull. Now I have the Problem that the Emulatorstation wont start. I tryied to run it offer the installed Appluncher. After The emulatorstation booting Screen it termates and I got back to the OSMC Screen. Could someone help me with my Problem. In which logfile do I get some Informations?

Tanks Joiyco

If the install went too fast, there could be a problem with the download or extraction process.
Please restart the installation and make sure you are connected to the internet and that your apt is working correctly.

apt is working correctly. Are there any posibilities to see what is done during the Installation. Like switching to the debug mode?

Did you try again? Did the downloading and extraction take longer this time?
Is there enough free diskspace?

There is enogh space free. It took a bit longer. The foldersize of retroosmc is 1,7 GB.

That’s the size of /opt/retrosmc right?
Have you tried deleting video.sh from /home/osmc/RetroPie/scripts?