[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC

You put your psx cdimages (e.g. img,iso) into /home/osmc/RetroPie/roms/psx/

Should work then.

Thank you very much for all the scripts and instructions! Worked flawlessly and just thought you deserve some more praise!

1 question I have is do you know what file or files I would have to edit if I wanted to add a state save button combo? Actually I guess I should ask if state save is even an option at this point?

Thanks for any help

i’m pretty noobish myself but i’ll right out some instructions

If you use retroarch emulators, savestates are enabled by default:
Hold select and press the left or right shoulderbuttons on your controller to save/load states.
You can also bring up the retroarch menu to advance slots and stuff.

Please refer to the retroarch/retropie documentation for details.

Hi,
Recently I installed the retropie into my RPi2 using the 0.006 version’s script with the Launcher Addon.
After pressing the Launcher I can see: some Kodi logo, then ES logo, then background window, and the ES logo again and the Kodi logo again. After it the Kodi is restarted.
Any ideas?

I tried to find any log files in /opt/retropie, I just found only the ./home/pi/.emulationstation/es_log.txt file recently modified.
cat:

lvl2:   EmulationStation - v2.0.1a, built Aug  2 2015 - 15:33:54
lvl2:   Creating surface...
lvl2:   Created window successfully.
lvl2:   Added unconfigured joystick Xbox 360 Wireless Receiver (GUID: 030000005e0400001907000000010000, instance ID: 0, device index: 0).
lvl2:   Added unconfigured joystick Xbox 360 Wireless Receiver (GUID: 030000005e0400001907000000010000, instance ID: 1, device index: 1).
lvl2:   Added unconfigured joystick Xbox 360 Wireless Receiver (GUID: 030000005e0400001907000000010000, instance ID: 2, device index: 2).
lvl2:   Added unconfigured joystick Xbox 360 Wireless Receiver (GUID: 030000005e0400001907000000010000, instance ID: 3, device index: 3).
lvl2:   Checking available OpenGL extensions...
lvl2:    ARB_texture_non_power_of_two: MISSING
lvl2:   Loading system config file /etc/emulationstation/es_systems.cfg...

Note: the same results are w/o the Xbox360 gamepad.

Any ideas? How can I get more detailed logd info or keep logs?

Try deleting video.sh from /home/osmc/RetroPie/scripts then reboot and try again.

Thanks @mcobit for the reply.
I did as you proposed.

So now after executing the Launcher Kodi is restarted w/o displaying the previous logos. The video.sh script is not recreated.

Also I found much more files touched: many in /opt/retrosmc/run directory and the /opt/retrosmc/home/pi/.emulationstation/es_log.txt - but with the same content as before.

Note that my OSMC is running on nfs share - I’m using SD card as bootloader only.

Hmmm… there might be a timing issue.
You could try to give es a bit more time to start by editing the sleep times in the watchdog script.

Yggdrasil
I cant wait to try the scripts out thank you :slight_smile:

Thanks @mcobit, I thought about the same, starting playing with values…
Also I redirected output from chroot.sh for the line:

sudo HOME="/home/pi" /usr/sbin/chroot --userspec 1000:1000 "$INSTALLDIR/retrosmc" emulationstation

cat:

terminate called after throwing an instance of 'std::runtime_error'
  what():  locale::facet::_S_create_c_locale name not valid
/usr/bin/emulationstation: line 17:  2123 Aborted                 $es_bin "$@"

The above looks similar to locale / UTF-8 issue… will try to fix as well

Update

Finally I fixed the issue. Reason of the ES issue was python locales not configured right.
There are steps done by me to fix:
in chrooted environment ( /opt/retrosmc/tmp/locale_fix.sh) I created the following shell script with the following content:

#!/bin/bash

# Note: possible additional step - uncomment 'en_US.UTF-8 UTF-8' line from  /opt/retrosmc/etc/locale.gen
export LANGUAGE=en_US.UTF-8
export LANG=en_US.UTF-8
export LC_ALL=en_US.UTF-8
locale-gen en_US.UTF-8
dpkg-reconfigure locales

Then

chmod a+rx /opt/retrosmc/tmp/locale_fix.sh

Next

cp  /home/osmc/RetroPie/scripts/chroot.sh  /home/osmc/RetroPie/scripts/chroot-locales.sh
chmod +x /home/osmc/RetroPie/scripts/chroot-locales.sh

Edit the new file and replace line:

sudo HOME="/home/pi" /usr/sbin/chroot --userspec 1000:1000 “$INSTALLDIR/retrosmc” emulationstation

with

sudo HOME="/home/pi" /usr/sbin/chroot --userspec 1000:1000 “$INSTALLDIR/retrosmc” sudo -i /tmp/locale_fix.sh

Then run once

/home/osmc/RetroPie/scripts/chroot-locales.sh

Also I executed the “sudo /opt/retrosmc/tmp/locale_fix.sh” in native environment

Note: I’m not sure if it is optimal procedure and some steps can be removed, but after the above steps ES is working for me now

Ah, yes.
It should also be sufficient to add a LC_ALL=en_US.UTF-8 to the top of the emulationstation script and generate the en_US.UTF-8 locale in the chroot environment.

Edit: This happens to me too if I install on my nas. Not sure what is causing it though.

Thanks, but the roms file is not a folder it’s more of a file so there is no option for me to put the roms in, am I doing something wrong? Thanks for the help.

The same way you did with your GBA roms. How can /home/osmc/RetroPie/roms/ not be a folder? How do you navigate and manage files on your RasPi? SSH, FTP, SMB … ?

Went through this tutorial yesterday, and everything is working fine except when i try moving rom files from my windows pc to the rom folder in retropie i get an error stating i do not have permissions to that folder. I can put them in the retropie folder no probs, or anywhere else in the osmc folder. Any ideas ?

Please have a look some posts (pages?) back for the answer. If it still doesn’t work, use the method one post below.

In a nutshell: don’t use samba to copy them, use winscp, as it is able to follow symlinks.

This should be a symlink to the real roms folder. If it is broken or something, you can try to put them directly into /opt/retrosmc/home/pi/RetroPie/roms/psx

Worked like a charm, thanks for everything bud

yes there is a symlink

Hi, I just started using RetroPie, using the script, and I love it!

Just one thing isn’t really working for me and I hope you might have an answer for me.

I’ve tried this with both the Wired and Wireless Xbox 360 Controller and have the same issue. (Note I’m using the Receiver for Windows and the Wired controller is also made for Windows)
When I configure the controller mapping it doesn’t allow me to configure the Right Bottom, it just skips it, I can configure all the other buttons. Also the Xbox logo button, or whatever it is called, keeps blinking.

And one other question, is it possible to connect a USB hub to an Extended USB cable to one of the ports on the PI and it will still detect additional controllers?

Hope you can help. :slight_smile:

You got 2 working? I can’t seem to get more than one to be recognised. Did you install xboxdrv or no?