[HowTo] rtorrent instead of transmission (rewritten and tested)

Hi Toast,
thanks for your HOWTO. Maybe you want to edit the first post to change the location of the rt-service from /etc/systemd to /etc/systemd/system ?
With the original location the systemctl start rt command would fail.

Also I’d like to ask if the .rtorrent.rc config you suggest does actually use the complete/incomplete/watch directories you made us create.

Another observation: it is not reccommended to run rtorrent as root. Maybe it would be better to have the torrent directory tree owned by the same regular user such as osmc which might then use it ?

And a last question is about the rutorrent web interface … do you have instructions for that too ?

Take care

With Juon “google for RTorrent-Auto-Install-3.0.2-Debian-Jessie” and LAMB-service that is in beta testing, this worked like a charm.

there is this revolutionary thing called hyperlink that allows you to link stuff on the web mail wanna give that a go

It’s an install script that installs packages needed and compiles rtorrent+rutorrent (even installs apache + php, if not installed allready)

https://github.com/Kerwood/rtorrent.auto.install/blob/master/Rtorrent-Auto-Install-3.0.2-Debian-Jessie

The file is not available anymore on github. Is there a newer one r was it moved ?

Thanks

try this:

wget -O rtorrent_install.sh https://raw.githubusercontent.com/Kerwood/Rtorrent-Auto-Install/master/Rtorrent-Auto-Install-4.0.0-Debian-Jessie
chmod +x rtorrent_install.sh
./rtorrent_install.sh

The script works as expected. I’m wondering is it possible that I postopne the rtorrent service for a minute after startup? I don’t have enough linux knowledge on how to do that. Can anyone help me postopne rtorrent.service that is used in that script to postopne startup for a munute? The problem is because usb drive isn’t mounted fast enoug and torrents cant find files on ext drive, so I need to postopne rtorrent.

Thanks

sleep 60 add that :wink:

You should wait for the filesystem mount targets in systemd instead.

SSH into your device and do this:

sudo nano /etc/systemd/system/rtorrent.service

Under Description line add these two lines

After = remote-fs.target network-online.target
Wants = network-online.target

To save changes and exit: CTRL+x

Installed as per the sctipt above. It appears all went ok, but when I try to use the web interface (http://localhost/rutorrent) i get ‘file not found’ error in my browser. Any ideas how to fix this?

Since strethc upgrade i haven’t tested the script which was made for debian jessie.

The script devloper has gone for to Docker installation:

Here is a link where the developer, talks about it: Debian Stretch · Issue #184 · Kerwood/Rtorrent-Auto-Install · GitHub

Many thanks for help. Has anyone managed to successfully deploy rutorrent on Vero4K with Docker option?

I managed to install Docker, following Duncan’s post here: Docker support - #12 by Duncan

Then, finally following this guide GitHub - Kerwood/Rtorrent-LXC: A Docker container with Rtorrent + Rutorrent. I even managed to install the rtorrent+ allegedly rutorrent.

The problem is I am unable to launch webUI. I don’t even know what address should I use in my browser? Obviously htttp://my.vero4k.address displays only kodi web interface. I tried using different ports: 80, 8080, with no joy.

Oh, maybe this can help when I try to run rutorret the following error occurs:

root@osmc:/home/osmc# sudo docker start rutorrent
Error response from daemon: driver failed programming external connectivity on endpoint rutorrent (e7464d15e607426f43fa8f5c076dffb5b2a8320ac8d21de99aef5afa75016a5e): Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use
Error: failed to start containers: rutorrent

If someone was able to tame rtorrent on vero 4k, please let me know how it was done;) all help much appreciated!:wink:

since i dont have it installed i dont know where to change port which eever webserver that comes with the docker package. What i have done, since stretch, is to use debians rtorrent and flood node.js server, was a bit to setup but works properly screened, both processes.

Edit: Read that it was apache, but there was some instructions here GitHub - Kerwood/Rtorrent-LXC: A Docker container with Rtorrent + Rutorrent. where you say 8181:80, which i guess is where you point the webserver to another port.

I didn’t understand half of your post… but;), see following errors I encountered ever since trying to get this working:

root@osmc:/home/osmc# sudo docker create --name=rutorrent
–restart=always
-v /home/docker/rutorrent/config:/config
-v /home/docker/rutorrent/downloads:/downloads
-e PGID=1001 -e PUID=1001
-e TZ=Europe/London
-p 80:84 -p 5000:5000
-p 51413:51413 -p 6881:6881/udp
linuxserver/rutorrent

and

Error response from daemon: Conflict. The container name >"/rutorrent" is already in use by container >“70607159724c23d31b6fb386545c5df7380a55bfba01bdd7ae2568e>4de2205cc”. You have to remove (or rename) that container to be >able to reuse that name.

I feel this is really simple to fix as both Docker and rtorrent/rutorrent ui appear to be installed with no errors.

It seem it is a configuration issue but then again, I’m a noob;)

I really want to get utorrent working as transmission has limited torrent management options.

Many thanks for help.

another stab in the dark 80:84, should be like 8192:80. then you should be able to connect to your web-ui with http://ip.of.your.osmc-device:8192, change to your lan ip:8192, if that doesn’t work try the otherway around, like 80:8192.

Never worked with docker contianers so i’m just guessing

You already have a Docker container called rutorrent

Do:

docker ps -a
docker stop …
docker rm …

docker run -d -p 6881:6881 nivepl rutorrent

Sam, much appreciated you joined the conversation.
So I get the following:

osmc@osmc:~$ sudo su
root@osmc:/home/osmc# docker ps -a
CONTAINER ID        IMAGE                   COMMAND                  CREATED             STATUS                     PORTS               NAMES
70607159724c        linuxserver/rutorrent   "/init"                  3 hours ago         Created                                        rutorrent
409371317bef        kerwood/rtorrent-lxc    "/startup.sh"            3 hours ago         Exited (1) 3 hours ago                         rtorrent
a7dec196251b        docker                  "docker-entrypoint.s…"   4 hours ago         Exited (125) 4 hours ago                       rtorrent1
2f6a2d1a7271        armhf/hello-world       "/hello"                 4 hours ago         Exited (0) 4 hours ago                         nervous_austin
root@osmc:/home/osmc# docker stop …
Error response from daemon: No such container: …
root@osmc:/home/osmc# docker rm …
Error: No such container: …
root@osmc:/home/osmc# 
root@osmc:/home/osmc# docker run -d -p 6881:6881 nivepl rutorrent
Unable to find image 'nivepl:latest' locally
docker: Error response from daemon: pull access denied for nivepl, repository does not exist or may require 'docker login'.
See 'docker run --help'.

As far as I understand, “…” is container id of rutorrent.

Yes. It’s meant to be substituted.