[HowTo] Spotify-Connect support via Raspotify (LibreSpot)


Is there any solution for osmc on the Vero4k?


Not sure if it’s any help (tbh I’ve only skimmed through this thread) but I’m using marcelveldt’s Spotify for Kodi add on with my Spotify full trial on my Vero 4k. Working fine, automatically defaults to high quality bitrate.

You’ll need to install from marcelveldt’s repo: https://github.com/marcelveldt/repository.marcelveldt/raw/master/repository.marcelveldt/repository.marcelveldt-1.0.1.zip

Full details here: https://forum.kodi.tv/showthread.php?tid=265356

Apologies if it’s already been mentioned.


That’s a whole Spotify Client in Kodi, solutions like that for Kodi existed for a while. But thanks anyway.

The whole idea of Spotify Connect is that you use the UI of your (mobile) device and audio will simply output via Vero.



Since there is no other solution for the Vero, I tried this addon. Unfortunately, you need a browser on your device to login. This should not be necessary for Spotify-Connect. LibreSpot/Raspotify also do not require login (but it only works with Premium).

For now we have to wait for OSMC to implement basic support for LibreSpot.


@pulham @MelBourbon @djisou @shoupresse @Chillbo @dabraun88

Spotify-Connect WORKS on the Vero!
You just have to install it differently. I have updated the first post, including the instructions for Vero (tested on the Vero4K which is directly connected to a receiver via HDMI).




I installed with vero 4k and it works with The default settings. But editing the /etc/default/raspotify file does not make anything change. Name, bitrate, hw, etc.

I just re-installed omsc and that didn’t work.

Any ideas?



I have the same impression. Also this evening it crashed several times. Mostly at the time the screensaver wants to start. I got a sad face and restart. Music is only stopping short and repeat playing after restart.


Hey, thanks a lot for this. It worked immediatly on my raspberry pi 3. I have a little issue though, when my pi is connected to cable and wifi is turned of it connects, when my pi is connected with wifi then it doesn’t connect. Any idea why ?


I just install Raspify. Everything works fine. Raspotify plays from HDMI.

But now i want to play from 3,5mm jack. In OSMC i tried settings>system>audio options and set to analogue. Now I have audio from mediacenter in audio, but from raspify goes audio still from HDMI.

I experiment with OPTIONS="–device hw:" but still now success.

Can you help me please ?


Seems logical to me. The service is broadcasting it’s availability. You change IP address, so it won’t work anymore. You probably need to restart the service.


Try no --device option at all. Just comment it out, like this:
#OPTIONS="--device hw:0"

Remember to restart the service.

If that doesn’t work please show me the output of aplay -L


Maybe i’m doing some mistake, but when i log via ssh login:osmc pass:osmc and type aplay -L i get command not found.


try this command:
sudo apt-get install alsa-utils
and then
aplay -l

i have the same problem as you. Raspberry Pi3 with OSMC and spotify play only on hdmi source. My dream is spotify via jack 3,5mm.

My list:
osmc@osmc:~$ aplay -L
Discard all samples (playback) or generate zero samples (capture)
bcm2835 ALSA, bcm2835 ALSA
Default Audio Device
bcm2835 ALSA, bcm2835 ALSA
Default Audio Device
bcm2835 ALSA, bcm2835 ALSA
Direct sample mixing device
bcm2835 ALSA, bcm2835 IEC958/HDMI
Direct sample mixing device
bcm2835 ALSA, bcm2835 ALSA
Direct sample snooping device
bcm2835 ALSA, bcm2835 IEC958/HDMI
Direct sample snooping device
bcm2835 ALSA, bcm2835 ALSA
Direct hardware device without any conversions
bcm2835 ALSA, bcm2835 IEC958/HDMI
Direct hardware device without any conversions
bcm2835 ALSA, bcm2835 ALSA
Hardware device with all software conversions
bcm2835 ALSA, bcm2835 IEC958/HDMI
Hardware device with all software conversions


@kajzer That should actually work.

If you run aplay -v /usr/share/sounds/alsa/Front_Left.wav -D hw:0; aplay -v /usr/share/sounds/alsa/Front_Left.wav -D hw:1 what do you hear on what device?


when I run this command:
aplay -v /usr/share/sounds/alsa/Front_Left.wav -D hw:0
I hear voice in my monitor via hdmi
when I run:
aplay -v /usr/share/sounds/alsa/Front_Left.wav -D hw:1
I have this:
ALSA lib pcm_hw.c:1713:(_snd_pcm_hw_open) Invalid value for card
aplay: main:788: audio open error: No such file or directory
and still silent via jack.


Hi, I try to installed it on Vero4K, following the updated instructions of the first post.
Raspotify service is active. But I cannot see the service in myOSMC.
Any idea ? many thanks


Try this solution:


My OSMC only displays services that it knows about.

There would need to be an entry in /etc/osmc/apps.d/


many thanks for fast reply ! now I can see it … but I cannot see the OSMC device appearing.