I/O error- unable to transfer files via Samba from Windows PC or FTP

Vero 4K has 3 USB hard drive enclosures. All drives are NTFS and worked the same day I disconnected the previous HTPC before connecting to the Vero.
Samba enabled on Vero.
Windows 7 PC can see all drives via the OSMC network location.
Attempt to transfer a large file (40+gb) fails giving the I/O error seen in previous posts:
Copying file from windows PC to HD on vero results in network error - #24 by fzinken.

An unexpected error is keeping you from moving the file. If you continue to receive this error you can use the error code to get help with this problem.
Error 0x8007045D. The request could not be performed because of an I/O device error.

I setup FTP client successfully on the Vero and connected from the PC, I can see the media drives using the /media/ folder and my HDDs.
Transfer fails giving ‘553 Could not create file.’ error. Do I need to enable read/write access for FTP? If so, how do I do this?
Do I need to set permissions on the hard drives from the Vero? I tried from my PC but it wouldn’t stick.
Is the file size an issue? Perhaps I need to get one of the usb to gigabit ethernet adapters? Don’t think so, but just spitballin’ here.
I’m still working on figuring out log files, and what to enable.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Thanks, after father’s day activities this weekend, troubleshooting will resume today.

Log uploaded here: http://paste.osmc.io/apisosocuc.md
FYI: it had the full library scraping in there, I’ve removed most of that, there were no errors other than a few that weren’t able to be scraped so I don’t believe they’ll be relevant.

  • Can you try with one disk connected a time only?
  • It’s NTFS formatted, which can be a bit picky. Can you try and repair the disk in Windows?

How are you transferring files? Samba?


I’ll try, but I’ve never heard that ntfs can be picky…and yes using Samba.
OSMC shows up on my Windows pc immediately after I installed samba on the Vero.

Narrowed it down to the Vero not picking up one of my enclosures, not sure if it’s not waiting for the drives to spin back up or what…for now, I can either power down the enclosure and power it back, or I can reboot the Vero and they reappear as available and I can transfer files and play them in Kodi.