Impossible to change static ip in wired connection

Hello, i need to change my static ip on wired connection but i cannot do it:
If i try to do it from the UI when i click apply the old configuration come back;
if i try click on dhcp it do nothing;
if i try to use conman it say the eth device is not supported.
if i change the conmann configuration on /var/lib/connmann/ethernet_macaddress_cable it reset on reboot and do nothing.
I cannot change the router configuration because it’s not mine.
What can i do more?

Is the device up to date? Some logs would help

yes it is, to be honest i’m not sure about how to make logs, can you help?

Can i use this istructions How to submit a useful support request whit eth only then switch to wifi to get the url?

I got a problem in wifi too because i don’t see my wifi wlan, i need to use the other router,the same of the dhcp and internet, with a wrost signal , i don’t know why.

1 Like

Yeah follow log part and add too here added logs in relevant information

i cant upload the logs from osmc, i don’t know why.
I found this 2 logs, hope it can be helpful.
Upload Files | Free File Upload and Transfer Up To 10 GB for uploadlog.txt
Upload Files | Free File Upload and Transfer Up To 10 GB for kodi.old.log

There are some weird things, for example i cannot ping the raspberry connected with wifi and i cannot log on ssh.
If i use the cable i can do it but i need to change the ip of my computer because it is on a different net

PS: i upgraded the log’s links

The File says it is deleted.

suggest to check if other changes on the SD Card survive a reboot.
Use nano /home/osmc/test.txt and add some text (CTRL-X to end). Reboot and run again the nano command to check if the file still include the text.


i’m sorry, there are 2 new links
Upload Files | Free File Upload and Transfer Up To 10 GB for uploadlog.txt
Upload Files | Free File Upload and Transfer Up To 10 GB for kodi.old.log

The file still there after the reboot

Can you upload full logs via My OSMC? You can save the logs to /boot if there is no connectivity.

Hello, thanks for the help, it is not the uploadlog.txt? I can try again tomorrow

I found the time to try again the process for logs, this time worked.

i tryed to change the ip of enxb827eb3e53f7 from to and the gateway form to but when i click apply it reset

Are you using a DHCP server on your local network ?

Yes there is one on a router not mine.
I can’t switch to DHCP, it do nothing on wired connection.

Well if this router is active with a DHCP server (which assigns IP addresses to devices with a MAC address) then it will be assigning its own IP Addresses, which will over ride any you may set manually on the vero/osmc.

So to set them manually you will need to disable this DHCP server on the router. Why do you need to change the IP addresses asignments anyway ?

Have you tried a different ethernet cable or plugging it into a different location to rule out an issue with your physical connection?

The problem is that the router is on another network, the ip of osmc Is manual on but I need to change IP in to go on internet .
If I try to go with DHCP it stay on manual, if I change IP it reset on apply.

Actually no, because I used every time this port. I changed cable without any different behaviour. I’ll try tomorrow to change port.

Did you try using an internet proxy server ?

i tried different cable and different port but it is the same, i can’t use dhcp or change the manual configuration writed some time ago

No, but i can’t cange ip and gateway so i can’t go on internet with cable, anyway if i change the ip of my computer i can enter the rasp with ssh and do things, so the ip + eth is working.
For now i use the wifi that’s work but the signal is low.

I’m starting to thing about format everithings :frowning: