Install failed: can´t mount root

hallo all

whenever i try to install on my raspberry pi model b+ i get this “install failed: can´t mount root” right after formatting

here is what i have tryed:
different psu
different sd card
different raspberry pi
disconnect every usb stick/kable/keyboard
re-download image ( many times)
reinstall osmc onto the sd card(s) (many times)
download the image without the installer and use USB image tool, to install osmc to the sd card
only thing i can think of is that is something wrong with OSMC RC for the Raspberry pi b+ (raspberry pi 1)

btw i heard that RC2 soon will come out, is that right?
and can i update my pi 2 with RC without install or even ssh when a new version is released (like a RC 2)?

no one???

I’m having the same problem. I’m using RaspberryPi2
All I have found so far was that my microSD card could be faulty.
Apparently I’m starting think that the OSMC has a bug.

I have tried different microSD cards and even tried RaspberryPi1 but still the same result. I have tried installing for example NOOBS on the SD and that worked. Looks like RPi and microSD cards are working.

… and there’s my output of the install.log which seems to be the same for everybody else.

Thu Jan 1 00:00:09 1970 Starting OSMC installer
Thu Jan 1 00:00:17 1970 Detecting device we are running on
Thu Jan 1 00:00:17 1970 Mounting boot filesystem
Thu Jan 1 00:00:17 1970 Trying to mount to MNT_BOOT (/mnt/boot
Thu Jan 1 00:00:17 1970 Using device.boot: /dev/mmcblk0p1 and FS: vfat
Thu Jan 1 00:00:17 1970 Preseed file found, will attempt to parse
Thu Jan 1 00:00:17 1970 Found a definition for storage: usb
Thu Jan 1 00:01:25 1970 Creating root partition
Thu Jan 1 00:01:26 1970 From a root partition of /dev/sda1, I have deduced a base device of /dev/sda 
Thu Jan 1 00:01:26 1970 Must mklabel as root fs is on another device
Thu Jan 1 00:01:26 1970 Going to mklabel with device: /dev/sda with a label type of MSDOS
Thu Jan 1 00:01:27 1970 Calling mkpart for device: /dev/sda and fs: ext4 with start 4096s and end 100% 
Thu Jan 1 00:01:28 1970 Calling fmtpart for partition /dev/sda1 and fstype ext4
Thu Jan 1 00:01:28 1970 
Thu Jan 1 00:01:28 1970 Mounting root
Thu Jan 1 00:01:28 1970 Trying to mount to MNT_ROOT (/mnt/root
Thu Jan 1 00:01:28 1970 Using device.root: /dev/sda1
Thu Jan 1 00:01:28 1970 Error occured trying to mount root of /dev/sda1
Thu Jan 1 00:01:28 1970 Halting Install. Error message was: can't mount root

No one have a answer for this?

RC2 was released today could be worth another try, I remember seeing something about install issue being resolved



I have been reading this thread. A few answers would help work some things out

  • How large is your SD card?
  • How did you image the SD card (Windows / Mac / Linux? Using OSMC installer)?
  • Did you set any networkin settings or a USB install?
  • Are you an ‘Administrator’ on you PC if running Windows?

The logic in the installer should be very robust. It’s serviced many an install and I suspect this would be more widespread if there was a bug.


Hallo sam,
I tryed with both a 2GB, 8GB and 64GB SDCARD

Windows 8.1 64bit with osmc installer

No usb, and no network settings,
And yes im admin

Is it possible for you to try another PC? It may be something to do with how the SD card reader interfaces with your computer


I can try another pc, but i used the same pc for my RPI 2 a mounth ago, and it worked fine

Will try when i wake up, and i will report back
(the time is currently 02:10 in denmark)

1 Like

hallo again Sam
i just tried with another PC to install OSMC RC2 onto 3 different SD cards to the RPI B+ (model 1)
and all i get was:

Install failed: can´t mount root
i am now tryin to install onto a usb stick (ofcause via sd card)

Hallo again sam
i just SUCCESSFULLY got it to run of an USB stick/pen

so its eighter the 3 sd cards i have thats broken or the 2 computers??? (wich is highly unlikely)

its running smoot now
so now is there any way to move the entire installition of OSMC from the usb to the sd card???

Hi everyone,
I have the same problem with a RC2 and I have a RP2 also. With USB no problem. With the SD Card (32Gb): Install failed: can’t mount root.

I’m using OpenSuse 13.1 and installed OSMC via osmcinstaller.
Both RC1 and RC2 didn’t work for RaspberryPi1 and RaspberryPi2.

The program itself was started as root (normal user didn’t have rights anyway).

Currently what I did and because of what I managed to start the installation.

this is to show what device name the usb stick has (i’m using micro sd card inside usb 2.0 adapter)

# fdisk -l

Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048    31291391    15644672    c  W95 FAT32 (LBA)

Then remade the partition

# fdisk /dev/sdb

Command (m for help): p

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048    31291391    15644672    c  W95 FAT32 (LBA)

Command (m for help): d
Selected partition 1
Partition 1 is deleted

Command (m for help): n

This part meant hitting enter couple of times :slight_smile:

Partition type:
   p   primary (0 primary, 0 extended, 4 free)
   e   extended
Select (default p): 
Using default response p
Partition number (1-4, default 1): 
First sector (2048-31291391, default 2048): 
Using default value 2048
Last sector, +sectors or +size{K,M,G} (2048-31291391, default 31291391): 
Using default value 31291391
Partition 1 of type Linux and of size 14.9 GiB is set

Command (m for help): a
Selected partition 1

Command (m for help): p

Disk /dev/sdb: 16.0 GB, 16021192704 bytes, 31291392 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x000b7709

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048    31291391    15644672   83  Linux

Command (m for help): t
Selected partition 1
Hex code (type L to list all codes): c

WARNING: If you have created or modified any DOS 6.xpartitions, please see the fdisk manual page for     additionalinformation.

Changed type of partition 'Linux' to 'W95 FAT32 (LBA)'

Command (m for help): p

Disk /dev/sdb: 16.0 GB, 16021192704 bytes, 31291392 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x000b7709

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048    31291391    15644672    c  W95 FAT32 (LBA)

Command (m for help): w
The partition table has been altered!

Calling ioctl() to re-read partition table.
Syncing disks.

# mkfs.msdos -F 32 /dev/sdb1 -n Verbatim
mkfs.fat 3.0.22 (2013-07-19)

Now I wrote the image to usb. Didn’t use the installer this time.

# dd bs=4M if=OSMC_TGT_rbp2_20150412.img of=/dev/sdb

# sync

… and now finally I got it to work.
For me this setup seemed to work.

Edit: This solution worked for both RPi1 and RPi2. The coolest part is that my “most-probably-DOA” microSD cards work also perfectly :smiley:

I ordered my first raspberry pi 2 with 16gb sd card, and I had no issues at all.

Then I bought a new raspberry pi 2 without sd card, and ordered a couple of cheaper micro 8gb sd cards (turned out they were only class 4) and they all failed, from the same windows 7 laptop, same sdformatter settings, same oscminstaller.exe, same RC2, and even the same sdcard adapter.
The message is always: “Install failed: can’t mount root”

I’m not sure if it is the class4 or the brand of the sd card.

Luckily I found another type of 8gb sd lying around, and now with this same process it all worked fluently again

Hi, my Raspberry pi2 was working fine from last couple of months, just last weekend, I wanted to set-up as wired instead of wireless, I tried re-installing new windows image file ‘OSMC_TGT_rbp2_20150519.img.gz’ and was never successful, getting msg. Install failed: can’t mount root.

Using same earlier:
16 gb Lexar 633x micro HC1 SD card
Raspberry Pi 2 Model B 1GB
Same HDMI and micro USB cable - powered directly from board (earlier from TV was working too)
Same Windows 7 laptop - to download, extract and run the exe file.

I remembered earlier, the Windows installer from the site was working and was directly installing on the SD card.
Now the Windows installer is not working, downloading the above image file, extracting the exe and then running from windows 7 laptop - NO success.

Also tried unzipping the file in separate folder and then copying these following files on the SD card, after switching on rp2 and TV gets the error msg. install failed: can’t mount root.


your advice will certainly help in getting this running back.
Regards, S.

I think Lexar cards are potentially problematic at the moment. Can you try another card?


does that include cheap chinese cards (like the onces from thats problematic also???

Those are problematic because they just suck


1 Like

Thank you all, I went through complete thread and thought may be I was missing something while installation, and that was correct.

One thing OSMC works flawlessly! you need to be careful do not miss any step.

Worked for me with the same setup i.e. laptop, SD card, pi2, cables and network.

Earlier my mistake was at step# 14 I was selecting ‘NO’
And I also remembered that I have issue with my laptop, that one of the USB port do not work with Lexar USB stick drive the one I had (laptop freezes - HP Pavilion g6 - Intel i3). This could be the USB 3.0 port, therefore I used another USB port for OSMC setup on SD card.

Following are the steps I followed for setup:

  1. Login as Administrator to your Windows machine
  2. open browser - Download - OSMC
  3. select - Raspberry Pi
  4. select - Windows
    5)Click on link: self extracting installer - save osmc-instller.exe - to one of the folder on your pc.
  5. Run osmc-instller.exe
    7)OSMC installer UI opens on the screen - select/configure the options as per following:
    8)Language: English and install OSMC on?: Raspberry Pi2 - NEXT
    9)version: RC3 - NEXT
  6. Install OSMC: on an SD card - NEXT
  7. Networking: select either wired/wireless both works - NEXT
  8. Device selection: select the drive with SD card - NEXT
  9. Lic agreement: I accept - NEXT
  10. Downloading: msg. popup window: Do you want to re-download this image? - YES - Download begin - please wait!
  11. Confirmation msg. popup window: Are you sure …install OSMC …device? - Yes - installing begin - please wait!
  12. get msg.: Congratulations - click - quit

Verify on SD card following 08 files are installed:

insert SD card in Raspberry pi2, power-on and enjoy!

lel they DO suck :smiley: