Install NextCloud on Raspberry OSMC

#1

Hi.

I’m trying to install NextClod on my OSMC raspberry device. NextCloud need php7.1 at least but the stretch repositories only has php7.0.
On my test, I changed main repository to “buster” to install php7.3, but I think I had broken dependencies to the end.

Anyone run nextcloud with OSMC? If yes, how?
Thanks

#2

Note that this is unsupported, but i did it before and didn’t notice any stability problems.

1 Like
#3

Thanks.
What version of libcurl you have installed?

I get this message when I try install “php7.3-curl”:

    The following packages have unmet dependencies:
    php7.3-curl : Depends: libcurl4 (>= 7.44.0) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
#4

Sorry to say, I installed php7.2, it was a while ago so Nextcloud just needed 7.2

#5

Ok. I’ll do that