Install question - Stuck at welcome - no user input

Pi version 1, Class 10 SD card. I can load and boot into raspian and have mouse keyboad control but when I try and load OSMC (or Xbian) I get stuck at the welcome - language selection screen. The KB is being read and I get sounds but no reaction onscreen. When I attempt to use the Mouse I see a white triangle up left corner but no cursor. Do I need to enable KB and Mouse control somewhere?

Reboot and see if you have any joy (pull power)

Nope same screen.
Welcome Afrikaans…”

This try was using the IMG file. I will try again with the installer.

Still stuck. I know the network is up because it updated scrapers. I know it’s not this specific KB or mouse because I have tried others. Next I will try a powered USB hub.

No KB response with powered hub.
I’m out of ideas for tonight. I may borrow a different Pi and try again.

There is currently no mouse support in the skin so you won’t be able to use that. As for keyboard, have you tried pressing right before you press down ?

There is no input support period that I see. Keyboard num-lock toggles but zero input ability.
Back to the drawing board guys. This latest version 10.1 fails in every way.

You have some local problem. Try to re-image, try another power supply, try another sdcard.

You are most certainly an exception while you attempt to insinuate that your experience is the rule.

You probably inserted your remote controller after OSMC started. This will be problematic (LIRC socket). Reboot and try again. Start a new thread if the problem persists.

I’m sure we’d have some more reports if there was a widespread issue.

A post was split to a new topic: Install question - Stuck at welcome - no user input - not related