Installing Ajenti

I’m running OSMC on a Raspberry Pi. I installed Ajenti using the guide at http://support.ajenti.org/topic/349864-installing-on-debian/. I tried both the automatic and manual approaches but I cannot access Ajenti on <IPAddressOfRaspberryPi>:8000. I can access SSH, web servers and other ports so it’s not a network issue. I’m a newbie to Debian so any help is appreciated.

i used my approach the raspbian installation instead of the debian it worked

found that Eugenes methods arent perfect all of the time kinda missing deps for ajenti on minimal distrobutions

http://support.ajenti.org/topic/436874-installing-on-raspbian/

try that one thats my contribution to Ajenti :smile:

if it doesnt work i promise to make it work :smiley:

Neither of the install methods for Raspbian appear to work for OSMC. Any other suggestions?

sudo -s
apt-get install libevent-dev
apt-get install greenlet-dev
pip install -U gevent
pip install -U greenlet --allow-external greenlet --allow-unverified greenlet
pip install -U psutil
pip install -U gevent-socketio
pip install -U gevent-websocket
pip install -U ldap
/etc/init.d/ajenti restart

got mine running with this, make sure to have build tools etc installed

I tried these commands but Ajenti is still not accessible. What do you mean by “make sure to have build tools etc installed”?

Woah hadn’t heard about ajenti, looks awesome! Will try this.

Also @Toast how do you have time to help everyone with literally everything? Kudos!

Not getting it to work here,
apt-get install greenlet-dev fails (can’t find package), works with apt-get install python-greenlet-dev
pip install -U ldap similarly fails but works with pip install -U python-ldap but the install then fails with

    In file included from Modules/LDAPObject.c:9:0:
Modules/errors.h:8:18: fatal error: lber.h: Filen eller katalogen finns inte
 #include "lber.h"
                  ^
compilation terminated.
error: command 'arm-linux-gnueabihf-gcc' failed with exit status 1

----------------------------------------
Rolling back uninstall of python-ldap
Command "/usr/bin/python -c "import setuptools, tokenize;__file__='/tmp/pip-build-wYypvD/python-ldap/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-N0cUTe-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-wYypvD/python-ldap

(“Filen eller katalogen finns inte” = No such file or directory)

EDIT:

sudo apt-get install -y python-dev libldap2-dev libsasl2-dev libssl-dev

fixes the installation error but still can’t access ajenti. I think the error message before was that the server wasn’t found, now the server is busy… Progress! (kinda)
Suggestions?

sudo apt-get install libldap2-dev
sudo apt-get install libsasl2-dev

or

sudo apt-get install python-ldap

btw hsus ? swede ?

short answer: Beer, thats how i find time :stuck_out_tongue:

Already ran those! (must’ve missed the update to my post)
That fixes the installation error but still can’t access ajenti. I think the error message before was that the server wasn’t found, now the server is busy… Progress! (kinda)

Oh and yeah, Swedish, saw your Github handle and guessed that you’re Swedish as well :beers:

simplest solution when running into issues with pip grab the line it fails on like .h files then install that dev package and run again :slight_smile: thats how shit works :smiley:

now i need more beers :stuck_out_tongue:

Haha but this time it didn’t do the trick? So what’s the beer telling you to tell me to tell the shell to do?

EDIT:
Disregard this. Wasn’t beered up. Forgot the “s” in https…

I can connect to the web interface but the content doesn’t seem to be loading, also since installing Ajenti I’ve been experiencing (more frequent) random freezes, removing the init script for now. It looks cool though, and I think OSMC would benefit from having some sort of easy web interface like a cross between this and htpc manager. Thanks for all your help :slight_smile:

hmm you could bug report that to ajenti

I would, if it wasn’t for me having sort of a feeling that part of this must be a hmm how should I put it… “human error” (I must’ve mucked something up)