iPlayer plugin version out of date (Broken)

The version of the iPlayer plugin in the OSMC repository is 3.x. This has stopped working due to changes that the BBC have made.

There is a new version (4.0) in the kodi repository.

Please update.

The OSMC repository is identical to the Kodi repository and already has the latest version.

We have the v4.x version: http://download.osmc.tv/kodi/addons/matrix/plugin.video.iplayerwww/.

You may need to update the repository on your device.

How do I force a repository update??
Tried OSMC → Updates → manual → Update

No updates available.

I couldn’t find any way to force a repository refresh, so downloaded the add-on zip file from the URL above.

Trying to load this fails with this error message:

ERROR: CAddonInstallJob[plugin.video.iplayerwww]: The dependency on xbmc.python version 3.0.0 could not be satisfied.

It looks like the new plugin requires Python 3 (which comes with Kodi v19). There is no newer version for Kodi Leia (18.x).

ETA for v19 on OSMC ??

(I was wondering why it was working on my Macbook but not on the R-Pi)

There are already v19 test builds. There are some implications for Pi. Have a look here: Kodi v19 Matrix is here. Here's what you need to know - OSMC.

Sam

Hi Sam,
Many thanks for the reply and link to the info on Kodi 19 and Python etc.
Being a simple soul all I want to know is what I must do to get iPlayerWWW working again.

If I cannot do this now how long do I have to wait? If I cannot solve this now the Vero 4K looks like heading for the bin.

Simple instructions would be appreciated as I tried all the updating that is readily available and there are no updates available.

Thanks,
Budgie

You can install Kodi v19 today which will fix your iPlayer issue.

The instructions are in the first post of the v19 test thread. Do keep in mind that v19 is a little rough around the edges.

It seems a bit extreme to throw the device in the bin, particularly when the new version of Kodi will be released as a stable update quite soon.

Hi Sam,
Many thanks. Will try the v19 test as you suggest. I am not asking much of this Vero and I agree binning it would be premature. Trouble is technology moves faster than me these days and I have drawers full of kit which is no longer supported, like 32 bit laptops for example, although antiX is doing a great job.
Thanks again,
Budge

Budgie – It is frustrating, but I think Sam is coping as well/fast as he can.

I think in your original post you said that you were not particularly technical, but trying to keep it simple, this is what the “problem” is:

The BBC keep changing the way their streaming, particularly the HD live streaming works.
The last set of changes were to remove some of the older types of stream, and move to the latest version. The latest version has the big advantage (when it works properly) of having multiple streams of the same thing, but at differing resolutions. Each stream is chopped up into packets. The higher the resolution, the bigger the packet.

On the viewer side the software looks at how fast it is able to download a packet.
If it is falling behind, rather than freezing the video and putting up the dreaded “Buffering” message, it switches to a lower resolution stream. It adapts automatically to your network speed, in close to real-time, so if it starts running slow, you just get a lower resolution picture until the speed picks up again, and then it will switch to higher resolution.

The iPlayerWWW plugin didn’t use this until very recently, partly because of a bug in Kodi itself, which needed to be fixed. When the BBC turned off the older streams, fixing that became a priority, and it was fixed, and new version of iPlayerWWW was created to use it.

That work was done on Kodi 19. Unfortunately, Kodi 19 used a different version of the Python programming language (Python is evil, it should just die, they bring out new versions and break code already written for the previous ones). So the add-on only worked in the newest version of Kodi. A version was created, back-porting the code to Kodi 18. That is the one you and I are using.

It worked fine until something changed - I would put money on it being a change at the BBC - that broke it. Interestingly, the Version for Kodi 19 is still working ok. It isn’t clear to me if the problem is in Kodi 18 or in the iPlayerWWW add-on for that version.

So that is the breakage … the fix sounds simple, move to Kodi 19, but as Sam pointed out, that has its problems too, since the Kodi team have changed the way video is processed, and in doing so made a lot of the hardware acceleration unusable.

As you can (I hope) see, Sam is in the middle of a lot of things he has no control over, just working hard to try to mix and match all these changes into something that works,

I know that doesn’t get you BBC News, but it hopefully helps you to understand what is going on.

As a workaround, there is always the same VPN that you are using for your OSMC and you laptop browser pointed to: https://bbc.co.uk/iplayer

2 Likes

Hi and thanks for the further info and interesting background.
I agree Sam is doing brilliantly; no complaints from me.
Will try the new version and see how it runs over the weekend.
Thanks again to you and of course Sam.
Budge.

The update failed quite early in the process but didn’t give me much info.
Will try a bit more, read the thread and then upload logs if appropriate.

Meanwhile one question regarding the update instructions which as me to add deb http://apt.osmc.tv buster-devel main to the sources.list file. Done that but will there now be a possible conflict unless I remove deb http://apt.osmc.tv buster main’ ?
Just asked.

I have a stack of errors, for example:-

BlockquoteGet:15 http://apt.osmc.tv buster-devel/main armhf vero3-bootloader-osmc armhf 1.7.0-1 [2,127 kB]
Get:30 http://ftp.fau.de/osmc/osmc/apt buster-devel/main armhf vero3-device-osmc armhf 1.5.0 [6,644 B]
Err:15 http://apt.osmc.tv buster-devel/main armhf vero3-bootloader-osmc armhf 1.7.0-1
File has unexpected size (6644 != 2127076). Mirror sync in progress? [IP: 131.188.12.211 80]
Hashes of expected file:

  • SHA256:e05e2361def77a38789bddeadedcce5113e89c02b3d1194c70a27ff2f3642ac7
  • SHA1:e84f5337df6505c3ff20d95b1e291a64b7396bc4 [weak]
  • MD5Sum:5b994560810a3015d6ef1eeb0e5b1d2f [weak]
  • Filesize:2127076 [weak]
    Err:30 http://ftp.fau.de/osmc/osmc/apt buster-devel/main armhf vero3-device-osmc armhf 1.5.0
    File has unexpected size (6644 != 2127076). Mirror sync in progress? [IP: 131.188.12.211 80]
    Hashes of expected file:
  • SHA256:3cb32c6159f4bde14efed944de5dfbb9fd6fd2151a190e1ff7ed4020999742fb
  • SHA1:c2de401d6fb9fcd5ca6c27c6920a43b23e10a6b0 [weak]
  • MD5Sum:b470f9c93fadfd0d841235c13bcbe4be [weak]
  • Filesize:6644 [weak]
    Fetched 29.7 MB in 50s (591 kB/s)

Blockquote

Not much help but even my update downloads failed so will wait for a while. Perhaps repo site is being edited?
Budgie

Try reboot and make sure your time is correct

Hi Sam,
Good news and bad.
The good news is that after coming back to this the update ran OK or appeared to do so.
The less good news is I have lost my display.
I am now only able to work on device using ssh on terminal from my laptop.
I appreciate you are busy so will be patient but where to look to get HDMI back up would be start. Will do some searches.
Regards,
Budge.

Upload logs via grab-logs -A and share the URL for us to check.
Also could try to delete guisettings.

systemctl stop mediacenter
rm .kodi/userdata/guisettings.xml
systemctl start mediacenter

Cannot see anything wrong with system. Not entirely sure of my HDMI connection as it uses an HDMI > DVI converter plg so will take whole lot to another display. Meanwhile I tried to upload the log file and received an error message that the file type is not permitted! For a log file!!!?
This is what I want to send:- /home/osmc/.kodi/temp/kodi.log.
https://paste.osmc.tv/ecudenunoc
Hope this helps.

Hi and thanks for the reply.
I tried moving to where there is an HDMI TV and Vero 4K seems all ok so I guess it is an issue with my display. What used to work no longer does. Trouble is the display has “intelligent” source selection and byzantine button logic. Will read manual again and meanwhile many thanks for the reply.
Budge

It’s probably not related to your current problem but I’d recommend that you remove the network-manager packages since they will conflict with connman:

ii  network-manager                      1.14.6-2+deb10u1                    armhf        network management framework (daemon and userspace tools)
ii  network-manager-openvpn              1.8.10-1                            armhf        network management framework (OpenVPN plugin core)
ii  network-manager-openvpn-gnome        1.8.10-1                            armhf        network management framework (OpenVPN plugin GNOME GUI)