IR Remote not working when watching video

Just got a Vero 4K+ and trying to get it to work with my Logitech Harmony 665 IR remote. It looks like I am running the August 2021 2021.08-1 build on the Vero.

I configured the remote to act like an xbox 360 remote and set the remote type in osmc to xbox360-lircd. The remote appears to work ok in all the menus but as soon as I start playing a video (over UPNP if it matters) the remote stops working. The remote that comes with the Vero does not have this issue (it works all the time). If I pause the video using the Vero remote then the Harmony remote works again. Start the video and the Harmony remote stops working again. Something about playing video seems to be interfering with the remote. I tried using the IR extender but saw the same issue, although I don’t know if there is some way to verify that the extender was actually being used. I don’t see this issue when playing music, only when playing video.

By turning on debug logging and using “irw /var/run/lirc/lircd” from an SSH session, it looks like lirc is not working properly when video is playing. When video is not playing, I see events in the log and from irw almost every time I push a button on the remote. Once I start the video, there are seldom any events in the log or from irw for button pushes. Every once in awhile one will work but most of the time there are no events when I push a button until I stop the video.


Do you experience this problem with the version of OSMC we shipped (November 2020)?
Kodi v19.1 still has a couple of quirks and this might be one of them.


I did some more experimentation and it appears to have something to do with mpeg2 acceleration. With this acceleration on, the remote did not work when viewing an mpeg2 video and the picture looked degraded at times. With mpeg2 acceleration off the remote worked again and the picture looked better. I did not see these issues when viewing an h264 video. I went back to the November build and the problems seem to have gone away. The remote works and the picture looks ok even with mpeg2 acceleration on. I will stick with the November build for now. Thanks.

If you don’t mind spending a couple bucks I would purchase a Flirc USB adapter (and likely a USB extension cable to be able to put the thing in an ideal location). What this will do for you is make it almost as fast as the OSMC remote, allow all the buttons on your remote to work with Kodi, plus it will give you long-press support.

This looks similar to the IR remote problem I reported here. I’m using the WDTV Live Gen 4 remote and the IR extender that came with the Vero 4k+.

Kodi 18.9 - Vero 4k+ immediately responds to all button presses in all menus and during movie playback

Kodi 19.1 - Vero 4k+ responds often enough in the main menu items, but almost no response during movie playback. If I hammer on the buttons often enough, I can get the movie to fast forward 2x, pause or stop, but it’s not usable this way.

My advice for now is to stay with Kodi 18.9.

1 Like

My guess is that this is IRQ related, and some video playback changes mean that the IRQ for meson_ir is not getting serviced in time.

I will investigate soon – but am travelling and do not have a remote at hand presently.

Please keep in mind that the IR works somewhat unreliably in normal menus too. During video playback the effect is just most extreme.

FYI: I’ve confirmed the same behaviour with my support ticket from a few weeks ago (IR Remote problem after Upgrade - #8 by jedney). I’ve disabled MPEG2 acceleration and remote has started operating normally again.

Hi Sam,

It looks like the fix for this wasn’t in the November update. I didn’t see it in the release notes and I still get the same behavior after the upgrade. Is this still being worked on?


Hi Jon

This hasn’t been solved yet. It will be looked in to at a later date



@sam_nazarko has there been any progress on this in the latest March release by any chance? This is still a problem in my house, but I haven’t updated as yet.


The issue stems from high IRQ load during video playback.
We are working on a new video stack and I’ve sent you an invite to the testing thread.

We will make it public after more testing. Let me know how it goes.

Hi there
I just upgraded OSMC on my Vero 4K+ and now have exactly that Problem.
My IR Remote barely responds while playing a movie.

Is this Problem still being worked on?

I could work around it using an USB Receiver which seems to be working but when using it OSMC registers double inputs from both receivers.
Is there a way to disable the internal Receiver of the Vero?


You could just change the IR profile to a non functional one in OSMC.


Would the USB-Receiver work without a selected Profile?

If it is a FLIRC USB it will.

Well, turns out my receiver is also a RC6
So the only thing that works for me is to tape over the Vero’s built in IR Receiver.

The external one has a delay of about half a second though which is really annoying.
Is there a fix in the works for this IRQ Problem?

No – this is low priority, so hasn’t been looked at yet.

You could just change the profile in My OSMC → Remotes.

Hi @sam_nazarko, did a fix for this make it into the Sept 22 release please?


No - there haven’t been any improvements for this yet.

When there are, it will be covered in the release notes