IR Remote problem after Upgrade

Hi team,

I’m having a few problems with my IR remote on my Vera 4K+ since the upgrade to Kodi v19 (August 2021 update). Any help would be much appreciated.

Logs: https://paste.osmc.tv/obegebufir

Whilst playing back certain video files the remote doesn’t respond, or requires multiple presses.

In the log file attached I played back two files:

The first (movie “Turbo”) worked fine - playback started, I pressed right arrow to skip +10s - it obeyed, I pressed right arrow twice to skip +30s - it obeyed, I pressed stop - it stopped. Each key acted promptly and correctly.

The second (TV show “Allo Allo”) didn’t work properly. Playback started, I pressed right arrow - no result, I tried again - no result, I pressed it 3-6 times rapidly, it detected one skip (+10s), I pressed stop, nothing happened, I kept pressing stop, it eventually responded (after a 2-3 seconds and 5-10 button presses).

I’m using the Vera 4K provided IR remote sensor (the wired one) with a Harmony 650 remote using the XBox 360 IR profile.

Some additional info that might be useful:

  • The UI responds fine to the remote.
  • Some video files work fine, others don’t. The result is consistent (using the same file) across my Vera 4K and Vera 4K+.
  • Whilst I haven’t tested the theory extensively, the problem media all seems to be older low-res (<720p) TV shows/movies, other files, including UHD and HD seem to work fine.
  • The files that don’t work now, did skip and stop properly before the upgrade - so whilst things are pointing towards the media/rendering, I don’t think it’s file corruption. There’s too many files and they all worked pre-upgrade.
  • If I repeatedly press Pause to get the playback to pause, then the remote becomes fully responsive again.
  • I tried re-applying the remote profile (Xbox 360) in the OSMC add-on.
  • I haven’t been playing with any pre-release versions of OSMC. I upgraded straight from the last stable v18 release.

I’m happy to share an example file if it helps - a 1954 episode of Popeye the Sailor must be out of copyright by now surely!? :wink:

I hope you can help.

Thanks,
Jon.

I was actually about to post my own thread on this same subject, but you beat me to it. And you seem to have done much better analysis than I have as well.

Im also using a pair of Vero4k+'s (built-in IR sensor rather than the extender) and also using a pair of Harmony 650s. Im using the RC6 profile but have also tried a couple of others to see if I could improve the response, with no luck. CEC is not available on one of my TVs, so not an option there.

Im using a MariaDB back end and all my media files are on SMB shares - not mounted via fstab.

Before the upgrade the remote response was fine. Not immediate like a bluetooth response, but the delay only felt like a few milliseconds or so and was quite usable. After the upgrade, numerous button presses just dont register. The skip function during playback is no longer usable because I can only get 1 or 2 clicks registered out of 5 or 6.

Unlike the report above though, I am seeing issues in navigating the UI. I regularly have to repeat clicks again in order to move around menus. Since the upgrade, ive been using the Arctic Zephyr Reloaded skin, but ive also swapped to the OSMC skin and it behaves the same.

I also havent noticed any difference related to video files. All of mine exhibit the same behaviour, at least as far as ive tested so far.

I’ll upload my own logs as well if needed, but need to wait til after work for that.

EDIT: Logs are here: https://paste.osmc.tv/iheloselox

Thanks.

Others have reported some regressions with IR.

I have some ideas.

Can you confirm that if you use the OSMC RF remote, you don’t experience an issue?

Sam

1 Like

Sorry Sam I’m not too sure where the RF remote is, so I can’t check that, sorry.

I confirm there are no problems/delays using the KODI REST API to issue Pause, Stop, Skip, etc.

Did you participate in 4.9 kernel testing at all?

It would be good to know if you did.

Sam

I dug out my OSMC remote and can confirm that there are no problems when using that. Everything is really responsive and all clicks are registered.

Ive never participated in any 4.9 kernel testing. Ive always maintained a pretty vanilla distro as much as possible.

Thanks for the assistance so far. I appreciate the help.

Thanks. I think it’s a regression with IR on 4.9. I can think of a couple of reasons and will investigate shortly using a Microsoft Xbox 360 MCE remote

Cheers

Sam

3 Likes

Thanks Sam, no, I went straight from RTM to RTM version. No beta’s or non-standard repositories.

Thanks for your help.

Jon.

Conversation continues here…

Ok, I thought I was going crazy w/ my harmony one having to perform couch acrobatics to get the remote to ‘pick up’ after the update… def. something amiss here. Related, has anyone tried using the newer universal remotes with bluetooth capabilities? It seems like that’s more of a long-term solution (IR will hopefully start going the way of the dodo here sooner rather than later?)

We will keep IR alive for the next Vero generation and for the foreseeable future.

I bit the bullet and upgraded to a universal remote that supports bluetooth… so much better compared to the Harmony 1 (first gen) IR control! I’m upset at myself I haven’t done this sooner… (my other vero boxes use cec control and even that was lightyears better than IR)

The issue is the software layer that most IR sensors have to go through in this application. A Flirc USB IR adapter will get around this problem and allow an IR remote to perform almost as fast as an RF one at likely a significantly lower price.