Is Composite Video still supported in OSMC on Pi?

From what I’ve been searching up, it seems that as of the v19 update from 2021, OSMC no longer boots when using composite video due to a video stack rewrite.

Does this mean that composite video output is now unsupported and no longer part of the feature set of OSMC for Raspberry Pi based systems?

We fixed it in the latest update: Happy New Year! OSMC's January update is here - OSMC

Unfortunately, on my Pi 2 using the January Image for 2023, composite video is not working out of the box like previous releases.

After the install process finished and rebooted to OSMC, the screen remains black after the splash screen.

Did you change config-user.txt?
It has been confirmed as working by another user.

You will need to make manual changes.

I have. sdtv_mode and hdmi_ignore_hotplug do not work.

Switching to the staging branch did not fix the issue. For further information, the Pi is a Pi 3 Model B+.

To re-establish the symptoms:

Booting the Pi 3 with the latest January 2023 OSMC image, out of the box (stable branch being default) will output through composite video. The splash screen appears.

After the splash screen appears, Kodi does not start, and a black screen is shown indefinitely. sdtv_mode and hdmi_ignore_hotplug make no changes as output is working, but Kodi is not launching. I am unaware of any extra changes that need to be made to the config file to enable anything like video drivers to enable Kodi to launch properly on a Pi 3 B+. I have even checked for the dtoverlay settings and cmdline settings for composite video. No effect.
Here are the logs.

Strangely, while not related to OSMC, I installed LibreElec on a different SD card and used the cmdline and config parameters and Kodi launches on that distro, which is great, but it’s not OSMC. I at least know there are no issues with my Pi at all, and I highly doubt the SD card has issues as I’ve reflashed it multiple times.


I have an idea. Try this:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

Downside: this will stop HW accelerated playback until we release some Kodi v20 (due imminently) test builds, but it will let me know if this issue re. composite is finally put to bed.



I apologize for the two week wait, I’ve been quite busy.
Changing to the staging repo has no effect. I did use the command line parameters that work with libreelec to try to force video to composite to no avail.