Is my official power supply not good enough?

I’ve got an official 5V 2A Raspberry Pi PSU but I still see the lightning bolt icon appear in the top right of the screen and every now and again the Pi freezes, should that be happening with an official PSU? The only thing I’ve got attached to the Pi is an Archer T4U AC1200 USB WiFi adapter.

How old is the PSU ?

have you measured it so it gives the right amount etc ?

About a year old, not been able to measure it, I blew my multimeter and I haven’t got around to changing the internal fuse :wink:

However, I’m fairly sure I’ve been seeing the rainbow/lightning icon for a long time, I’ll try a replacement fuse in the multimeter and check the output.

Is it a Pi 2 or Pi 3?

Easiest way is to check with another PSU (if you have one on hand)

Sam

Pi 2, I don’t have another non-mobile phone PSU to hand so I think starting with checking the output is the easier thing to do!

you could also use android apps for measuring might not be as accurate as a multimeter

Thanks, that’s handy to know but at the moment the only Android phone I’ve got has USB-C not micro USB.

I wouldn’t trust that at all. It’s easy for a power supply to provide a steady 5V with no load. It is when you start consuming considerable power that the voltage drops.

If the Android phone’s battery is reasonably charged it will only be drawing a small amount of current, and so you won’t see the voltage drop. I’d also question the accuracy of voltage measurement in a phone.

i didnt say totally rely on that measurement, did i?

its better if he uses a multimeter to measure the volt and ampere of the charger, the app i recommended is more or less to get a estimate not a “defecto” result

I have the same problem using OSMC on Pi3. I updated OSMC to the latest (stable) version. I see the thunder symbol in the top right corner very often.

As power supply I have an Icy Box IB-AC611 which provides 2,4 A and has a powerful external supply:

Icy Box IB-AC611 4-fach USB 3.0 Hub mit 1x USB-Ladeport und zusätzlichem 5 V Netzteil https://www.amazon.de/dp/B00CO3RAA4/ref=cm_sw_r_cp_apa_yyifyb40045W8

http://www.raidsonic.de/products/external_cases/mm_cardreader/index_de.php?we_objectID=733

Does Pi3 consume too much?

Try other cables, cables and connectors can be one of the problem.
Secondly as mentioned more than once before, any device that is designed as a “charger” is not ideal as a powersupply for the Pi as charging cares more about the ampere than a stable voltage above 5V

1 Like

I’ve had a similar issue with a PSU I ordered from Pi Hut.

I suspect the issue maybe that I have my Pi3 connected to a HDMI switch hub which is drawing power via HDMI. The HDMI box is connected to a PS4 and PC and when I don’t have the Pi connected to it, the HDMI switching hub doesn’t work with the PS4, instead getting stuck in a flashing LED loop. But once the Pi3 is connected via HDMI, the HDMI switch hub seems to work but causes the lighting bolt icon to appear occasionally.

I’d expected this PSU to work at a stable level, as it’s sold by a supported Pi partner and as a PSU specifically made for the Pi.

The PiHut PSUs have caused problems in the past on this forum.

Note the PSU is 5v, 2A. The recommended PSU for a Pi 3 is 5V 2.5A. If the PSU is a little old, it may have degraded. If not, consider returning it under a warranty request. The official Raspberry PSU has been updated to 2.5A, as has our official PSU which is tested against OSMC

https://osmc.tv/store/product/raspberry-pi-power-supply/

The fact is that if you see the lightning symbol, you probably do need to check how you are powering the device.

Sam

Thanks Sam. I didn’t spot that it had to be 2.5A.

I’ll try and return it under warranty as it’s less than 6 months old.

If it’s outputting 2A, then there’s nothing wrong with the PSU, it’s just not appropriately specced for the Raspberry Pi.

What’s odd is the Pi Hut lists it as being a Raspberry Pi supported PSU. But lists it as 5V/2Amp. Looks like it’s mis-advertised.

It will probably work for some use cases; 2.5A is recommended now as the USB ports can provide additional 1A of voltage to peripherals that need it.

OSMC is probably one of the more power-hungry distributions, which is why we always insist people use a good power supply, and not just a phone charger etc.

Hi ‘indie1982’

We would like to think that the power supply we buy after the given voltage and current - should be ok.
But - the fact is, that many, many of the PSU which is produced today (and very often power which is produced in Asia)
do have a VERY big ‘Voltage Drop’ - when connected to a unit.

So - even the PSU is stated to give a 5V and 2A - - it doesn’t mean that this actually is correct.
Cuz, when you get a very high Voltage Drop from the PSU when connected to the unit - - you also get a current drop…
This means that the current which the PSU is stated to give - - is NOT correct.
I wanted to make sure that the RPi shold be able to have enough current and bought a 5V 3A PSU.
But - two of the one I bought - did NOT give enough to the RPi - - cuz the voltage drop from those two, was TOO high.

I had the same problem with lots of my PSU (many of them was the official PSU) - - then I search a little on internet and found from eBay, PSU which have almost NO voltage drop at all.
Those PSU’s are perfect and gives the needed current for the RPi.!

When we talk about voltage drop - - it is also stated that a RPi start to trouble already at a ‘drop’ of 0,4 V.
This means a working voltage of a little as 4,6 V (I have notised that troubles start already at a voltage of 4,7V)
One of my projects I built with RPi - I also mounted a digital voltage meter - for all the time monitoring the voltage when the RPi unit runs.
That is monitoring the voltage for RPi and shows a working voltage at 4,88 - 4,95 Voltage.
On that unit I am running a 12V PSU 4Amp. and a step-down module which gives me 5,2V (idle)
I also monitor the 12V with the same voltage meter (only switching between the two.

So make sure that the voltage drop is less than 0,15 V.
Also make sure that you use a power USB-HUB for actual connected USB-units (of used)
That will save the main PSU for the RPi.!

I bought a USB-meter to chech whether the PSU drops in voltage and also can message how much current the unit are pulling from the PSU. (They are very cheap form eBay).

Wish you good luck with the project and hope you find a PSU which gievs you the needed both voltage and current.

With regards
Oivind

I had a brand new 2.4A power supply but the icon did not go away until I replaced the (probably very) old cable I had been using

I run my Pi2 with a 3.5A psu and even with that the lightening icon comes up far too often. Today i changed it to a 5A psu and I still get the icon.