Issue with launching retrosmc on kodi v19

hello, I am having issues with the launcher that is included with Retrosmc. The script installs fine but the launcher is not working and complains that it is not for this version of Kodi can someone please assist me in making the launcher work on Kodi v19 Raspberry pi 4.

TIA!

The first step would be to edit addon.xml

One requirement is xmbc.python change version to 3.0.0

And try.

Haven’t talked to @hissingshark yet, so i don’t know if there is python code in the addon that is incompatible. And right now I don’t have time to trouble shoot.

Depending on how much prep work i have to do for the Roblox studio course I’m tutoring kids in tomorrow, i might have some spare time tonight or tomorrow evening.

It requires a couple of fixes for Python 3. I’ll be pushing an update when we officially get Kodi 19, to avoid breaking it for the 18 users now.

1 Like

Just checking now that OSMC 2021.8-1 is out if the Python 3 fixes have been merged.

They have.
There are however some issues with the binary downloads it seems. It affects RPi devices due to the video drivers. I’ve been working on it for a few weeks. Nearly there.

Fabulous! I am happy to test/validate when ready. Thanks so much!

Hi there, I’m having the same issue with the Vero4k I bought recently (which I bought mostly for the retropie integration). Will this issue be resolved anytime soon? If not, can I downgrade to the old OSMC version that let me install retropie?

@hissingshark Might be able to advise on that, but you can install the November release from Download - OSMC which should let you use RetroPie now.

What same issue? The Vero4K should be working fine.

hey sorry to message again was wondering if it has been released I would love having my retropie and osmc in one thing I have a 128 gb card I got with my pi and I know with my setup osmc wouldn’t take up a lot, I would also be happy to validate/test

I’ve already sent you a PM about testing what I’ve done. Maybe your notifications aren’t on?
I’ll see you in there.

@porksoda103 I’d also messaged you about it. Likewise, please check if you have chance.

@hissingshark Sorry for the late reply. ‘The same issue’ is the issue that was described by @thedigi321, which is that after running the retrosmc script to install Retropie the launcher does not work and I get the message that it does not work for this particular version.

You need to update the script. If you weren’t receiving warnings in advance to do so, then you must have been running a very old version. That would have prepared it for the new Kodi version. Now it will not work from Kodi.

At this point you can either update the script from the console menu or just delete and re-clone the repo.

Thanks, I will try this and report back!

May I ask which installer of retropie did You use?
I want to test it also. I’m having Rpi4 with lastest OSMC onboard, and when I tried about a month ago with installer from https://github.com/RetroPie/RetroPie-Setup.git - it installed but the overall performance was weak - menu lagging and tearing…
So I ended with PINN (multiple OS boot’er) with seperate OS for retrogaming. I’d like to get back to one system if this is possible :slight_smile:

@hissingshark - Is Your installer compatible with Rpi4? On retrOSMCmk2 github page it says that only Rpi 0,1,2 and 3 are supported…

I don’t have an RPi4 to test and I’m awaiting feedback from those who do. I’d be interested to hear if my installer works for you.

Ok, thanks for the info.
I’ll test & report with pleasure :slight_smile:

Ok, I have some news.
Installation - basicaly without problem, but I had to add key from ubuntu repository, because it failed to install sdl2 libraries:
sudo gpg --keyserver hkps://keyserver.ubuntu.com:443 --recv-keys DC9D77FF8208FFC51D8F50CCF1B030906A3B0D31

Startup addon also installed fine, but when I tried to configure the addon (exit button from remote) I got CEC error, and after that couldn’t use my remote. Restart didn’t resolve this problem. What I found out - there was newly created file .kodi/userdata/keymaps/remote.xml with empty mappings. Removing this file solved problem.

And last but not least - RetroPie runs, but it behaves exactly the same as when I tried before - it’s very laggy and not fluent at all. Looks like it has maybe problem with video driver? It prints this message at start:
Couldn’t get V3D IDENT0: No such device

So… the installer works - but unfortunately RetroPie somehow does not want to work properly on Rpi4 with OSMC.

hey Hissingshark I am looking in my “messages” and I do not see it apologies i forgot to check the thread

I don’t understand this issue with the gpg keys on RPi4. The commands you used manually are part of their scripts, so it should happen automatically. It works fine on the RPi3…

I wrote the CEC exit button option back when I had a Samsung TV. The CEC passthrough on theirs is excellent. I’m on an LG now and barely anything goes though, so I can’t test that very well anymore. Not sure if you’ve found a bug there or if it’s the TV. The mapping you found by your debugging is there is to prevent the remote from doing anything in Kodi while it’s being used in the programming process.

I much prefer the gamepad exit option I added later. The CEC option was originally written to give other users of the TV a chance to intuitively get out of EmulationStation when they’d started it by accident (and then leaving angry messages about it whilst you’re at work).

Thanks for the feedback.