Issue with Vero4k and raw 4K MTS files?

A friend brought over some raw 4k video of a few shows he shot, and the file starts with no sound for a few seconds but when the sound kicks in the video appears to be on FF, and sound drops every few seconds.
They’re all straight from his cam, raw 4K MTS files.
Played on Vero4k from USB stick connected to powered USB hub

My PC w/ VLC player play the files fine, is this a known issue or a setting?
Apologies if I missed a post about this, my initial searches didn’t yield my issue.

Logs:
https://paste.osmc.tv/qabodavoda

General
ID : 0 (0x0)
Format : BDAV
Format/Info : Blu-ray Video
File size : 347 MiB
Duration : 2 min 8 s
Overall bit rate mode : Variable
Overall bit rate : 22.6 Mb/s
Maximum Overall bit rate : 24.0 Mb/s
Recorded date : 2014-09-04 05:57:44-05:00
Writing application : Sony FDR-AX100

Video
ID : 4113 (0x1011)
Menu ID : 1 (0x1)
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4
Format settings : CABAC / 2 Ref Frames
Format settings, CABAC : Yes
Format settings, RefFrames : 2 frames
Format settings, GOP : M=2, N=15
Codec ID : 27
Duration : 2 min 8 s
Bit rate mode : Variable
Bit rate : 21.3 Mb/s
Maximum bit rate : 22.0 Mb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate : 29.970 (30000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Interlaced
Scan type, store method : Separated fields
Scan order : Top Field First
Bits/(Pixel*Frame) : 0.342
Stream size : 326 MiB (94%)
IrisFNumber : 3.100000

Audio
ID : 4352 (0x1100)
Menu ID : 1 (0x1)
Format : AC-3
Format/Info : Audio Coding 3
Commercial name : Dolby Digital
Codec ID : 129
Duration : 2 min 8 s
Bit rate mode : Constant
Bit rate : 448 kb/s
Channel(s) : 6 channels
Channel layout : L R C LFE Ls Rs
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Bit depth : 16 bits
Compression mode : Lossy
Delay relative to video : -67 ms
Stream size : 6.87 MiB (2%)
Service kind : Complete Main

Text
ID : 4608 (0x1200)
Menu ID : 1 (0x1)
Format : PGS
Codec ID : 144
Duration : 2 min 8 s
Delay relative to video : -67 ms

There seem to be really bad PTS issues in that file, which is causing discontinuities.

Can we get a sample of the file?

I’ll have to see if I can split out a sample file (and how to do that) and then find where to host it. Most of these files are ~2gb, this one that I texted and supplied media info was under 400mb I believe but all files showed the same behavior
Will update if I’m able to do that.
Thanks.

Just upload it to https://videosam.pl and let me know when you’ve done this
5GB upload max.

Cheers

Sam

Thanks, will do, when i get home from work.

1 Like

Uploaded a small 20 second clip, let me know if it worked or if you need the link it provided

Are you sure you uploaded a file? I can’t see anything here.

Sam

I did it again, choose and opened the file, it populated mediainfo, then I clicked Upload and it went to 100%.
https://paste.osmc.tv/axomedawew

I might actually have a dropbox i can up it to as well…just have to find my id and pw :slight_smile:
Lemme know, thnx.

You only uploaded the MediaInfo, not the file.

Make sure you are logged in to My OSMC.

Try this: https://www.dropbox.com/s/obtyi6dr58hcdbq/Cheap%20Trick%20Gene%20Intro-small-003.mkv?dl=0

Before I download - your complaint is about MTS files but this is an MKV. Did this change the behaviour at all?

Ugh, I’m having a tech challenged week - I used mkvmerge to split the file, didn’t spot that, sorry.
Let me upload the full 300mb file, but can I PM the link to you? My friend would prefer the file not get out.

Sure.

If you go to https://my.osmc.tv/my-account/ and login there first then https://videosam.pl/ should allow you to upload your file.

I can’t reproduce an issue with playback on that file with our current release. I see that your still on our March release. Can you update and try it again please.

And after doing so, if there is still an issue please post some new logs

Sam

Well, shit :slight_smile: The update has resolved the issues.
I tend to wait a week or two after updates are released before applying them to ensure there aren’t any issues.
Thanks for the assist guys.

I don’t know if this is the same issue. I am trying to play an m2ts file, from a bluray folder. I have uploaded my logs to: http://paste.osmc.tv/ovetukomac.

I have a Vero 4K+, and is connected via nfs GBit to my NAS. Audio plays, but video keeps “Buffering”, then a few seconds later the video catches up. I have been able to play other m2ts files okay, even via 5G wifi.

I also have an HEVC mkv file that plays back really (and I mean really) bad. It is not part of the uploaded logs, but I can do that if needed.

Any help always appreciated.

tia

ken

The original poster reports the issue as solved in the latest update. I haven’t checked your logs yet but will shortly. If you’re on the latest update and there’s still a problem, then I don’t think it is related.

In your player settings please turn off “sync playback to display” and try again. I would also recommend changing your GUI resolution to 1080p. Note the following regarding that…

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.