Issues with content playback since 2021.12

I am having issues playing HDR content since yesterday’s update to 2021.12. I see other topics with similar issues, but they seem to be solved with cold boots. My Vero always cold boots, so that’s not a fix for me.

Some HDR content starts, but only audio, other HDR content plays, but then after a few minutes just crashes and starts glitching.

I have a debug log of HDR content that starts audio but no video, if I then FF, video suddenly appears, but in the wrong resolution, it’s really borked:

Hope there’s a fix, otherwise I certainly need to downgrade.

I can’t see any video being played that’s HDR after you turned on debug logging.

Ok my bad, this one was actually FullHD.
So I have issues with both HDR as well as FullHD content. They manifest differently however.

I can test with some more different content, do you need a debug log for a HDR example also?

If you are experiencing issues with HDR content, then yes.

What are the symptoms for FHD?

It might help. I can’t see anything wrong in the log you posted (yet).

Here a debug log with HDR and SDR content issues:

This has both audio and video glitching. Audio dropping out like very short stutters, video has white pixels in different areas in the video, just overall glitchy looking and sounding.

Note that I also have FullHD issues, that playback is also in above debug log, with a different source than in the previous log, but same effect. The playback seems to start ,then display turns off, video returns in incorrect resolution (overscanning the display). Also very glitchy.

Hi, I don’t want to be impatient, hope you all had a good new year the last few days! I also hope to be able to use my Vero 4K+ again in the near future, any ideas? :slight_smile:

Is the problem only for movies you play from your NAS or also when you play from USB Disk/Stick?

Well I haven’t tried moving a file to local disk, but is that likely to matter? The problem also occurs when streaming from national TV using one of the Kodi apps for this. So it really seems to be caused by the video system itself. So far only Youtube is working OK.

Well it would help to exclude the network as an issue

Ok well here is a debug log with the same 1080p file from mounted as well as local storage:

Both play exactly the same, with the video being out of bounds of the display. Unlike HDR, 1080p does at least play. I don’t have a HDR file that fits on local storage, but I think this shows that the network is not an issue. Also not very likely as the problem instantly started after the December update.

What do you mean with “out of bounds” you mean picture bigger than screen? That would mean overscan issue (see below).

It seems you have a issue with Overscan. Ensure that you did not have any calibration configuration in Kodi/OSMC and use one of the following methods depending on the TV Brand you use.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off

Yes, that’s what happens for 1080p content. Note that I mistakenly said the last tested clip is not HDR, it is HDR, just 1080p HDR. Changing the screen setting on my (LG) TV does not change the problem. Either on 16:9 or “original” or any of the other settings, the image greatly overscans.

And the video also just crashed again (which is the effect with HDR content).

Also just checked again, 2160p HDR content does NOT display oversized. But that content crashes + shows glitching pixels all over the video.

Thats because you have Zoom/Overscan configure in Kodi. First remove that and set the TV to Just Scan.


Ok! Some progress here. I thought I didn’t have this “just scan” setting, but it was inside the menu, not just the quick menu. My just scan was set to “auto”, now it’s “on”. Then I removed the overscan settings.

This seems to have fixed several of the issues, the video is no longer overscanned and also the glitchy pixels appear to be gone!

However, the video crashing still happens (video disappears, audio still playing), but it seems to only do this after playback starts and then it does come back by itself. I can certainly live with that for now. Will have to do more testing to know for sure if everything else is now OK. Is that “video crashing” thing actually visible in the debug log?

Thanks a lot so far!

I didn’t follow up on this because I wasn’t sure it was not a network issue.

Have you tried local playback with logs after a crash?

Maybe I should describe the “crash” better, otherwise it may lead to wrong efforts. I played around an hour of HDR content after my last post, and resolution/overscan/glitching are all gone.

So the only remaining issue looks like this:

  • Start playback
  • Playback starts as audio can be heard
  • Display turns to LG TV background (basically a background picture which is normally visible when Kodi is starting up, so it’s from LG)
  • Audio and video become visible and play fine.

This lasts about 5 seconds, and only seems to happen at the start of playback, and possible when stopping. So it’s really not terrible, but certainly never happened before the last update.

That is expected as the Resolution and Framerate need to be switched to match the Video. That the LG TV needs 5 seconds to do that is quite strange.
You can disable it with Settings>Player>Videos>Adjust display refresh rate> Disable but surely you would miss a perfect video playback.

I see, I just tested and indeed disabling that setting makes playback instant. In that case I will leave it on, as the setting is useful. So it seems the last Kodi update changed things in this area of functionality? Anyway, I am happy!

Thanks for the help.