Issues with content playback since 2021.12

Yes the last update enabled it on start/stop to bring best picture to the user.

Oh, I do think I always had it on already, but now I am not sure…

You should probably leave “Adjust refresh rate” set to “On start/stop” for better playback quality. If, under Settings>System>Display, you set “Delay after change of refresh rate” to however long it takes for the picture to come back up (5 seconds?) that will ensure you don’t actually miss any of the video - Kodi will switch output mode and then wait the specified amount of time before the video starts playing.

Oh great tip! Had not seen this setting yet.

Note that mine needs to be set to 11 (!!) seconds for the video to start at the same time my TV display becomes available. This is with an LG OLED (couple years old).

To add one more observation, if I set the delay higher than about 11 seconds, the glitching returns! Even though the video then still starts playing a bit before the resolution change is finished. Quite odd.

Ok it appears I cheered too soon. Even though FullHD (incl. HDR) is working fine now, 4k HDR does not work correct when the “adjust refresh on start/stop” is enabled. It makes both the audio and video glitch, and sometimes the video stops entirely.

So now I am reverting to having this feature off.

I have a quite common LG OLED tv, so I assume my Denon AVR-S950H that’s sitting between the TV and the Vero is the culprit?

By “stops” do you mean it freezes, or that you lose the picture entirely? If you lose the picture altogether, that suggests an HDMI communication problem, in which case a new cable might help; you could also try (temporarily) connecting directly to the TV and bypassing the AVR - if that works better, that suggests the AVR might be to blame.

The fact that you have an AVR in the signal chain, incidentally, is the reason why it takes so long for everything to resync when you change resolution - each device in the chain has to re-establish a link, in sequence - first Vero → AVR, then AVR → TV.

Thanks for the explanations. When it stops, it loses picture entirely. Sadly replacing the HDMI is far from trivial due to how tightly and neatly everything is tucked away in the furniture. I remember using quality cables back then, but it’s been a couple years, so likely not HDMI 2.1 cables for example (and that shouldn’t be needed).

So for now I am back to the setting at “off”, which seems to work fine for me, and I guess I am used to it, and perhaps missing out on perfect audio/video sync? Not sure.

Doubtful that it’s affecting the sync, but with the setting set to “Off” you are downscaling 4K to 1080p, and also converting everything to 60Hz, both of which will adversely affect playback quality. If that is acceptable to you so long as it means you don’t have to unplug anything, that’s your call.

You shouldn’t need HDMI 2.1 cables, certainly, but you do need at least “Premium High Speed” grade. And cables can wear out - if there’s strain on them, the internal wires can break or pull out of the plug - and oxidation on the contacts can sometimes be a problem. Or, as you said, the AVR could be misbehaving. I don’t think you can eliminate those as possibilities if you can’t get at the wires.

Oh wait really? I am downscaling everything? Are you sure, as Kodi indicates 4K playback in the OSD, or is that information not accurate for what is displayed in the end? How could I verify this.

I guess I need to plan some time to open everything up then…

Normally your TV will show what signal (Resolution / Frequency / HDR,HLG,…) it receives

Ok wow, I don’t know when this “broke”, but even changing the Kodi GUI to 4K makes the display turn off for 5 seconds, and then return to 1080p! Clearly something is wrong here.

I was able to do a relatively quick test by plugging in HDMI cable going to a different input device into the Vero. Now 4K is actually working, including the “adjust refresh rate”. I ordered a certified HDMI 2.1 cable now, just to be done with this forever hopefully.

I feel so dirty, I have likely been watching 4K movie (backups) for at least a year or 2 in 1080P…

The odd thing is, there’s definitely a “good” cable between the Vero and receiver. It is braided (hear me out), meaning I didn’t just grab one from my big cable box, but actually spent time back then selecting and buying it, very strange.

Thanks for all the help in this topic!

Now I have likely solved the issue of glitching and crashing video, my overscan is still not right. Perhaps you are able to help me?

On the LG I can enable the “just scan” and disable overscan on Kodi, in that case:

  • 4K content displays correctly
  • Kodi UI displays correctly
  • FullHD content is too small (black borders)

When I disable “just scan” on the LG, and use Kodi video calibration I can seemingly make them all fit, but then 4K becomes more unstable/glitch again.

How do I fix the display of FullHD with “just scan” enabled?

So Full HD movies and Full HD GUI a shown with black border?
Suggest to upload logs from that situation.

Ok I did some more testing, with “just scan” still on.
To be clear, this is what I notice and see:

  • Kodi GUI: displays correctly
  • FullHD HDR: displays correctly (in debug log)
  • 4K HDR: displays correctly
  • 4K non-HDR: untested
  • FullHD non-HDR: black borders (in debug log, 2 different sources)

Whats the mediainfo of those files?
How do they look like if you play via USB from your TV?

This is the mediainfo for one of the FullHD sources with black borders:

Would the location of the file really make a difference for the borders? When I disable “just scan” the borders are gone (and then the Kodi GUI is overscanning so I have to use video calibration)

I meant not to play from Vero4k but directly via the Videoplayer of your TV!

Woops OK sorry, makes sense :grinning_face_with_smiling_eyes:
I am not sure I can reach the USB, the LG is installed tightly up against the wall…