Issues with OSMC DVB dongle

Just received my new OSMC DVB dongle which I thought I’d try instead of the MyGica dongle I use, in case it helps with the occasional issue where playback of an in-progress recording dies with corruption to the background recording process (still happens on occasion).

When I booted the Vero the TVH web page showed a couple of Sony adapters and a Realtek. I enabled the DVB-T/T2 adapters and rebooted the Vero. The TVH PVR client immediately posted a message that the server is not responding properly, and I now have issues even getting to the TVH web page. I tried uninstalling and reinstalling TVH server, and on one occasion got to the web page but now only the Realtek adapter is visible, the Sony ones have gone. But now after a couple of power cycles, the TVH server is not available upon reboot - actually, as I type this, it looks like there is a very sustained delay and eventually the TVH page responds, but no T2 adapter is available, only the Realtek.

I plugged the MyGica dongle back in and everything is working perfectly first time.

I may try the OSMC dongle on a Vero that has never had TVH server installed, but I’m a bit surprised that the MyGica dongle has turned out to be much more “plug and play” than the OSMC one.

Anyone have any suggestions?

Are you using a powered USB Hub?

I wasn’t using a powered USB hub as the MyGica doesn’t need it. However I just tried via the powered hub, and it still doesn’t work properly - a very delayed start before TVH web page becomes available, the PVR client posts an on-screen message about the server not responding properly, and no T2 adapter is listed (and I’ve not been able to make the Realtek one work yet either).

If you are familiar with ssh access to the OSMC device, you could restart with a virgin tvheadend configuration but have to reconfigure all:

  1. login via ssh to the OSMC device
  2. sudo systemctl stop tvheadend
  3. mv /home/osmc/.hts /home/osmc/.htsold
  4. sudo reboot

I tried the virgin install and have come full circle. At first encouraging, TVH web page was available and I had 3 adapters, including a T2 one, I went throught the TVH wizard but on finishing the set-up, the mux scan seemed to fail. I rebooted, and once again, availability of the TVH web page is very delayed after reboot (it should be instant), and only the Realtek adapter is present, and the TVH client on the Vero is very unhappy, advising that the server is not responding.

Is this a dodgy dongle? I will do a clean install of the MyGica, that seems to work.

Same story when connecting the OSMC dongle to a Vero that has never had TVH installed. All seems to work up to the initial mux scan, then when the mux list page comes up, all the scan results are fail. Reboot the Vero, TVH web page is not available when it should be, wait a couple of minutes before the TVH web page becomes available, and the 3 adapters are down to 1, and no useable TVH service.

Unless anyone can advise re a driver update, looks like an RMA request is next.

How many and what kind of unpowered devices you connected to the both USB ports of the Vero?

the only other device connected is the dongle for the Vero’s official remote. As mentioned, I’ve tried a powered hub (it’s a PiHut-branded one), and that did not help.

Some logs would be handy. This definitely sounds power related.

Here is a log

I just ran through this again with a clean TVH install. This time I put the remote dongle in the USB hub as well as the DVB dongle. As before, I start with 3 adapters listed in the TVH web page, and all seems ok up to the initial mux scan, then every scan has a failed status. On reboot, only the Realtek adapter is listed. What was different this time is that on reboot, TVH server seemed to start straight away, albeit with no ability to scan successfully.

The TVH log shows that it is actively trying to scan all the muxes but they are all failing, whereas with the MyGica dongle, the all scan pretty much instantly.

With this log I did a double-reboot first if helpful.

The issue with the disapearing Sony T2 adapters, sounds like same issue i have where you have to power off the device at mains to get them back, simply rebooting the device makes them disapear


Sorry for the late reply.
Does a cold boot solve the issue?

This is fixed in 4.9



how do you define a cold boot?

restarting vero4k either with sudo command or button in kodi, loses the sony adapters

shutting down kodi, then switching the unit off and on, then shows the sony adapters

Glad to hear 4.9 fixs it, I would have valuntered to test as ive 3 box`s, but I do like stability lol

A cold boot means plugging in from off at the wall, not a reboot. So what you describe as a shut down.



A cold boot does not bring back the full list of adapters. One thing that does is to delete the TVH server .hts directory and start again, but then when the adapters are listed, the initial scan appears to complete until you get to the mux overview page and find all of them failed. Then a reboot takes us back to just one adapter listed and no successful scans.

My Vero’s are running various staging releases in case that helped with other TVH issues, though since I discovered that the V4K+ that used to run TVH server may be from the bad initial V4K+ batch, I have moved TVH server over to another V4K+ and so far it’s solid with the MyGica dongle. So for now I may not even need the OSMC dongle, though the fact that it does not work with a Vero is rather ironic, given I bought it in case it would make my life easier!

That sounds like you selected the Realtek tuners in TVHeadend and these were cached.

If you purge the cache you will see the Sony tuners consistently from a cold boot.


how do I do that?

never mind, I added the OSMC dongle to the powered hub attached to my primary V4K+ TVH unit, ensured I did not enable the Realtek tuner (where is the reference for users on that?) and I have got a number of muxes working. My aerial points to Crystal Palace and I’m a long distance away, and the first test I gave to the OSMC dongle was whether it could scan the low-power muxes at 746 and 754MHz. It failed. The MyGica dongle can scan these muxes.

I suppose I may now keep the OSMC dongle as it may give me secondary tuners for the main muxes I use, but the whole experience with this dongle has been a rare low point on my OSMC journey.

I also use Crystal Palace. Your experience definitely sounds abnormal - I would check if the signal is marginal.

You will need to use the dongle with a powered hub, otherwise it may not receive sufficient power, particularly for DVB-T2.

There is only one issue (with warm boots) on 3.14; and this will be resolved in the next kernel update. It might be a good idea to keep this open and give some feedback when that update is made available as I’d like to get this working as expected for you