Just got my Vero 4k + (Not off to a good start)

Ok new to Kodi and Vero 4k +
I bought this device because I have been using my Xbox One X as my Plex Client for years and Plex has a pretty nasty buffer bug on the Xbox where 4k HDR material will start to randomly buffer after 5-20 mins.

I only bought a Vero 4k + cause I have heard to plays plex 4k HDR material with no issues. So far it is not looking to good

Here are the issues I need help in

  • I think I downloaded the Kodi Plex add in, NOT the native 4k Vero Plex app, how do I make sure and find the Native 4k Vero Plex app? Where is the exact place to find this through the menus?

*When I go to my OSMC and updates it does not seem to give me an optin to update now, it only shows me the schedule to set. I looked in the manual. current version shows as May

*Using what I think is the Kodi Plex add on trying to play 4k HDR video the video looks washed out meaning it is not actually doing 4k HDR, how do I make sure 4k HDR is properly triggered?

*When trying to play 4k HDR material it buffers horribly and won’t really play, I’m using wifi and that will be my only option, I’m on the same 5GHZ SSID AC network my Xbox is on and then will at least play it fine until a bug hits, The OSMC won’t even get that far.

So in summary currently I need help or I’m going to have to return it as it is not helping me at all with my Plex issues and performs much worse then the Xbox.

Summary

*Where is the official Plex app?
*Kodi plex add on does not trigger HDR, buffers and is useless
*Update page does not have a manual update button

Hello,

You can manually check for updates under the manual controls option.

To ensure HDR is properly triggered enable Adjust Refresh Rate under Settings -> Playback and set the UI to 1080p under Display, not 4K.

There are two Plex add-ons. The official one and PlexKodiConnect. Make sure you don’t have transcoding enabled, as you want the Vero to play the file as is.

If you’re playing over a WiFi connection, then you should make sure that your WiFi network has a separate SSID for 2.4G and 5G. It’s possible to play 4K UHD rips over WiFi, but might take a little bit more work.

Hope this helps

If you can post some logs we can take a look to see how your system is setup and offer guidance on anything that should be changed.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

We have a lot of Plex users here, so I’m sure they will be able to chime in

Sam

Logs are here

http://paste.osmc.tv/duhukorezi

Ok I’m in better shape now

I got the manual update, going

In the Kodi add on for plex I enabled HEVC playback which stopped transcoding and allowed HDR

On the audio side I got 5.1 from an AC3 audio source after enabling audio passthrough in plex but a DTS 5.1 source only played stereo
Do I need to further adjusting Vero audio settings for this?

I have to use optical audio and just want basic 5.1 audio from all my source files which can be DTS, AC3, TRUEHD, Xbox does this by forcing everything to DD 5.1.

I’m still not able to find the the Vero Plex app, can someone tell me the exact menus to search for that?

There is no separate Plex app for the Vero outside of Kodi. The Plex add-on you have installed is officially developed by the Plex team, so should be fine.

Yep I think my last deal breaker is DTS audio only plays in stereo through optical output. Only AC3 plays 5.1 correctly everything else is in stereo

Does the native Vero plex client fix this? I still can’t find where to download it

Yes, if you upload the log again we can check if your current audio settings are correct

Go to Settings -> Audio and make sure expert settings are set in the bottom left corner. Check the box for AC3 and DTS and it will work.

Cheers

The audio settings levels say standard, how do I change that?

http://paste.osmc.tv/batodupesu

Also to find audio I’m going to Settings/Sytem/audio

The information you need for setting the audio can be found in the following link. The option you describe as using before would be the ‘transcode to AC3 option’.

To get that option you would set your settings to “advanced” then in system>audio you will set…
Number of channels>2.0
allow passthrough> (enable)
dolby digital capable receiver> (enable)
enable dolby digital transcoding> (enable)

You click on where it says “standard” a few times until it changes to the level you want.

Nm

I see in your logs your UI is set to 4k and I would suggest to change that.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty)
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

I think I’m getting closer now on the audio side.

I can play AC3 5.1 and DTS 5.1

Ideally I’d like to use this option " AC3 transcoding" to force everything to AC3 5.1 to my receiver through optical.

I see that in the wiki but on the device itself using Advanced I do not have that option

Try to use expert modus

You need to set number of channels to 2 if I remember correctly, then the option appears

So I cant use the transcode to AC3 option if I want it to output 5.1 channels?

The basic gist ofwhat I’m looking for is for the Vero to convert all audio it can to AC3 5.1 through optical if possible. Would just make things easier on my receiver

Apcreiate all the help BTW it’s pretty close to fully usable right now where out of the box it was a mess.

Ok that seemed to work, set to 2 channels enable DTS and AC3 and AC3 transcoding and then any format outside of that transcode to AC3 5.1.

5.1 still works on all sources. A little odd though to set to 2 channels I kept thinking it would force all audio to 2 channels even though it doesn’t.

That setting is how many audio output channels you have. S/PDIF is only two channels so it would need to be set at that. When you enable passthrough it sends out a compressed multichannel bitstream (AC3) instead of LPCM. The other channel options are if you are outputting audio over hdmi to a device that supports multichannel PCM. There is nothing “odd” about it. Kodi just allows for more granular settings than you might be used to seeing.

Thanks, I think pretty much everything is in order from short quick testing.

Two quick questions is their a global volume boost option? I did not see that in the audio settings,
Can you turn off the red light in the front?

I’ll test more tomorrow and see if anything odd come up or have any long term playback issues