Just one tv show wont play

Logs: https://paste.osmc.tv/digaqomalu

Using plex connect I have tested every show I have, but it appears the one about a yellow family wont. It just seems to time out.

I assumed it was a number of seasons and episode thing but dr.who classic and SG-1 are about the only thing I have that has nearly 30 seasons and they both play with out pause.

Its also all 20+ season all different quality. Some DVD and Some Blu-ray. Getting very lost for solutions a this point.

Did you restore a Kodi backup from another device?
Can you change the device from something other than Default under Audio Settings

Do you know if it worked on the 3.14 kernel?

Thanks

Sam

Howdy Sam,

No restore, Wiped the settings of kodi and installed the new kernel trying to fix this. So can confirm that it was not working on the 3.14 kernel.

I have also test the files on my iPad with Infuse player, Windows desktop with VLC and Plex Web interface and MacBook with VLC. Works and starts almost instantly on all these.

Thanks,
Conor

Can you change the audio settings?

Sam

Changed to my second option using ARC and only have TV speakers. Audio of files is AC3 5.1 and still just have the spinning blue circles.

If it helps at all, upgrading my home network with cat6 this morning. 4K is playing without issue. Hitting 986mbs with iperf tests and the Simpsons still dies on it ass.

This is Plex-Addon and Plex-Server! So, first I suggest you test whether one of the affected eposides plays directly from the Vero without this Plex stuff:

Can you place such video material on a USB stick, insert the pendrive into a USB slot of the Vero and play it somewhere under Videos->Files->….

Second, in the beginning you provided some logs and your audio settings look sub-optimal for the connected audio device:

====================== Audio Cap =================== k3dRrf31
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48 kHz, 16/20 bit
Dobly_Digital+/ATMOS, 8 ch, 32/44.1/48 kHz, DepVaule 0x1
AC-3, 6 ch, 32/44.1/48 kHz, MaxBitRate 640kHz

This suggests that you configure under settings->system->audio

  • output device “AML-M8AUDIO, HDMI” or similar
  • number of channels: 2.0
  • output config: best match
  • allow passthrough: enabled
  • AC3: enabled
  • AC3-transcoding: enabled
  • E-AC3: enabled
  • DTS, TrueHD, DTS-HD: Disabled

So, awaiting your result when playing from a USB stick.

Third: If the problem still persists, real debug log is required:

The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding.

OSMC skin screenshot:

Another thing which should be changed/improved:

<setting id="videoplayer.adjustrefreshrate" default="true">0</setting>

Please, activate this setting at sttings->player->videos and set

  • adjust display refresh rate: on start/stop

A good introduction for video and audio setup you can find at Connecting up your audio setup & audio settings

Most of the above is done and tested. Problem is persisting in loading episodes, across plex app, SMB and NFS. Ill try the USB later today still upgrading cabling atm.

It was my understanding that the Plex app is using Kodi to play stuff so as long as it loads the file its an issue in the player?

You might also try Settings>Player>Videos>Allow hardware acceleration - OMXPlayer (disable)
EDIT: OMX is RPi only but was thinking about it as I know Plex has had issues with it.

@darwindesign This last one seems to have cracked it…at least so far in testing.

I was having issues with the USBplay back and I don’t have OMXPlayer as an option to disable but I have changes all the hardware acceleration to only effect HD and up. This seems to have stopped the forever loading issue both on USB and network (Plex, NFS, SMB).

1 Like