Just updating OSMC now - no keyboard and smb.conf message

Is this a time I need to buy some generic USB keyboard?

On a plus side I did backup just before.

[ MacGyver tools available now: usb mouse, putty connecting to RPi ]

PS I have nothing to hit Enter - to confirm choice

Click the above link for the workaround solution to this issue… Sorry for the inconvenience.

Well no worries. More importantly thanks for showing me direction @ActionA :slightly_smiling:

I’ll update when its ready.

I have solved it by commenting include line in smb.conf file.

Once you have updated you can restore that line as we have included a fix in the latest update that will prevent it happening again. Thanks for highlighting another possible workaround.

That was exactly what I have done, but I forgot to write it in my previous post.

update from command line stopped at 28%

commenting the line in smb.conf worked

thanks :dart:

sudo nano /etc/samba/smb.conf

If you were updating from the command line via SSH you should have seen the same blue message which you would have been able to use cursor keys and Enter to answer to proceed.

I did. It stopped like a minute later.

Updating from 2015.12-1 to 2015.12-3 and I got the Samba message as well. Used the SSH and command line upgrade to workaround with no issues.

My concern is that I support several others running OSMC (with the Samba server installed) who won’t have the skills or knowledge to do any kind of SSH workaround and don’t have USB keyboards.

If one has installed the Samba server package, is some form of workaround going to be mandatory when upgrading? I realise that the latest update will prevent the problem in the future, my concern is preventing (if possible) it happening now, for this specific Samba case.

If Samba is already installed there is no “easy” (non ssh) way to prevent it happening other than uninstalling Samba before upgrading then reinstalling it.

Unfortunate, but our hands really are tied due to the way debconf and apt work. We can’t update the updating script until after the message would have already appeared as debconf runs first before any packages are installed.

OK, thanks for confirming. At least I am forewarned… It will probably be easiest to find and plug in a USB keyboard when they get this message, assuming that this will work.