Kernel Panic - I panic!

Today I was greeted with this picture with some code and also kernel panic written in there.
After plug out and in again it worked and I got the logs:
I will add the picture later it’s too big.
Right now I listened to radio addon and got the sad face

Try a clean install seems like you been having alot of issues and the right move is to start over and see if that same stuff repeats.

less banned addons and try over thats my recommendations.

Apr 29 06:13:00 vero_2 kernel: [amlogic_cec] amlogic_cec_irq_handler(): amlogic_cec_irq_handler: nothing to read Apr 29 06:13:00 vero_2 kernel: [amlogic_cec] amlogic_cec_irq_handler(): cec msg status: rx: 0x2; tx: 0x0 Apr 29 06:13:00 vero_2 kernel: hdmitx: cec: CEC[1]: rx msg len: 1 dat: 01 Apr 29 06:13:00 vero_2 kernel: [amlogic_cec] amlogic_cec_irq_handler(): cec msg status: rx: 0x2; tx: 0x0 Apr 29 06:13:00 vero_2 kernel: hdmitx: cec: CEC[1]: rx msg len: 2 dat: 01 46 Apr 29 06:13:00 vero_2 kernel: CEC: tx msg len: 6 dat: 10 47 4b 6f 64 69 Apr 29 06:13:00 vero_2 kernel: [amlogic_cec] amlogic_cec_irq_handler(): cec msg status: rx: 0x0; tx: 0x2

ATTN @sam_nazarko seems like its stuffering from some sort of IRQ error in regards to CEC

Thanks for the reply… Exactly the answer I didn’t want to hear…
All the settings will be gone…
How could addons do this to a system? Like outside of kodi?
Is every addon I install via zip a banned addon? How would I know? I assume the To**enter addon is a banned one? I also had the A*uc one but removed it. =/
Funny thing about it is I don’t even use these addons an a regular basis, I was curious and tried them once or twice. There’s nowhere a hint such addons could seriously harm your system or is there?

I suffered a kernel panic once before with hummingboard, kodi on archlinux. I’m starting to believe that my external hard drive could be the root cause…It acts up every now an then, doens’t get recognized every once a while after moving it around and rebooting vero2. Switching case on and off sometimes helps.
… So my question to the experts: Could this even be possible?
Since I haven’t got any “system files” on the hdd I would say no…!?

is the official blacklist for Kodi suggest you read that their notorious for causing system instability.

as for the kernel panic thats an issue and i forwarded your issue to Sam via pinging him in this thread but if i had your problems i would start over if your not a avid banned addon user that would ensure that those arent breaking kodi functions.

I just read your “about me” profile text, it’s hillarious :grin:

…Now I’m sad again because of kernel panic :unamused:
I guess rsync backups to restore the settings also won’t help?
This way I will probably also restore the kernel panic issue, right?

if the kodi settings are a big to do then grab the .kodi folder in your osmc dir

no, it’s rather all the installed and configured packages like openvpn, transmission, pyload, sickrage, nzbget and so on…
locale settings etc…

Then maybe as a first try just go with a clean Kodi approach which will not impact any of the above, you always can fallback by moving back your .kodi.backup

sudo systemctl stop mediacenter
mv .kodi .kodi.backup
sudo systemctl start mediacenter

k, I will try.
Kodi with user configuration is my least concern.
I could even reinstall whole kodi package…or whould that lead to problems, missing files, .service file?

1 Like

No need to reinstall. The command I gave will clean all user initiated changes.

If fzinkens solutions doesnt work grab a backup of your /etc/openvpn and /etc/transmission and the other packages isnt that hard :slight_smile: takes 5 min to backup that crap then blow the sdcard and start fresh hell done it so many times when i broken my OSMC installation and im running on dev version i expect breakage :slight_smile:

fyi do a script (bash or batch) if your on windows that does that for ya might need to download some stuff if your on windows EXT4 filesystem

DiskInternals Linux Reader
Paragon ExtFS


that way it doesn’t matter if it breaks just restore with the settings files and try again instead of crying the blues in the forum :wink:

True, I thought with automatic backups i got that out of the way…
Strange thing though is that now it still works. Every kernel panic I had before on a device made it instantly unbootable or better said unstartable.

Which USB port is the HDD Plugged in to?
Is it externally powered?

The CEC TX errors won’t cause a panic and some improvements to CEC are on the way.


the hdd is externally powered and plugged into the single usb port on the back of the device.

The rear port is currently configured as USB OTG. Move it to one of the side ports and the issue will go away. In a near future update we will configure the rear port as FS so it is suitable for the RF receiver dongle and to avoid duplicate presses.


good to know! thanks.
I don’t fully get whats the use of this otg port… is it to connect a usb device without dedicated usb controller and still be able to exchange files? or can i connect vero2 to pc via itg port and access internal storage?

It’s configured to allow some devices like phones and tablets to act as a host.

I will reconfigure the port for RF in Full Speed soon enough.

Today, (may update installed) I got another black screen with code greeting me in the morning:

I don’t know if it’s the same issue I posted here:

I changed usb port and until updating it didn’t happen again.

Here is a new log:

I don’t know if it’s the same issue I posted here:

Then why clutter the forum with another thread?! Merged…

…because I don’t know if its the same issue or a different one. The older thread is before may update, the new one post may update, like I wrote.