Key Press Repeat Crazy

Just a +1 for the issue following the update this morning with my FLIRC.

I’ve also got a cheap and simple wireless USB keyboard, however that does not have any issues currently.

I’m looking in to this.
Hopefully the FLIRC guys look at the post (a user has reported the issue on their forum)

Well let me ask again in this thread why people using FLIRC with Vero 4k as the Vero build in IR reciever does the same job, see this thread

The built in receiver is not as sensitive, requiring careful aiming, and relatively close proximity. Additionally, it’s trivial to reconfigure the remote using FLIRC software than modifying either the Harmony remote or lircd configuration.

There’s no benefit to using the built in receiver for me.

EDIT: I forgot to mention, there’s very limited actions included in the in Vero configuration in MyHarmony. I use several buttons to do things like:

  • Show the EPG
  • Toggle subtitles
  • Toggle full-screen playback

And then there’s additional keys I’ve setup for bluetooth control and more. I’d have to spend hours adding custom commands via MyHarmony and/or changing lircd config. I can’t describe how unappealing that is.

For anyone who hasn’t seen, there’s a fix in this thread.

It will be released as an update shortly after some testing.

1 Like

I should mention, I was still getting the odd repeat after the change. I’ve increased my timeout and delay to 550ms and 65ms respectively, which seems to be stable with my flirc.

For the last week or so I’ve been experiencing chronic repeated key press issues, despite making no notable changes I can recall.
I have a Harmony remote, but this is occuring when not using the remote and simply using the standard Vero 4k remote, and configured as much. Logs are This follows a fresh boot, followed by a modification from xbmc remote to standard remote in myOSMC.
Any help much appreciated.

A reboot didn’t resolve the issue, however removing the standard RF dongle and reinserting, with no reboot solved it. The problem still occurs rarely however and hopefully you can see from a repeated keypress at some point in there.

What’s the output of lsmod via SSH?

I’d be surprised if the RF dongle is related – as it can’t interpret IR signals.


Hi @sam_nazarko , thanks for the reply as ever.

I’m not using an IR remote, just the default RF control.

The error still occurs despite updating to latest OSMC this week.
Here is my lsmod output:

osmc@osmc:~$ lsmod
Module                  Size  Used by
aes_ce_blk             20480  0
ablk_helper            16384  1 aes_ce_blk
aes_ce_cipher          16384  1 aes_ce_blk
ghash_ce               16384  0
sha2_ce                16384  0
sha1_ce                16384  0
dhd                  1368064  0
mali                  323584  1
ir_lirc_codec          16384  3
lirc_dev               24576  1 ir_lirc_codec
meson_ir               16384  0
amvdec_ports          233472  0
amvdec_mmpeg4          40960  0
amvdec_h264           147456  0
amvdec_h264mvc         69632  0
amvdec_mmpeg12         49152  0
amvdec_vp9            114688  0
amvdec_vc1             65536  0
amvdec_h265           147456  0
stream_input          192512  6 amvdec_h265,amvdec_h264mvc,amvdec_ports,amvdec_v                                                                               p9,amvdec_h264,amvdec_mmpeg12
decoder_common        200704  9 amvdec_h265,amvdec_mmpeg4,amvdec_h264mvc,amvdec_                                                                               ports,stream_input,amvdec_vp9,amvdec_h264,amvdec_vc1,amvdec_mmpeg12
firmware               28672  9 amvdec_h265,amvdec_mmpeg4,amvdec_h264mvc,decoder                                                                               _common,stream_input,amvdec_vp9,amvdec_h264,amvdec_vc1,amvdec_mmpeg12
media_clock            49152  8 amvdec_h265,decoder_common,amvdec_ports,firmware

Change the battery and repair the remote by holding Home and OK

Thanks @sam_nazarko. Unfortunately with a new battery in the RF remote it still goes crazy. Are there any other logs I can provide?

The logs show that the dongle is good.

All I can think of is some potential interference from something near by.
Also make sure that RF dongle is in black and not white USB port


Thanks Sam. After updating to the latest OSMC patch a couple of weeks ago all seemed better for a day, but it’s back again. RF dongle is in black and not white port.
The Vero is not in any different position to where it’s been since I bought it 2 or 3 years ago. I’ve just tried it in a different room, connected to a different screen (Dell monitor rather than Yamaha receiver) and see the same keypress craziness. It seems to occur most when the press is two or three times it like to then repeat in an indefinete loop. For example, when trying to skip 10s ahead in a video it then jumps to subtitle offset.
Is there anything else I can try?
Would a full reset of the device probably fix it? if so where will I find the instructions and is there a way I can export the kodi library data and reimport it so I at least have a track of what’s been watched?

You can reinstall from the Download page, but I’d be surprised if this made a difference


I’m unsure if it helps but:
i) This problem doesn’t exhibit when controlling remotely via phone app (Kodi Remote) with up/down controls
ii) When it starts to repeat it cannot be stopped/reversed/interrupted by the phone app, only the vero 4k remote
iii) removing the battery from the vero rf remote doesn’t stop the repeat. Only pressing another button on the remote stops it

Any more thoughts on how this can be diagnosed or fixed? Driving me crazy!

Are you able to install the older version (2020.11-1) and see if the issue occurs?

Is it relatively easy to reproduce the problem? Does it only happen on certain screens?


Yes, it is incredibly easy to reproduce. Essentially every 4-5 clicks of a direction and it goes crazy. It happens in many incl:

  • Kodi UI - scroll of movies/tv content lists
  • fast forward/rewind whilst watching content (after one or two clicks then jumps to Subtitle offset)
  • Kodi settings menus

I’m using default skin btw.
I’ll try an older version this week. Am I correct that I can:

  1. backup kodi database by backing up /home/osmc/.kodi (per
  2. reinstall gz file downloaded from Download - OSMC by putting on SD card via Reinstalling OSMC - Vero 4K - OSMC
  3. if required, at some later stage can restore Kodi database by wiping current /home/osmc/.kodi and replacing with backup taken in #1

Your database won’t restore to an older version of Kodi, but if the issue is so easy to reproduce, you might want to just take your backup, test the old version and if no joy, update again and restore the new backup.


1 Like