Keys not working on Remote Control

I am using two Vero 2 devices with the orginal black colored Remote Controls as shipped. On both Remotes two keys (the “i”-key right under the top and the “Context-Menu” Button right under the cursor keys) are not working in OSMC. They do work physically (I see IR light emitting when checking with my smartphone camera), but neither of my two Vero2 boxes recognize a key press (all other keys just work fine).
I tried with the “keymap” Editor - no feedback when I press one of the two keys.
I also plugged the USB-key into a Ubuntu PC - the Remote Control is detected as a “HID” device - and I see keypresses in my syslog file. But also no log entry when pressing “i” or “Context menu”.

As a backup I tried my existing HAMA MCE remote - this one also behaves strange as many function keys (e.g. “i”, “back”, “menu” results in the same key-code being displayed in the keymap editor.

Any suggestions how I get at least the original remotes to work?


The remote is RF, and light should be visible with the naked eye.

The Information and Context keys are transmitted in a slightly different manner under an alternative input path. When they are not configured properly, these are the most obvious keys that will not work as expected.

You can use OSMC’s amd64 packages if you are running a system that uses systemd (> Ubuntu 14.04 or Debian 8).

sudo dpkg -i *.deb
sudo apt-get -f install

You could also use evtest to verify that the keys themselves are functional, although it would be very surprising if for both remotes these two keys were physically broken and they were the only ones. It seems that the Vero 2 may be misconfigured. You should ensure that:

  • The USB receiver is located in the rear USB port, not the side port, as this will cause problems
  • You do not have a remote profile configured in My OSMC -> Remotes. The OSMC remote is a normal default
  • You are on the latest version of OSMC

The easiest way (if you can make a backup) is to reinstall OSMC.