Kodi 19 on Vero4k help

My EPG has stopped working (I use zap2xml). The author of zap2xml has released a newer version, but unfortunately it requires Python 3 which my current version of Kodi does not support.

I don’t know what else to do, but try upgrading to Kodi v19, but I’m having some issues with doing that. I understand I should edit /etc/apt/sources.list to include the line

deb http://apt.osmc.tv buster-devel main

Unfortunately I get a permission denied error. I’m no Linux pro (at all). I tried using chmod to change permissions of the file, but obviously if I don’t have permission to edit the file itself, I won’t have permission to change anything.

Can anyone help guide me through getting the next version of Kodi working? Or any other suggestions to get my EPG back.


if you use the command “sudo” you SuperUserDO that is run the next word on that line as a command as root.

sudo nano /etc/apt/sources.list

That should allow you to edit the file in question, in a ssh-connection to your osmc-device.

Thank you so much @joakim_s

Okay, I have Kodi 19 working on my Vero4K now. Unfortunately, zap2epg is still not working. I am in touch with the author and they will take a look at it. He did say that it seems OSMC isn’t installing the correct Python version.

I tried using an older version of zap2epg and I get an error of

dependency on xbmc.python version 2.7.13 could not be satisfied.

The current version of zap2epg requires Python 3+, which was the main reason I upgraded to Kodi 19.

Something weird is going on. I looked through all the add-ons hoping to find something about installing Python, but couldn’t find anything.

Does anyone have an idea? I’ll pass on info from the script author if I hear from them first.

osmc@vero4kp2:~$ python3 --version
Python 3.7.3

I guess this is the same version Kodi is using.

I had a similar problem to this with a different add-on. I was able to fix it by removing all of my old orphaned add ons and then reinstalling the one that was causing trouble.

I don’t know if this would be a good thing to try in your case; maybe @grahamh can tell us.

To do it, you go into Settings / System / Add Ons / Manage dependencies; then you get a list of installed add ons. Highlight each one in the list to check its status, and if it’s orphaned, press OK and then uninstall it. Keep going until there are no orphaned entries in the list. (You may have to go through the list more than once, as uninstalling one thing may orphan others).

addons not my thing, sorry.

Well, I tried uninstalling all orphaned dependencies, as suggested by @angry.sardine but, alas, this did not work.

Going back to my original problem of trying to install zap2epg, it seems that it isn’t working because it is failing to install the dependency xbmcswift2.

I try and install it manually and it tries to get it from the official Kodi repository 19.0.5 and it still doesn’t work. All I get kids the enigmatic error “installation failed” error.

Thoughts or suggestions?

It seems the problem was to do with Tvheadend. Uninstalling it and reinstalling it seems to have done the trick.

Naturally, there have been further issues, but I’ll address them in a seperate post.