Kodi crashes when selecting Music view

I take that back. It is the WMA files that cannot be played.

I just checked old forum entries and it seems someone solved the problem when using kernel based SMB mounts instead the Kodi internal way. While it is totally not clear why that is Only a OSMC propblem it would be interisting to see if fstab mount solves it.

Maybe for testing purpose do a kernel base mount (either fstab or autofs) for the folder that contains the WMA file.


I can confirm a couple things.

  • WMA files cause the issue

  • Mounting the server folder via the Kodi method will cause Kodi to crash

  • Mounting via fstab does not cause Kodi to crash. It also shows all metadata for the music. Unfortunately, this method will require the use path substitution for my shared database.

  • I did not try the autofs method but will if further testing is warranted.

fstab and autofs should have the same outcome so no need to test.

So confirms this is strangely enough an issue with the Kodi internal SMB access and even more strange seems to be only on Vero.

1 Like

Can you reproduce it @fzinken?
Is only SMB affected?

I haven’t tested myself but from a forum search seems quite clear and second link also shows that only Kodi SMB is impacted, Kodi NFS and all Kernel mounts are working.
Also seems to be working on Win10.

I can produce a potential fix, as long as people can check there are no regressions for SMB performance.


Would you be willing to test a 4.9 build?
If not – I can backport this to the current supported kernel and associated Kodi version.


I just got the Vero 4K+. Still setting it up. I am willing to test but if you can backport it that would be the easiest and best solution for me.

Thanks for the quick fix.

I will build a potential solution today and give you some instructions on how to test that fix.

Sorry – this has taken longer than expected as I am in the process of merging some other changes. I will produce a new build for you tomorrow.

I’ve now built some changes which I hope remedy this.
I would appreciate some testing. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Thanks for the quick update. I have attached new logs. The problem still exists.


Why does the image have a date of April 2nd and not the 24th?
Linux osmc4k 3.14.29-158-osmc #1 SMP Thu Apr 2 18:40:24 UTC 2020 aarch64 GNU/Linux

@wbeard52 Could you also activate SMB component specific logging like shown in the pictures below?

I enabled SMB logging. Fortunately, KODI did not crash this time.

After the crash last night, I updated my system again. The installer downloaded an additional 90MB. I checked the version between the updates and they were the same so I assumed it fully updated the first time. It looks like the second time fixed the issue.


ok, so, in summary the log in post #32 shows the problem and the log in post #34 was after you updated to staging as adviced by @sam_nazarko … and now your problem is solved with that.

No. I updated to staging in post #32. I then updated my system again and the result was #34. I don’t know if the first update didn’t fully take. It is working right now though.

The first time you ran an update (#32), you updated the kernel to 3.14.29-158. During the second update (#34), you updated the mediacenter package to 18.6.0-7.

So is this still a problem?
The solution (proposed) was Kodi only, not kernel.

The changes you made to Kodi worked for me. Thanks.