Kodi doesn't play next track automatically

Hi everybody,

I have installed OSMC RC2 on a Raspberry Pi 1B. My music and video files are stored on a NAS, which is connected via SMB. On The NAS, the directory structure of my music files is like “artist / album / title”, so I don’t use the database but rather browse in files view.
In Kodi settings (music playback), I have checked the option to play the next song automatically, but if I start any track inside any directory, Kodi will just play this single track and then finish. It will not continue with the next track. I’ve tried several different tracks in different directories, but it never worked.
Any suggestions?

Regards and thanks in advance

Have you tried creating a playlist ? I very rarely use music on Kodi but I suspect automatically playing the next track is something that only works on playlists.

No, I haven’t yet. But even if this would work, I don’t want to have to create a playlist each time I want to listen to a whole album or e.g. a special symphony or concert on a classical album.

The Kodi Wiki says: “XBMC automatically plays the next item in the current folder. For example, in Files View: After a track has been played, XBMC would automatically play the next track in the same folder”.

And that’s exactly what I’m trying to do…

But anyway - thanks for your answer!

Searching the internet, I found this forum thread which seems to cover my question. So this doesn’t seem to be a Raspberry Pi specific issue. But honestly, I don’t know what to do with the information offered there. What is lpcm? Do I need it? Where can I enable / disable it? There’s no information about it in the Kodi wiki.

Press play on the folder.

O.K., that’s what I do, if I want to listen to the whole album. But what, if the album has 8 tracks, and I just want to listen to track 5 - track 8? This really happens quite often.

Works fine for me with non-library music files. I suggest you ask on the Kodi forums as this isn’t a skin problem.

Well, this isn’t a skin forum either, it’s about OSMC on Raspberry Pi.

Oh, I had not seen this thread and starting another one that is very similar here:

I did not get any replies, so I assumed I was the only one with the problem! The thing is, I am pretty sure the “play next song” part was working fine before upgrade to RC2. @Hmuenz - was this ever working for you?

@berto Yes, that seems to be exactly the same issue. Unfortunately I can’t tell you if it was in former versions, since I was on RaspBMC until last weekend and then switched directly to OSMC RC2. But I think it did work in RaspBMC.

If you should find any solution, please let me know - so will I.

Go to settings, Music, Playback and disable queue song on selection. Used to work with xmbc and was a nice feature to create a playlist with. But since Kodi its not working as should.

@Ayub: I’ve tried this before, but it has no effect on the issue.

I switched to BubbleUPnP yesterday to control music playback. It has an option to pick any track inside an album and select “play all from here” respective “enqueue all from here” with a single tap. Works perfectly with Kodi. Of course, this doesn’t fix the bug inside OSMC, but since my NAS supports UPnP, it does exactly what I want now.

Hmm, maybe it’s not as perfect as I thought it to be. OSMC will continue playing this way, but with huge gaps between the tracks, although kodi has gapless playback capability.

Is there any change this bug will be fixed?

Sending a playlist containing several 100s of songs to a queue takes minutes…

Having the same issue. My Pi stopped working after an OSMC update, so I reloaded it and now auto play next video does not work after being enabled.

I had the same issue and solved it like this:

Buffalo NAS

Instead of using uPnP, I switched to Windows Network -> Workgroup -> Selected the network name, -> Added login credentials.

Sounds dumb, but it worked on BOTH Pis that had this issue.

Guys, now using Kodi 17.1 and have been head butting the “NOT playing next song automatically”… until today.

There is still a conflict between (Settings/Player/Music) “Play next song automatically” and the “Queue songs on selection”. Selecting both ('cus I would like to do both) prevents the next song from playing most of the time. I say “most of the time” because occasionally it’ll work for one next song but usually only once.

I can see there could be a conflict where one bit wants to play the next song but the user has already selected a new song. I guess the current code solution is getting this one wrong in some way the majority of the time.

So, to play next song automatically in Kodi 17.1 (on Pi3b in my case) ensure “Queue song on selection” is OFF. Then hope the clever guys investigate this one and get it going correctly. Would really like to access the two playing options directly at run-time (and not buried in settings) perhaps even include “A play next album” option (PLEASE!)

Using Kodi 17.1-May’17 on Raspberry Pi 3b in mostly default mode as installed with default Estuary skin. Primary control via wireless mouse/TV.

Have you tested on any other device? Are we sure this is not a kodi bug rather than an osmc bug?

The only way Kodi knows what to play next is if it’s in a playlist. “play next song automatically” just creates a playlist from the songs in that folder and starts playing from the selected song.

“Queue songs on selection” is just a quick way of adding songs to the current playlist. It’s not clear what you expect to happen when both options are checked. Also, what would be the “next album”? What’s wrong with a right click on each album and Queue item?

Anyway, this is a kodi function, not OSMC AFAICT.

A, I have Kodi installed as a stand-alone (SD Image) and as an installed application. Both on Raspberry different Pi 3B. I could select and play a track but neither would play next track.

Have only discovered the interaction of queueing the next track with play next automatically on the stand-alone Kodi Pi3b. Perhaps there is a conflict in the way the temporary play-list (next reply) is built.

As to whether Kodi or OSMC I’m not qualified to determine this. This one seems to have been around for a while perhaps pre-release of Kodi.